Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting Laptops, Portable, and Mobile Devices (https://www.badcaps.net/forum/forumdisplay.php?f=23)
-   -   Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage (https://www.badcaps.net/forum/showthread.php?t=66867)

FrozenHaxor 01-08-2018 06:12 PM

Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
2 Attachment(s)
Hello, as the title says, I have bought a broken M17x that I hope to repair. On power up there is no display and I get 7 beeps indicating "CPU Failure". It lacks a discrete graphics card, so it must have been running from the integrated Intel graphics for some time, I suspect something happened due to this.

The main CPU power conversion IC is ISL95831 which I cannot find datasheet for. I have the main motherboard schematic though (attached in this thread).

Every rail is going up, except for +VCC_GFXCORE_AXG. Upper and lower mosfets are fine, nothing is shorted, resistance with and without CPU looks okay. If you require specific measurements please tell me, I will do my best.

I have replaced the ISL95831 with no success. Another CPU was tried. BIOS Main and EC were reflashed and replaced. Behavior still identical.
Measurements of PU12:

Pin 3 - PGOODG - 1V
Pin 8 - PGOOD - 3,3V
Pin 37 - LGG - 0V
Pin 39 - UGG - 0V
Pin 40 - BOOTG - 4,8V
Pin 45 - RTNG - 0V
Pin 46 - VSENG - 0V
Pin 47 - FBG - 0V
Pin 48 - COMPG - 3,15V


Any help is appreciated. I will do requested measurements. Got access to scope and a multimeter. Thanks!

mcplslg123 01-08-2018 10:34 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Try flashing bios first.

piernov 01-09-2018 01:17 AM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Make sure the internal screen is plugged in and works ok (as well as the cable). At least on some motherboard it's required to be detected properly for the VGFXCORE voltage to come up.
Also the VGFXCORE voltage comes up when the BIOS is POSTing. So you need to make sure that you have BUF_CPU_RST# and that your BIOS is OK (the BIOS with and without discrete graphics may be different, I don't know).

dellxps15 01-09-2018 03:38 AM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
if cpu has some problem mainboard wont enable cpu voltage. try another cpu first for 7 beep error.

FrozenHaxor 01-09-2018 07:39 AM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Thank you for replies.


2 different CPUs were tried with same result.

BIOS Main and EC were both flashed onto brand new ICs and replaced, same result.

Does the same thing with the LVDS LCD connector plugged in or not.

This motherboard has MXM slot for graphics so the bios is one and the same. Intel graphics are supposed to be used during low load or if the main graphics card is missing.

Thanks for suggestion, will check BUF_CPU_RST# if I can find the signal. Couldn't find boardwiev for this.



I'm tempted to replace the HM67 PCH.

FrozenHaxor 01-09-2018 01:03 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Measured BUF_CPU_RST# at pin 4 of UC2 - 0V in standby, 1V when the board is turned on. Same voltage is at pin 2 of RC33.


http://frozenhaxor.pl/fh_as/D2018-01-09_T20-01-50.png


Any further suggestions?

piernov 01-09-2018 02:39 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Seems fine, when BUF_CPU_RST# is present, the other power rails should be OK, the PCH is initialized and the CPU is initalizing and will begin processing BIOS' instruction. Now this does not mean the PCH is ok. So yeah, maybe a PCH issue if you're sure your BIOS is OK.
But make sure that you're indeed using Sandy Bridge CPUs, as Ivy Bridge CPUs should not work on 6-series chipsets.

FrozenHaxor 01-09-2018 06:48 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
I have tried a fourth different CPU now (SR02N / i7-2670QM) while the original was SR02W / i7-2760QM, I don't have any closer match than this. It behaves exactly the same way, same rail is missing.

About BIOS... well I have tried only one that was available at dr bios. Couldn't find anything different, by description it should have fit this board perfectly.


// EDIT1:
Just found yet another compatible Sandy Bridge that I took off a donor board with exactly the same PCH on it, SR04W / i5-2430M. Fifth CPU that I have tried and same result as before. Only the GPU rail is not there.

//EDIT2:
Replaced PQ41, PQ42, PQ43, PQ44 with SiR466DP N channel mosfets. Same as before...

raihan 01-10-2018 11:38 AM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
why isl95831 pin number 3 vgateg 1v??? it should 3.3v .... check pr185 resistance good or bad?

FrozenHaxor 01-10-2018 01:26 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Quote:

Originally Posted by raihan (Post 796198)
why isl95831 pin number 3 vgateg 1v??? it should 3.3v .... check pr185 resistance good or bad?

It's 1V because ISL95831 is signalling that VR2 is not working, pulling the line down. The pullup resistor has a correct value of 1.9kOhms.

It's extremely difficult to find those resistors, none of them are marked on the laminate, and the only way to find them is to have surface layer visible traces or with diode test which is laborious.



Any other suggestions?

smali 01-10-2018 09:18 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Check voltage on isl95831 pin#23 it must be 19v on charger.also check the resistance valu of resister pr201 it is 0 ohms ..may be change the valu

FrozenHaxor 01-11-2018 01:38 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Voltage on Pin 23 is stable 19.5V

Without this voltage the other three phases wouldn't work and the CPU would not get any power at all.

FrozenHaxor 01-11-2018 06:14 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
1 Attachment(s)
Complete DC voltage measurements of PU12 (ISL95831):

Pin 1 - 3.3V
Pin 2 - 0.2V
Pin 3 - 0V
Pin 4 - 1.1V
Pin 5 - 1.1V
Pin 6 - 1.1V
Pin 7 - 3.3V
Pin 8 - 3.3V
Pin 9 - 0V
Pin 10 - 1.1V
Pin 11 - 0.9V
Pin 12 - 1.2V
Pin 13 - 0.9V
Pin 14 - When probed regulator shuts down
Pin 15 - 1.2V
Pin 16 - 1.2V
Pin 17 - 1.2V
Pin 18 - 1.2V
Pin 19 - 0V
Pin 20 - 1.2V
Pin 21 - 1.2V
Pin 22 - 5V
Pin 23 - 19.5V
Pin 24 - 0V
Pin 25 - 5.6V
Pin 26 - 1.4V
Pin 27 - 1.2V
Pin 28 - 0V
Pin 29 - 4.7V
Pin 30 - 0.4V
Pin 31 - 5V
Pin 32 - 4.7V
Pin 33 - 0V
Pin 34 - 1.2V
Pin 35 - 1.4V
Pin 36 - 5.6V
Pin 37 - 0V
Pin 38 - 0V
Pin 39 - 0V
Pin 40 - 4.9V
Pin 41 - 1.3V
Pin 42 - 0.9V
Pin 43 - 0V
Pin 44 - 0V
Pin 45 - 0V
Pin 46 - 0V
Pin 47 - 0V
Pin 48 - 3.3V


Also uploaded a datasheet that I managed to get for this regulator.

Any further ideas about what could be wrong with this thing are greatly appreciated!

pyry 01-12-2018 10:04 AM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Hello Friend
with the oscilloscope measure pin 1 of the pl20 coil and press power and see if for a moment the voltage goes up and low

hikaruichijo 01-12-2018 10:11 AM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
I have an M17x r3 running only with the integrated graphics, the 6990m died.
No problems at all because of this.
At the Dell drivers page, if you use the service tag number you can get the original BIOS whitought problems, modded bioses cause problems sometimes, I had some.

FrozenHaxor 01-13-2018 09:22 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Quote:

Originally Posted by pyry (Post 796718)
Hello Friend
with the oscilloscope measure pin 1 of the pl20 coil and press power and see if for a moment the voltage goes up and low

Hey, I have already tried that. It's like it doesn't even try, there is absolutely no change. Also probed both Mosfet gate drivers, nothing there either.



Quote:

Originally Posted by hikaruichijo (Post 796721)
I have an M17x r3 running only with the integrated graphics, the 6990m died.
No problems at all because of this.
At the Dell drivers page, if you use the service tag number you can get the original BIOS whitought problems, modded bioses cause problems sometimes, I had some.

This is clearly not my issue. I know it can work without an MXM card, but I don't have a supply line for CPU Intel graphics, hence the motherboard won't boot.


Still no idea what could be wrong with it. Tried another ISL95831 chip just to be sure, same behavior. I don't have an exact PCH on hand to do a swap, and it's an expensive part. Too expensive to replace blindly.

atsio 01-14-2018 04:13 AM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Check if PM_DRAM_PWRGD (VDDPWRGOOD), H_CPUPWRGD and PLT_RST# signals are present. Also check if the CPU voltages correspond to the CPU on board (proper vid signal from CPU). Usually the problem is with the BD82. Probably you have an HM67 you can try an HM77 (see wiki for replacement https://en.wikipedia.org/wiki/List_of_Intel_chipsets)

FrozenHaxor 01-14-2018 10:08 AM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Thanks for replying.

PM_DRAM_PWRGD is 3.3V
VDDPWRGOOD is 1.5V
H_CPUPWRGD (measured at empty resistor pad near pin 39 if JXDP1 [RC22 pin 1]) is 1V
PLT_RST# (measured at empty resistor pad near pin 46 of JXDP1 [RC25 pin 1]) is 3.3V

All 3 working CPU phases deliver 1.15V, seems right

Measured DGPU_PWR_EN and it shows 0V at all times. I'm unsure though if it isn't just for the MXM card power switchover though.


Also one thing is that my Mini PCI post card doesn't work at all in any slot, I don't know if there is some sort of incompatibility or the LPC bus doesn't work properly. I don't even get a reset or clock signals on the card.


I don't think HM77 will work, it's a completely different architecture (Panther Point) as opposed to Cougar Point. I would rather confirm the PCH fault and just order the right part.


Cheers!

atsio 01-14-2018 12:34 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
DGPU_PWR_EN is for MXM. I am proposing HM77 if it is easier for you to find one to test (it is working, I've tested multiple times) and is working with your pocessors (http://kompom.kiev.ua/articles/laptop-cpu-upgrade/). Your test card will not work because pins 17, 19, 8, 10, 12, 14 and 16 are not connected on mini connectors. You have to find the appropriate places on your board for the signals required from your tester to solder wires and test.

FrozenHaxor 01-14-2018 01:24 PM

Re: Alienware M17x R3, LA-6601P is missing +VCC_GFXCORE_AXG CPU voltage
 
Will the functionality of all peripherals be kept in working order or will such PCH cause problems and is only suitable for test? I'd imagine some BIOS incompatibility should arise. I will look around on donor boards.


I know for sure I've had an SLJ8C somewhere.


All times are GMT -6. The time now is 03:14 PM.

Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.