Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting TVs and Video Sources (https://www.badcaps.net/forum/forumdisplay.php?f=31)
-   -   Sony Bravia KDL-52S4100 No picture or Sound (https://www.badcaps.net/forum/showthread.php?t=24510)

Markw959 12-02-2012 10:21 AM

Sony Bravia KDL-52S4100 No picture or Sound
 
3 Attachment(s)
I am looking at my brothers TV he has a Sony Bravia KDL-52S4100 it has no sound or picture. When the power button is depressed the light located under the panel turns green. I removed the back and immediately checked the power supply for bad caps. There were none. I then proceeded to check all of the output voltages on the power supply. They were not perfect, but very close to nominal.

I then removed CON3 from the power supply which connects to the main board and the back light illuminated. I think there might be a problem with the main board. I have checked to just try to purchase a main board (48.71H01.31), there are none to be found. I assume this must be a huge problem for this model.

If you have any ideas on where I should start troubleshooting on the main board I would like to hear them.

I'm looking for my digital camera once I find it I will take better pictures of the boards that in question.

randtek 12-02-2012 01:00 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
The part number for the main board for this model is 185722711. I did find a few available but they are horribly expensive. (One site listed it for over $800.00 USD.) So the board replacement option is probably out.

Markw959 12-02-2012 03:01 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Yeah I have even found the set for sale used for $900.00-$1200.00 which is what they were probably going to do is buy it and sell the board for $800.00

budm 12-02-2012 07:01 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
1 Attachment(s)
Did you check the voltage and the surface mounted fuse on the T-CON board yet? This model may use error signal from T-CON board to shutdown (BL_ON) if the T-CON is dead.

bumbling808 07-13-2013 02:37 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
I know this is an old post, but I have the exact same problem. I even changed out the motherboard with no improvement. Did you ever find the problem?

capkid 07-13-2013 02:52 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by bumbling808 (Post 354740)
I know this is an old post, but I have the exact same problem. I even changed out the motherboard with no improvement. Did you ever find the problem?

When you say "motherboard", do you mean the power supply or the main board with all the inputs?

bumbling808 07-26-2013 12:08 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
1 Attachment(s)
I mean the main board. In desperation, I went ahead and ordered a replacement tcon board. Still same problem. I didn't think I needed to replace the power supply because the relay was still working during initial power up and the backlight would go on if I unplugged one of the wires that go to the main board. Should I go ahead an get a replacement power supply board now?http://www.badcaps.net/forum/attachm...1&d=1374818858

capkid 07-26-2013 12:23 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
You could have gotten a faulty replacement main board. When it comes to these Sony main boards, I prefer to have them repaired if possible rather than replacing them, or I'd buy from a highly reputable seller who offers a warranty. There are a lot of faulty main boards out there for Sonys. Where did you get the main board?

http://www.ebay.com/itm/1-857-227-11...item27d34a8e85

bumbling808 07-26-2013 12:29 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Yes on ebay, but not that listing. Here's the one I bought. Got the tcon board from the same guy. ebay listing

How can I verify which board is the problem?

capkid 07-26-2013 12:42 AM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
The link I provided was for a repair service. I had a KDL-46S4100 that did the exact same thing - no backlight until I unplugged the connector. My issue was a bad main board. I don't know of many Sonys that suffer from power supply issues. If your part numbers match and you're still within the time window for returns, you may want to consider returning the main board and using that repair service. It's a bit expensive, but people have had good results using that seller.

Edit: I actually bought my main board from Tristate Module, but it doesn't appear to be in stock for your TV: http://www.tristatemodule.com/p-2556...l-52s4100.aspx

fixitelectronix 02-15-2015 06:54 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Old topic. But I now have the same TV with the same issue. I've disconnected the above cable with the same results. I've used a voltmeter to test the voltage. There's 5 volt on the b-on when cable is diconnected but loses it when cable is connected. I'd like to attempt to repair the main board instead of replacing it because it's a little pricey and hard to find in stock. If others can repair then I'm sure I could as well. besides replacing the board, has anyone figured out if an IC is causing this issue. Seems like it's grounding out or something.

newtothis 02-15-2015 07:02 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Be warned mainboards are not easy to repair, Are you competent using a DMM, Scope and Soldering equipment? Do you have the available tools and materials?

If no to any of the above send it for repair

capkid 02-15-2015 08:12 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
There could be an issue with a BGA, in which case I'd be out.

fixitelectronix 02-15-2015 08:22 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by newtothis (Post 531027)
Be warned mainboards are not easy to repair, Are you competent using a DMM, Scope and Soldering equipment? Do you have the available tools and materials?

If no to any of the above send it for repair

Yes I have a DMM & soldering equipment. I can get my hands on an oscilloscope if needed. If I could find the proper schematic for the board it would help as well. I understand main boards aren't an easy task. I was just wondering what expertise we have available and if anyone has repaired this problem without replacing the board.

nomoresonys 02-15-2015 09:21 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
with a steady green light , you can try a firmware update, if you can find the firmware, in some cases it fixes the problem, maybe check sony's site for it.

fixitelectronix 02-15-2015 09:24 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Firmware update is out of the question. Unfortunately I'm unable to see an image on the screen to attempt an update plus screen went out while watching TV. Can't be a firmware issue.

nomoresonys 02-15-2015 09:28 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
thats the problem, everyones positive about everything, you dont need to see the screen with the kdl to do an update. bye now.

capkid 02-15-2015 09:34 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
I'll just leave this here, just in case: http://www.badcaps.net/forum/showpos...9&postcount=59

fixitelectronix 02-15-2015 09:57 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
Quote:

Originally Posted by nomoresonys (Post 531062)
thats the problem, everyones positive about everything, you dont need to see the screen with the kdl to do an update. bye now.

As much as I don't want to admit I was wrong, that fixed the set. You sir are a god. I can't believe that's all it was. I would give you a great big hug if I could. I applaud you :bow:

nomoresonys 02-15-2015 10:13 PM

Re: Sony Bravia KDL-52S4100 No picture or Sound
 
:lolsign:it happens, ASSUMPTIONS have been screwing people up since time began, including me.:noob:


All times are GMT -6. The time now is 08:04 PM.

Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.