Badcaps Forums

Badcaps Forums (https://www.badcaps.net/forum/index.php)
-   Troubleshooting Printers, Copiers, Scanners and other Imaging & Printing Devices (https://www.badcaps.net/forum/forumdisplay.php?f=39)
-   -   Panasonic NVGS50 camcorder backlight issue (https://www.badcaps.net/forum/showthread.php?t=76314)

R_J 05-14-2019 10:37 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
It must be that something else caused r1002 to go open, not the monitor circuit, what you could do is remove R1002 and see if the camera operates as before, If it does, then I suspect the problem is elsewere.
R1002 supplies the NOREG line (page74), that line also goes to (page78), IC2201 (cyl/cap loading motor drive)
This circuit with ic2201, could not have been working with R1002 open. I think this is what caused R1002 to go open and NOT the monitor circuit, the no backlight was just a result of the missing 8 volts, but the real cause could be with the mechanism overloading ic2201.
The NOREG line also supplies the lens drive (page 58)

The video drum (1 inch cylinder) should be free to spin, check that it is not stuck.

Pierre95 05-14-2019 11:46 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
I will try what you are suggesting.

Unfortunately, I am facing another issue by now: I stupidly forgot to remove the battery when I was connecting back the LCD monitor in order to see if it still displays the "Please re-operate after pushing reset button" message.

I may have blown something as the device does not work at all by now. M NOREG is missing again and I suspect IP1001 blown as the LCD flat cable has been inserted diagonally wich may have shorten M NOREG pin to ground resulting in destruction of IP1001 which I have to locate on the main C.B.A (not easy without the labels).

Pierre95 05-14-2019 04:17 PM

Re: Panasonic NVGS50 camcorder backlight issue
 
I managed to locate IP1001 and replaced it. The camcorder powers ON again, but even after R1002 removal I'm still getting the tape insertion issue.

It seems the video drum doesn't rotate at all as I do not hear the typical noise. The two mid-height located rings of the video drum are rotating freely.

I understood from you that the video drum shall start rotating while a tape is being loaded and if it does not spin up the tape will not be loaded.

R_J 05-14-2019 04:22 PM

Re: Panasonic NVGS50 camcorder backlight issue
 
You WILL get the error if R1002 is removed, It should act just like it did when you first posted, with R1002 removed there is no voltage going to the cyl/cap/loading ic. Did you even try a tape in the unit when you had the problem with no backlight on the monitor display?
I would reinstall R1002 and try and find out what is not working, Is the capstan turning when the mechanism is closed without inserting a tape?
I am guessing the tape never did load and what ever caused the problem, is what opened R1002, You saw it had no backlight and thought that was your only problem, but the missing backlight was just the result of the missing 8 volts. It was not the monitor that blew R1002 it was something else, maybe something was jamed or bent in the mechanism causing one of the motors to draw too much current.

Pierre95 05-15-2019 05:02 PM

Re: Panasonic NVGS50 camcorder backlight issue
 
I can claim for sure that when the backlight issue occured, everything was operating well (tape was loading and I was able to record/play movies on the tape). According to this and the fact that an R1002 removal or breakage would necessarily lead to no NOREG, I had a look at the schematics, and understood that NOREG and M NOREG (M stands for monitor?) are not the same power line as they have IP1003 in between them.

And what I thought was R1002 is IP1003. That all makes sense and as you suggested, the V marking most likey means it is a fuse. And yes, when IP1003 is blown, there is no backlight but NOREG, which drives the tape mechanism engines is still available.
So an IP1003 breakage can only be due to some overcurrent from the monitor as M NOREG powers only the backlight.

So R1002 is for sure OK as without it even the zoom in/out would not work.

When the mechanism is closed without a tape, not sure if the capstan is turning as the noise from loading motor and transmission overrides capstan noise. But without a tape, the mechanism closes normally.

As far as I know nothing bent in the mechanism so really strange that I'm getting this issue.

R_J 05-15-2019 09:01 PM

Re: Panasonic NVGS50 camcorder backlight issue
 
Ok that makes a bit more sense now. I guess recheck around ip1003 to make sure nothing has a solder splash shorting anything. I don't know what could be causing the issue if you only replaced ip1003.

Maybe check the solder connections on those plugs on that board in case they got loose when you opened the camera

Pierre95 05-16-2019 05:59 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
I will inspect soldering joints near the plugs involved in the tape mechanism.

As the behavior is not the same when a tape is inserted, the tape detection seems to work properly. There may be something that prevents the tape loading mechanism to load only when a tape is inserted. Is the video drum expected to rotate before the tape actually loads?

I noticed two sensors at each extremity of the loading mechanism. They are not documented, and I assume they are tape detection sensors.

There are also 4 blind holes at one corner of the DV tape, but I didn't find any documentation about it and don't know if their purpose is tape quality detection (as for audio tapes where holes allowed detecting between Ferro/Chrome/metal tapes) or if they serve for tape presence detection.

Pierre95 05-17-2019 06:08 PM

Re: Panasonic NVGS50 camcorder backlight issue
 
I did not have time to check for broken soldering joints yet, but I've got the idea to trigger displaying the error code behind the "Please re-operate after pushing reset button" message by pressing the FADE+REC buttons for 3 seconds . The displayed error code is F05 which means cylinder lock. So your suggestion about motionless video drum is most likely the cause of the error.

For now, I have to check why it does not work properly.

Pierre95 05-18-2019 06:50 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
As error F05 refers to "Cylinder Lock", I concentrated on checking continuity of the 7 wires between connector FP2202 and corresponding pins on IC2201. I checked directly on where the signals end, on the video drum itself to take into account the whole path. Unfortunately I didn't find any breakage on any of the lines (M1A, M2A, M3A, COM CYL, GND, PG+, FG+).

Maybe it could be usefull to solder small wires on the contacts attached to the video drum and check signals while the tape mechanism is operated but as I'm far from being a camcorders expert, I don't know what levels/waveforms I should check.

R_J 05-18-2019 08:04 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
You may cause more problems by trying to solder wires, Check that the flex cable going to the drum motor did'nt get damaged when you took the camera apart, If it worked before it should be easy to locate the fault.
You can put a small felt pen dot mark on the spinning part of the video drum (cylinder) and see if it changes position when you try loading a tape, if it moves at all the lines to the 3 phase motor are likely ok, the other two lines are PG (pulse generator) shows the position of the video heads on the drum, for timing. the FG (frequency gen) is for locking the speed of the video drum.

Pierre95 05-18-2019 09:29 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
Ok I will try the flet pen mark test. About the flex cable, I already checked the wiring between the motor and the IC through that cable.

What about the COM CYL signal? Is it through it that the IC checks the status of the drum. Or is the status checked by sensing current over the 3 lines phase or presence of pulses over PG line?

R_J 05-18-2019 10:08 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
COM is just common, it is likely the common connection for the motor windings. It might be used to sense over current to the motor, I can't remember.
The PG signal is mainly used for head switching, the FG is feedback to control the speed of the drum.

The last camcorder I worked on was many years ago, I worked on Sony, Panasonic, Hitachi and others. and I know they are a pain in the ass to work on, I had most of the extention cables and software and it was still difficult.

Pierre95 05-20-2019 05:18 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
That's a good point you had the opportunity to work on several brands/models of camcorders. About me, it's the first time I have to service a camcorder and I have to say the level of integration and miniaturization is absolutely breathtaking.

Pierre95 05-21-2019 05:09 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
I tried the flet pen mark test. The video heads drum changed its position but maybe it was due to the tape being pushed against the video drum while the cassette was getting to its position within the mechanism.

I checked the M1A, M2A and M3A signals with a scope. they are all of constant '0' level, but I'll retry the test by recording the signals on a longer period of time as the pulses may be transitory.

I also checked CYL ERR signal which is constant 2,8V value (don't know if it is a logical level line) and /CYL ON which is also of 2,8V constant level. Maybe it could be useful to record the /CYL ON for a longer period of time to see if a low pulse is occuring. Maybe everything is OK with IC2201 and the issue has to be investigated on IC2001 (which drives /CYL ON)...

Pierre95 05-30-2019 02:23 PM

Re: Panasonic NVGS50 camcorder backlight issue
 
2 Attachment(s)
I made recordings of the M1A, M2A and M3A and /CYL ON signals. When the tape ejection mechanism is opened/closed, we can see /CYL ON going low for 2 seconds then high again. Within the 2 second /CYL ON low period, M1A, M2A and M3A are being driven as can be seen on the first picture in purple color and zoomed on the second picture.

I also know for sure the cylinder motor is not rotating at all which seems very strange as the M1A, M2A, M3A signals seem to be OK. I also have checked the windings of the cylinder motor were OK by measuring their resistance on the corresponding pins of IC2201 and for each of the 3 windings, I read arround 4 ohms.

The FG signal which is output on pin 54 of IC2201 is constant '0' but this makes sense as the cylinder is not rotating (no frequency generated).

CYL SW is constant 7,4V. I thought it would switch similarly to /CYL ON. CYL VM is constant 8,0V which is confusing because of the PNP transistor within Q1062.

The DRIVE CLK signal is a permanent 420KHz 2V amplitude square wave signal.

Unless there is some missing DC voltage that comes to the cylinder motor from another connector, I don't see any reason the motor is not rotating.

Pierre95 06-19-2019 05:38 AM

Re: Panasonic NVGS50 camcorder backlight issue
 
After some theoretical reading about brushless sensorless motors, I realized the measurements of the M1A, M2A and M3A signals were not valid as they were referenced towards the regular D GND ground instead of COM CYL. D GND seems to be involved only for shielding the video heads drum.

I made new readings of the signals while the tape mechanism is operated by connecting scope's GND to COM CYL and I read a "perfect" 0 for all of them.

So maybe IC2201 is internally damaged at least for the drum part or there is some missing input voltage to IC2201 that supplies power to M1A, M2A , M3A.


All times are GMT -6. The time now is 05:26 PM.

Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.