No announcement yet.

A1989 EMC3214 can't boot to USB drives due to T2 but SSD can't be initialized and Macbook freezes then reboots in recovery

  • Filter
  • Time
  • Show
Clear All
new posts

    A1989 EMC3214 can't boot to USB drives due to T2 but SSD can't be initialized and Macbook freezes then reboots in recovery

    Hey folks, I'm working a 2018 13" Macbook Pro that I can't get to install an OS on.

    This was given to me by a friend who told me I could have it, if I fixed it.

    I've noticed a couple of dents on the laptop case and the touch bar doesn't have any activity lights when first turning on. When I boot up the machine, it gives a folder with a question mark. When I do eventually get to internet recovery with High Sierra, I can go to Disk Utility but I'll get errors when I try to erase the 512GB SSD. First Aid comes back with no issues. But if you linger too long on anything, the laptop will just reboot.

    I've done an SMC and NVPRAM reset as well. I even tried running Apple Configurator 2 and have gotten the laptop into DFU mode many times using an M2 Mac Mini. I even reached Step 4 of installing the OS but the process fails and nothing happens on the laptop.

    I spoke to Apple's chat support whom figured it could be the SSD, but it needed to be booked in for an appointment. I spoke to the store that was going to look at the machine, who told me that it would have a diag. fee attached, but because the laptop was taken a part, they would stop service.

    Apple's built in diag. comes back with ADP000. To be clear, I'm not a novice with computer builds and fixes, but I haven't worked on too many Apple machines.

    I even tried Checkra1n and that also won't finish in DFU.

    I have a hot air reflow station that I picked up off Amazon, a budget soldering iron and soldering gun (that can be used on cars).

    I spoke to a place that can reprogram the T2 chip and was quoted $199.99 CAD, which I'm not sure is even worth it. A replacement "logic" board is 300-400 and I could do a board swap. However, as this laptop is now mine to figure out, I thought I'd head over here and see what you folks have in mind. The place that can reprogram said that the issues I'm getting a symptoms of a T2 chip that needs to be desoldered, reprogrammed and soldered back.

    I took the back off to check for dust buildup and such; my friend told me he repasted the CPU a few months back but I haven't done a teardown to verify that. I'm suspecting that the SSD could be wrong since it fails whenever I try to format/erase. Especially as, when I go to select a startup disk to disable the T2 security, it says no Admin can be found. Same as when you try to install Mac OS. The laptop does get quite a bit toasty, but I hear that's standard for Macbook Pros.

    If you have any ideas, before I start tearing this laptop a part, please let me know.

    The good news, the screen works great, the keyboard feels nice and the touchpad is large.

    Please ask me for any further info you require and I'll see what I can get you. I do believe this has an i5 and 8-16Gigs of RAM.

    Thanks again,

    - MullySculder