Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 07-22-2018, 01:13 PM   #1
mike_drz
Member
 
Join Date: May 2017
City & State: Toronto, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 41
Default Samsung LN40B500P3F screen goes black every few seconds

Hello folks, as the title states, the TV's picture will drop to a black screen every few seconds and the picture will come back intermittently. There is audio the whole time, and it's not a signal issue, as it does this in all modes even with the signal cables unplugged.

I've opened it up and found that one of the inverter transformers was getting very toasty, it had black char marks (part QGAH02095). If I just replace this part is it likely to just fail again in the near future? Does it have anything to do with the light tubes? If I need to replace the tubes, how would I go about that, and where could I get them? Has anybody had the same issue, is it worth fixing? Pictures attached.

Any advice is welcome, Thanks in advance,

Mike
Attached Images
File Type: jpg mainboard.jpg (777.6 KB, 23 views)
File Type: jpg transformer.jpg (586.5 KB, 20 views)
mike_drz is offline   Reply With Quote
Old 07-22-2018, 02:31 PM   #2
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 4,871
Default Re: Samsung LN40B500P3F screen goes black every few seconds

I have seen this before, many times its the blue one that goes bad, sometimes it's just the transformers insulation that breaks down and it shorts, spend the $6.00 and replace it

Last edited by R_J; 07-22-2018 at 02:33 PM..
R_J is offline   Reply With Quote
Old 07-22-2018, 02:51 PM   #3
mike_drz
Member
 
Join Date: May 2017
City & State: Toronto, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 41
Default Re: Samsung LN40B500P3F screen goes black every few seconds

Quote:
Originally Posted by R_J View Post
I have seen this before, many times its the blue one that goes bad, sometimes it's just the transformers insulation that breaks down and it shorts, spend the $6.00 and replace it
Thanks RJ! I'll give it a shot, worth a 6 dollar gamble. haha I'll check other components while I wait for the part to come.
mike_drz is offline   Reply With Quote
Old 07-22-2018, 04:26 PM   #4
neilc6
Badcaps Veteran
 
Join Date: Nov 2015
City & State: BC
My Country: Canada
I'm a: Knowledge Seeker
Posts: 616
Default Re: Samsung LN40B500P3F screen goes black every few seconds

I've replaced this part before with no other issues. If you order the part from China, it could take 3-6 months to get past customs in Canada so would recommend that you purchase from a North American seller.

Would also recommend recapping the 8 larger electrolytic capacitors.

Last edited by neilc6; 07-22-2018 at 04:29 PM..
neilc6 is offline   Reply With Quote
Old 07-22-2018, 04:47 PM   #5
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 4,871
Default Re: Samsung LN40B500P3F screen goes black every few seconds

I have never had any problems with customs and parts from China, especially with cheap parts, it takes a while usually a few weeks if they use postal service.
R_J is offline   Reply With Quote
Old 07-22-2018, 04:54 PM   #6
mike_drz
Member
 
Join Date: May 2017
City & State: Toronto, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 41
Default Re: Samsung LN40B500P3F screen goes black every few seconds

Quote:
Originally Posted by neilc6 View Post
I've replaced this part before with no other issues. If you order the part from China, it could take 3-6 months to get past customs in Canada so would recommend that you purchase from a North American seller.

Would also recommend recapping the 8 larger electrolytic capacitors.
Thanks for the advice. Canada customs can be crazy at times. Sometimes I get Chinese packages in 2.5 weeks, other times it's 4 months. All the north american sellers have this at $20 vs $5 from hong kong. I might need a backup TV in that time, hah
mike_drz is offline   Reply With Quote
Old 07-22-2018, 05:01 PM   #7
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 4,871
Default Re: Samsung LN40B500P3F screen goes black every few seconds

You can sometimes speed it up: this seller https://www.ebay.ca/itm/Inverter-Tra...-/251243358376
Economy International Shipping 12-43 days
$4.00 extra for Standard International Shipping 11-22 days

I just ordered some parts from Laval QC, $60.00 shipping for under a pound envelope Puralator
Digikey, from the USA next day $8.00!
R_J is offline   Reply With Quote
Old 07-22-2018, 05:48 PM   #8
mike_drz
Member
 
Join Date: May 2017
City & State: Toronto, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 41
Default Re: Samsung LN40B500P3F screen goes black every few seconds

Quote:
Originally Posted by R_J View Post
You can sometimes speed it up: this seller https://www.ebay.ca/itm/Inverter-Tra...-/251243358376
Economy International Shipping 12-43 days
$4.00 extra for Standard International Shipping 11-22 days

I just ordered some parts from Laval QC, $60.00 shipping for under a pound envelope Puralator
Digikey, from the USA next day $8.00!
Thanks for this link, I ordered from an ebay seller that uses "speedpak" whatever that is, but customs still holds on to it just to be difficult sometimes. I LOVE digikey, I have digikey boxes all over the place here. lol

Here's an interesting link regarding crazy shipping delays, Canada Post blames Customs, and customs blames Canada post.
https://calgary.ctvnews.ca/canada-po...lays-1.3447438

Last edited by mike_drz; 07-22-2018 at 06:09 PM..
mike_drz is offline   Reply With Quote
Old 09-12-2018, 08:04 PM   #9
mike_drz
Member
 
Join Date: May 2017
City & State: Toronto, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 41
Default Re: Samsung LN40B500P3F screen goes black every few seconds

I finally got the replacement part in today. I soldered it onto the board and put the board back in to the TV. No more flickering backlight, BUT now it sounds like an electric razor due to buzzing from the board whenever the backlight is on.

It's hard to tell which transformer it is coming from, but I used a non contact style probe to narrow it down a bit. The noise is loudest in the area's highlighted in yellow. The thermistors also get pretty warm, not sure how hot those should get. I let it run like that for 15 minutes or so and tapped all the transformers with the plastic end of a screw driver. It didn't change the sound. The transformer near the middle was warm to the touch but not super hot.

Yes I know it's been a while, but thanks to my country's postal service, they didn't get around to delivering my package for months.
Attached Images
File Type: jpg mainboardMarked.jpg (783.1 KB, 9 views)

Last edited by mike_drz; 09-12-2018 at 08:17 PM..
mike_drz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 03:18 AM.
Did you find this forum helpful?