Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 07-26-2017, 04:03 AM   #1
Th3_uN1Qu3
Believe in
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 5,269
Question Sony KDL-46W5500 got backlights, no picture.

Have this TV which turns the backlights on but shows no picture. Have quickly checked voltages, may have missed some on the power supply and main but overall it looks ok. Responds to buttons, backlight brightness changes if i press the "Home" button.

Tcon fuse is good. Tcon is generating all drive voltages for the panel. Scoped some of the LVDS pins on the Tcon side, it looks to me like it's getting data from the mainboard.

Reflowed both BGAs on the Tcon, although the board underside did not show any signs of them getting hot. No change.

Would this pretty much guarantee the Tcon is bad, or should i dig deeper into the mainboard as well?
__________________
Quote:
Originally Posted by PeteS in CA View Post
Remember that by the time consequences of a short-sighted decision are experienced, the idiot who made the bad decision may have already been promoted or moved on to a better job at another company.
A working TV? How boring!
Th3_uN1Qu3 is offline   Reply With Quote
Old 07-26-2017, 04:35 AM   #2
attainteddragon
Badcaps Veteran
 
Join Date: Apr 2013
City & State: victoria
My Country: australia
Line Voltage: 240VAC 50hz
I'm a: Knowledge Seeker
Posts: 639
Default Re: Sony KDL-46W5500 got backlights, no picture.

disconnect one half of the t-con, where it attaches to the panel and see if you get half a pic and then try the opposing half.
__________________
WHY CAN'T PHILIPS USE PHILLIPS HEAD SCREWS?
attainteddragon is offline   Reply With Quote
Old 07-26-2017, 04:39 AM   #3
vinceroger69
Badcaps Veteran
 
Join Date: Mar 2012
City & State: Nuneaton Warwickshire
My Country: uk
I'm a: Hobbyist Tech
Posts: 5,301
Default Re: Sony KDL-46W5500 got backlights, no picture.

Edit! was typing this when above poster did too

do you get anyting on the screen if you remove one of the ribbon cables on the the tcon try doing this too the left and right ribbon cables.
vinceroger69 is offline   Reply With Quote
Old 07-26-2017, 05:11 AM   #4
Th3_uN1Qu3
Believe in
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 5,269
Default Re: Sony KDL-46W5500 got backlights, no picture.

No picture with either half.
Th3_uN1Qu3 is offline   Reply With Quote
Old 07-26-2017, 05:50 AM   #5
dick_barton
Badcaps Veteran
 
dick_barton's Avatar
 
Join Date: Aug 2015
City & State: Cardiff
My Country: Wales
Line Voltage: 230V AC, 50Hz
I'm a: Hobbyist Tech
Posts: 4,525
Default Re: Sony KDL-46W5500 got backlights, no picture.

Check very carefully to see if there is a small crack in the panel, perhaps in one of the corners.
__________________
Willing to help but I'm no expert.
dick_barton is online now   Reply With Quote
Old 07-26-2017, 09:47 AM   #6
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,052
Default Re: Sony KDL-46W5500 got backlights, no picture.

Are you getting data coming out of t-con
__________________
I assume no responsibility for any stupid suggestions I might post.
dskall is offline   Reply With Quote
Old 07-27-2017, 06:17 AM   #7
Th3_uN1Qu3
Believe in
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 5,269
Default Re: Sony KDL-46W5500 got backlights, no picture.

To my uneducated eye, i would say "not really", hence why i suspect one of the processors on the T-Con to be faulty, as there is definitely data going IN via the LVDS cable. If you could show an example waveform though, and which pins to scope, i would be grateful.
Th3_uN1Qu3 is offline   Reply With Quote
Old 07-27-2017, 06:26 AM   #8
tom66
Wants a Tesla
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 31,812
Default Re: Sony KDL-46W5500 got backlights, no picture.

The T-con data output is also LVDS; the purpose of the T-con is essentially to generate the row/column scan and latch signals in sync with "re-timed" LVDS data. (Hence "timing controller"). If you see no LVDS out, check the crystal on the board, and all voltage regulators/buck converters.
tom66 is offline   Reply With Quote
Old 07-27-2017, 09:05 AM   #9
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,052
Default Re: Sony KDL-46W5500 got backlights, no picture.

Hey tom66 have you thought about writing a book on plasma tv repair. Explaining how they work and troubleshooting?
dskall is offline   Reply With Quote
Old 07-27-2017, 10:58 AM   #10
tom66
Wants a Tesla
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 31,812
Default Re: Sony KDL-46W5500 got backlights, no picture.

Quote:
Originally Posted by dskall View Post
Hey tom66 have you thought about writing a book on plasma tv repair. Explaining how they work and troubleshooting?
Yes and I gave up because I didn't have the time.
There is far too much to explain.
__________________
Please do not PM me with questions! Questions via PM will not be answered. Post on the forums instead!
Free service manuals: http://www.toms-service-manuals.com/ -- 72 LED/LCD TVs, 5 monitors, 28 plasma TVs, and 2 AVR 6.1 amplifiers fixed!

2 Pioneer KURO 9G, 12 Panasonic LCD/Plasma, 1 Sony LCD, 1 NEC Plasma, 2 Yamaha HTS, 5 Sharp LCDs, 5 Toshiba LCDs, 7 Philips Plasma/LCD, 1 Hitachi Plasma, 11 LG LCD/Plasma, 18 Samsung LED/LCD/Plasma, 1 Thomson Plasma, 1 Atec LCD, 1 Hanspree LCD, 1 Xerox LCD, 1 Harwa LCD, 2 Proview LCD, 2 Hyundai LCD, 1 "Onn" LCD, 1 Grundig LCD, 1 Dell LCD, 1 iiyama LCD, 1 Acer LED, 1 Logik LCD, 1 Baird (China) LCD, 6 Bush LCDs, 22 Vestel LCDs (Best->Worst)
tom66 is offline   Reply With Quote
Old 07-27-2017, 11:08 AM   #11
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,052
Default Re: Sony KDL-46W5500 got backlights, no picture.

Maybe some short guides on specific components.
dskall is offline   Reply With Quote
Old 07-27-2017, 12:08 PM   #12
tom66
Wants a Tesla
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Student Tech
Posts: 31,812
Default Re: Sony KDL-46W5500 got backlights, no picture.

Quote:
Originally Posted by dskall View Post
Maybe some short guides on specific components.
I've already posted several.
tom66 is offline   Reply With Quote
Old 07-29-2017, 07:35 AM   #13
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 2,054
Default Re: Sony KDL-46W5500 got backlights, no picture.

Could be the tcon, shop jimmy is out of stock, some on ebay, took a quick look, saw one for 28 dollars or so, there's probably more there, just took a fast look.
nomoresonys is offline   Reply With Quote
Old 09-13-2017, 09:24 AM   #14
Th3_uN1Qu3
Believe in
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 5,269
Default Re: Sony KDL-46W5500 got backlights, no picture.

Received a new Tcon - still no picture.
Th3_uN1Qu3 is offline   Reply With Quote
Old 09-13-2017, 10:20 AM   #15
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,052
Default Re: Sony KDL-46W5500 got backlights, no picture.

I have a tv that has a separate frc. I saw data going in but nothing coming out so I replaced frc. Still have same problem. So I wonder if main board needs to send enable signal to enable board. You have checked new t-con to be good?
dskall is offline   Reply With Quote
Old 02-20-2018, 08:47 PM   #16
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 2,054
Default Re: Sony KDL-46W5500 got backlights, no picture.

Did you ever figure out what was wrong?
nomoresonys is offline   Reply With Quote
Old 02-21-2018, 10:56 AM   #17
Th3_uN1Qu3
Believe in
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Professional Tech
Posts: 5,269
Default Re: Sony KDL-46W5500 got backlights, no picture.

No, we gave it back and the boss put the replacement Tcon up for sale.
Th3_uN1Qu3 is offline   Reply With Quote
Old 02-21-2018, 12:03 PM   #18
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 2,054
Default Re: Sony KDL-46W5500 got backlights, no picture.

Ok thanks.
nomoresonys is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2018
Powered by vBulletin ®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 09:22 AM.

Did you find this forum helpful?