No announcement yet.

Samsung WD80N645OOW died mid-cycle

  • Filter
  • Time
  • Show
Clear All
new posts

    Samsung WD80N645OOW died mid-cycle

    Hi fellow lifesavers.

    I have a Samsung washer-dryer WD80N645OOW which died mid-cycle. No response to anything, completely dead.

    Checked the socket, the plug fuse, all good. Took it out to examine the boards.

    There is a relay clicking on the mainboard. Upon applying power, I can see a diode flashing on inverter board, after a while a diode on main board lits up for a split second, then I can hear a relay clicking. This repeats a few times, then everything dies completely.

    I've been trying to examine the main board, but it's a bit difficult becuse it's covered in a glue/resin/silicone - which also makes it tricky to get to the other side of the board at all. I've checked some random diodes, caps and ics by just stabbing the DMM probes through, but it's not a reliable way of working at all.

    I have close to 0 understanding how washing machines work in terms of electronics inside, what checks are being made and in what order etc. The fact that the boards are sank in resin makes it even worse.

    I have found a reliable source from where I could get the mainboard, reasonably priced. My question is: what checka can I do to determine what's actually faulty? Does anyone know the behaviour of led diodes on healthy boards? I can imagine a faulty component switching off everything, so I'm afraid the main board may actually be healthy. Out of curiosity tried to plug in the machine without the display boards (the actual LCD board and the 'buttons' pcb), acting exactly the same. My understanding is the main relay should be switched on via pressing power button (as per service manual).

    Some photos uploaded themselves twice and wouldn't get deleted when I tried. Sorry for this. Also there are some 'stab' marks visible in resin, in points where I tried to check for shorts etc. Please ignore those.

    Also there's a service manual for similar models, on last pages there are pcb layouts with mainboard looking the same, might be of use.

    Any help much appreciated. Cheers
    Attached Files

    Cannot edit post anymore, apologies for double posting.

    Just noticed the STR W6053s exposed pins are all short. According to datsheet these are pins 3, 5 and 7, and it doesn't look like a short should be there.
    Edit: found another post at this forum saying to check pin 1-5 for shorts in order to test it, they're not shorted in this case.

    Also I think there's been some heat build up around area shown on photo (cap top isn't 'shiny' like the rest of the board's caps, some browning on varistors' blue cover).
    Last edited by mrsith; 06-06-2024, 01:01 PM.


      Yeah, this case style power IC are problematic. When you do replace it, have the board around the pins hospital grade clean. Other than that it will die again after a day or so. This type of power IC is the worst style on earth.


        I have managed to take the inverter board out as well.

        If I disconnect everything from the main board, except the main relay connection and the transformer, nothing changes.

        Tried disconnecting everything from the inverter board, except main power connection - same result, relay clicking.

        If I disconnect the inverter board at all, leaving only main relay and transformer plugged into main board, nothing happens, it's dead.

        There's some signs of slight heat on the inverter board, apart from that nothing suspicious. At least on the exposed side of the board. Main fuse is fine but that's obvious with led blinking on the board.

        I'm still not sure if my is issue's caused by mainboard, inverter board or actually something connected to one of them (motor, heater, drain pump etc). I'm afraid to buy new boards in case they'll go bonkers when I connect everything to them.

        I don't really seek to repair the board (I might try but with that resin everywhere, won't be easy), just to identify which one is actually faulty. My guess is the inverter board at the moment.

        The service manual I uploaded before has a different layout of Inverter board than mine.


          Heat gun and a dental pick.


            Man, what a fight....
            Managed to take the board out. Used pliers, plastic card, a spudger and heat gun.

            Didnt find anything really suspicious, except the fuse next to main relay seems blown. Seen some heat mark next to the dry pump relay leg, but I think it's from my heat gun. Relay legs resistance measures around 155ohm, similar to another relay, so I assume it's fine.

            Ordered 5 fuses, gonna replace it and see if it blows again. If yes, gonna disconnect everything from the board to see if it keeps blowing. Hopefully gonna get somewhere this way.


              That white through hole fuse in post 4, 1st picture, top left?


                No, the black 'box' fuse on the other board. Wasn't aware it's blown until I had the board taken out of it's case.


                  Right above the blown fuse is a bridge rectifier and a large bulk capacitor. Go with you meter directly to the bulk capacitor and see if you got a short there.


                    Checked both bridge rectifier and the cap, looking good. I'm getting a stable reading (doesn't go up to infinity), but I didn't find any short on caps.

                    870ohms to be precise. Same reading on the smaller one, 400 ohms on another, again smaller cap in a different area, raising to infinity on smallest caps.
                    Last edited by mrsith; 06-09-2024, 03:39 PM.


                      If you don't have a short on the main bulk filter cap in the primary, then the mosfet etc in the primary is good. That doesn't explain the blown fuse, as they blow for a reason.
                      To the right of that bulk filter capacitor, there is another power IC on a heatsink and it looks to me that's another one of these 7 legged wonders I hate with a passion. Maybe it croaked out?
                      Last edited by CapLeaker; 06-10-2024, 03:46 AM.


                        I know, I just hope it was a voltage spike/drop in my socket that made it blow. If it was a component like dry heater or drain pump, I should be able to find out with these 5 fuses arriving tomorrow (by disconnecting stuff one after another and seeing when the fuses stop blowing). I'm just praying it's not the inverter board, wouldn't like to fight with resin again, and in case I'm not able to fix it, it's expensive af to buy a replacement.
                        But I keep my hopes high, if the inverter board itself is damaged, I'd expect the fuse there to be blown instead the one on the main board.


                          If it is the heater, that is the easiest to figure out. Re read my post 11, as I had updated it the same time you wrote this one. lol maybe it is that 7 legged wonder of power IC.


                            I've been checking it before I took the board out (checked for short between the middle front pin and the lone leg in the back, as per instructions found elsewhere on this forum on how to check that particular IC).

                            There's another, 3 pin mosfet with heatsink a bit further away that I wasn't able to reach before, I'll check it as soon as I can.

                            Edit: looks fine to me. Do you know how can I reliably test top253pn? The multifunction pin stuff confuses me a bit.
                            Last edited by mrsith; 06-10-2024, 04:24 AM.



                              Changed the fuse, connected just inverter board and main relay to main board - all good. Connected everything else - heard (probably pump) noise and the fuse blown.

                              Took another look inside the filter housing, there's a small hole with a spinning stuff inside. It was stuck. Played quite a lot with it to take out my baby's sock stuck there. Replaced the fuse, connected everything and boom - it turned on, everything looks good!

                              Gonna secure the board with a glue gun, connect the water supply and drain hose and try running a quick wash soon. I'll let you know if it manages to finish the program.
                              Last edited by mrsith; 06-11-2024, 07:01 AM.




                                  Started a program, machine took some water in and died shortly, everything took maybe 2 minutes. No water drained out. But that early within the program, would drain pump even try to start? Maybe it's the motor that died?


                                    Fuse blown again?


                                      Yeah, acting exactly the same. I'm steering toward the drain pump because of that sock that was stuck inside, but need to take it out to check resistance to be sure.


                                        Took the pumps out, checked their resistances by inserting probes into the connector. One pump (I think the drain one) measures 190.5 ohms which I think is good, the other (circulation pump?), the one that the sock was in, has just 11.8 ohms.

                                        So I guess I should replace the circulation pump. And the fuse, of course.
                                        Last edited by mrsith; 06-12-2024, 02:37 PM.