Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Audio Equipment
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old Yesterday, 01:03 PM   #161
Tecchris0516
New Member
 
Join Date: Apr 2018
City & State: New Jersey
My Country: USA
I'm a: Knowledge Seeker
Posts: 1
Default Re: Infinity PS-12 Powered Subwoofer Fired Amplifier

Hello All,

New to hear - but a huge wealth of information - I just got a PS-10 from a Garage sale - that didnt power up - Internal fuse was blown - replaced the fuse and immediately blew- did some preliminary checking and form the Q18-22 MOSFETS were bad - replaced and powered up but lasted for about 3 sec and fuse blew again - check and mosfets bad again !

I began checking some voltages and i have some questions

What is the output voltage (DC) from the bridge- i have over 100vDC
What is the voltage After the (R6-&A) and (R9& R9) I have about 10v
What controls the 15V rails - I checked C5 and i have approx 8v but on C10 it is less then 1V

I also replaced TIP31C with the orig Q18,22 to be safe
There were also a list of CAPS that were know issues - replaced all of them as well
and Q2 and Q3

And help would be appreciated
Tecchris0516 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2018
Powered by vBulletin ®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 09:11 AM.

Did you find this forum helpful?