No announcement yet.

HP 800 G4 DM Mini. Machine not in commited state!

  • Filter
  • Time
  • Show
Clear All
new posts

    HP 800 G4 DM Mini. Machine not in commited state!

    Today i have a challenge, i bought 6x HP 800 G4 DM Mini from USA, the motherboards are blank and MPM state meaning no feature byte, no serial number, no system board CT number etc.
    I talked with a HP insider and informed me that i can set the same parameters as another G4 BUT "it will not lock MPM and after 250 boots you will not be able to boot"
    He talks about a HP tool that is not public (yet) that is required in order to "lock" this particular mode and make the pc fully usable for unlimited boots, he can't do it due to legal reasons and i understand him completely.
    So what do you suggest?
    Flash the entire BIOS chip from another G4 and see what happens? Enter manually the data from another G4? Or this tool is indeed available and i'm not aware of it?

    Thank you in advance!
    Last edited by Andreasbest; 02-12-2024, 07:35 AM.

    In other words all i need is a way to lock MPM.


      Likely been reprogrammed with a vanilla BIOS. The HP BIOS Configuration utility should work on it I think as I have used it on previous EliteDesk generations such as a 800 G2. You just need to set the MPM mode to lock once you have set all of the board parameters with it.

      The motherboard will have stickers on it with most of the missing info etc. To make it easier, I dump out the contents via the utility to a txt file, edit manually, reimport, then lock MPM. You won't have a Windows key though so you'll need to source that another way.

      BIOSConfigUtility64.exe /GetConfig:"BiosConfig.txt"

      Edit in your info into the file then reimport.

      BIOSConfigUtility64.exe /SetConfig:"BiosConfig.txt"

      Lock it with

      BIOSConfigUtility64.exe /setvalue:"Manufacturing Programming Mode","Lock"


        Ok, i'll try.


          All good. Tried it and worked like a charm.
          I only changed the model from 800 G4 35W that was the dump config.txt to 800 G4 65W
          Also changed to System Board ID, i kept the ID from 65W that was the blank.
          Also noticed the Cover Sensor setting not works as DISABLED, while SetConfig get error so i change it to DISABLE and worked great too.
          Now i kept one with blank bios to upload it here, it's nearly impossible to found blank bios with MPM unlocked these days.
          Thank you for the great info!!