Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Tablets, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-04-2023, 11:36 AM   #1
mferna14
Badcaps Veteran
 
Join Date: Jun 2018
City & State: Brampton
My Country: Canada
I'm a: Knowledge Seeker
Posts: 734
Default Lenovo Thinkpad X13 Battery not charging

Hi., I am working on a Lenovo ThinkPad X13 Board # NM-C891. The unit is working fine but the battery does not charge & the laptop does not stay on with a charged battery, if I removed the Adapter cord it just turns off. I put in a new battery & when I turn on, it gives beeps & then laptop does not turn on at all. I checked the battery terminal (JDC1). The reading are as follow:
Pin 1-2 GND
Pin 3 NOT Connected
Pin 4 M_TEMP 2.2v which is very abnormal. This should change to low (GND) when good battery is attached. The volts on this pin never changes with or without the battery or the AC Power in or out.
Pin 5 DATA 3.3v
Pin 6 Clock 3.3v
7-8 Positive (No voltage at all)

M_TEMP signal is directly coming from UCE1A (MEC1663-WC_WFBGA144) .... Do you think this chip got defective. Is this chip programmable?? Can someone look into this. Thanks in advance

Last edited by mferna14; 06-04-2023 at 11:40 AM..
mferna14 is offline   Reply With Quote
Old 06-04-2023, 03:58 PM   #2
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 8,365
Default Re: Lenovo Thinkpad X13 Battery not charging

Pin #4 is driven by the battery pack. Given that both tested batteries are unable to pull this line low, review the actual battery contacts. Next, check the resistance from this battery contact on the connector back to the UCE1A chip.

That is, the MEC1663-WC is using an input pin (ADC = analog to digital converter) to detect if the battery is connected or not by monitoring the M_TEMP signal.

After the above checks, use a piece of wire to manually drive the M_TEMP pin low @ junction of PR0101 & PC0102.
mon2 is offline   Reply With Quote
Old 06-04-2023, 05:32 PM   #3
mferna14
Badcaps Veteran
 
Join Date: Jun 2018
City & State: Brampton
My Country: Canada
I'm a: Knowledge Seeker
Posts: 734
Default Re: Lenovo Thinkpad X13 Battery not charging

Our saver mon2!!! thanks for the tips I will check tomorrow... Regarding this manual drive "piece of wire to manually drive the M_TEMP pin low @ junction of PR0101 & PC0102." So as I understand One end of the wire goes to the M_TEMP battery terminal & the other end to the junction of PR0101 & PC0102!! Is it right what I have understood???
mferna14 is offline   Reply With Quote
Old 06-04-2023, 05:51 PM   #4
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 8,365
Default Re: Lenovo Thinkpad X13 Battery not charging

No. One end of the wire to the junction of PR0101 & PC0102 and the other side of the wire to ground.
mon2 is offline   Reply With Quote
Old 06-04-2023, 06:55 PM   #5
mferna14
Badcaps Veteran
 
Join Date: Jun 2018
City & State: Brampton
My Country: Canada
I'm a: Knowledge Seeker
Posts: 734
Default Re: Lenovo Thinkpad X13 Battery not charging

Ok thanks, will do this & inform you tomorrow...
mferna14 is offline   Reply With Quote
Old 06-04-2023, 11:00 PM   #6
mcplslg123
Badcaps Veteran
 
Join Date: Jun 2015
City & State: siliguri
My Country: india
Line Voltage: 220vac,60hz
I'm a: Professional Tech
Posts: 5,794
Default Re: Lenovo Thinkpad X13 Battery not charging

Pin7-8 too should show voltage as long as battery is charged(one of the batteries is new as per your post). Resistance check to GND on pin7-8?
mcplslg123 is offline   Reply With Quote
Old 06-06-2023, 09:22 AM   #7
mferna14
Badcaps Veteran
 
Join Date: Jun 2018
City & State: Brampton
My Country: Canada
I'm a: Knowledge Seeker
Posts: 734
Default Re: Lenovo Thinkpad X13 Battery not charging

Thanks for all replies, my client has taken the laptop for data backup, once he gets it back, I will troubleshoot once again & let you guys know.
mferna14 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2023
Powered by vBulletin ®
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:47 PM.
Did you find this forum helpful?