Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 02-11-2019, 04:55 AM   #21
ktmmotocross
Boardkiller
 
ktmmotocross's Avatar
 
Join Date: Feb 2014
City & State: slovakia
My Country: slovakia
Line Voltage: 230VAC 50Hz
I'm a: Hobbyist Tech
Posts: 1,750
Default Re: Acer Aspire 5742ZG working on battery only!

try to jump vin from power connector to DCIN pin
ktmmotocross is offline   Reply With Quote
Old 02-11-2019, 05:15 AM   #22
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

It is not clear to me, why i have Voltage drop on pq51 from 19.18V to 18,89V, and i have tried to change pq52 whit a New one and the same problem, 8.3V on output. Those two mosfet should be there for passing full 19.18V if they get signal on pin 4 (gate). Am i right?
Frenk7 is offline   Reply With Quote
Old 02-11-2019, 05:45 AM   #23
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

Here is what i would like to do, i would like to jump pq52 so i have 19V, 5V and 3.3V and also make jumper on PQ54 like on pictures so i have DCIN on pu17
Frenk7 is offline   Reply With Quote
Old 02-11-2019, 05:47 AM   #24
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

But i don't knew if i can have 19V on DCIN
Attached Images
File Type: jpg IMG_20190211_124012.jpg (898.9 KB, 10 views)
Frenk7 is offline   Reply With Quote
Old 02-11-2019, 08:37 AM   #25
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 834
Default Re: Acer Aspire 5742ZG working on battery only!

Quote:
Originally Posted by Frenk7 View Post
It is not clear to me, why i have Voltage drop on pq51 from 19.18V to 18,89V, and i have tried to change pq52 whit a New one and the same problem, 8.3V on output. Those two mosfet should be there for passing full 19.18V if they get signal on pin 4 (gate). Am i right?
PQ51 Drain need a Gate pass from pin 4 to by pass 19V to Source if 19V gets drop in Source 18,89V (pin1.2.3) that means your Gate is not active it should be less than 10V
techtiger is online now   Reply With Quote
Old 02-11-2019, 09:41 AM   #26
ktmmotocross
Boardkiller
 
ktmmotocross's Avatar
 
Join Date: Feb 2014
City & State: slovakia
My Country: slovakia
Line Voltage: 230VAC 50Hz
I'm a: Hobbyist Tech
Posts: 1,750
Default Re: Acer Aspire 5742ZG working on battery only!

Quote:
Originally Posted by Frenk7 View Post
But i don't knew if i can have 19V on DCIN
read page 8 again
ktmmotocross is offline   Reply With Quote
Old 02-11-2019, 10:04 AM   #27
shandybass
New Member
 
Join Date: Nov 2018
City & State: Nuneaton
My Country: United Kingdom
I'm a: Hobbyist Tech
Posts: 16
Default Re: Acer Aspire 5742ZG working on battery only!

The gates of PQ51/52 aren't being driven low because the gates of PQ59 and PQ63 aren't being driven high.
This is due to pin 1 of PU18A being low @ 0.03v. This pin should be around 4.3v as pin 3 is greater than pin 2.
I'm a bit long in the tooth now so maybe my theory isn't right but I would be checking for a s/c PD1 or replacing PU18.
shandybass is offline   Reply With Quote
Old 02-11-2019, 11:30 AM   #28
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

Ok, here is follow up on my problem. I found that PR296 resistor is not 10k but 80k, after replacing it i finaly have 19V on PQ52 and 19V, 5V and 3.3V powers rails . But that would be to easy, now i have new problem.
When i power it up with battery it gives me charging light, but after some time screen gets dots and start download flicker, white line appears. It all disappears when i pull put the charger.
If i start the laptop on charger only i get strange white Linea on top and black on the bottom od the screen.

Thanks you all for your help, you have help me a lot, and gided me in right direction. If you have any ideas on new problem please tell me.
Attached Images
File Type: jpg IMG_20190211_180833.jpg (2.33 MB, 10 views)
File Type: jpg IMG_20190211_180353.jpg (598.6 KB, 15 views)
Frenk7 is offline   Reply With Quote
Old 02-11-2019, 12:42 PM   #29
shandybass
New Member
 
Join Date: Nov 2018
City & State: Nuneaton
My Country: United Kingdom
I'm a: Hobbyist Tech
Posts: 16
Default Re: Acer Aspire 5742ZG working on battery only!

PR296 which is connected to pin 1 of PU18A ?
I'm surprised that it going to 80k alone would account for such a low on pin 1 though. What voltage do you have there now?

Would help also if you could take and post hi-res pictures of the board where the liquid damage has occurred.
shandybass is offline   Reply With Quote
Old 02-11-2019, 01:08 PM   #30
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

Now on Pin1 i have 3.14V. I am sorry to say, but someone has clean the motherboard and i can't also see where was the damage, i only see a bit on vent...
Here are the pictures, they were taken with cellphone...
Attached Images
File Type: jpg IMG_20190207_132332.jpg (1,009.3 KB, 12 views)
File Type: jpg IMG_20190207_132355.jpg (992.6 KB, 10 views)
Frenk7 is offline   Reply With Quote
Old 02-12-2019, 02:40 AM   #31
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

I was looking at the board and i think i found something (look at the pictures). Mosfet is not shorted to the ground but i think it is not good. And it is on VGA rail so maybe that is my problem with screen
Attached Images
File Type: jpg IMG_20190212_093354.jpg (816.8 KB, 10 views)
File Type: jpg IMG_20190211_220712.jpg (2.09 MB, 9 views)
Frenk7 is offline   Reply With Quote
Old 02-12-2019, 03:11 AM   #32
shandybass
New Member
 
Join Date: Nov 2018
City & State: Nuneaton
My Country: United Kingdom
I'm a: Hobbyist Tech
Posts: 16
Default Re: Acer Aspire 5742ZG working on battery only!

You're barking up the wrong tree Frenk7. According to post #28 your problem is only present when both the charger and battery are connected or charger alone. If everything is fine with only the battery connected then all circuitry after ac/dc switching is ok.
It appears you still have a power problem.
My OpenBoardView won't open your board file for some reason which would make life a little easier but I'll take a look at the circuit again shortly and see if I can help at all.
shandybass is offline   Reply With Quote
Old 02-12-2019, 03:33 AM   #33
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

I use this, it is free
http://boardviewer.net
Frenk7 is offline   Reply With Quote
Old 02-13-2019, 06:20 AM   #34
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

I think it is a graphic issue, i don't know if it was like this before, but now when i start the laptop i get white screen (see the 1. photo) and then normalno screen telling me i have no hard drive and the picture stays normal, if i plug in the charger that weird issue starts (see other photos)
Attached Images
File Type: jpg IMG_20190212_212740_1.jpg (267.2 KB, 9 views)
File Type: jpg IMG_20190212_213220.jpg (710.1 KB, 8 views)
File Type: jpg IMG_20190212_213158.jpg (1.36 MB, 8 views)
File Type: jpg IMG_20190212_213145.jpg (590.6 KB, 7 views)
Frenk7 is offline   Reply With Quote
Old 02-13-2019, 11:39 AM   #35
shandybass
New Member
 
Join Date: Nov 2018
City & State: Nuneaton
My Country: United Kingdom
I'm a: Hobbyist Tech
Posts: 16
Default Re: Acer Aspire 5742ZG working on battery only!

Is it the original adapter and have you got another one you could try? Just wondering if you are perhaps getting excessive ripple.
Did you have any problems identifying PR296 when you replaced it? Your boardview appears to be a mirror image of your actual board.
shandybass is offline   Reply With Quote
Old 02-13-2019, 03:07 PM   #36
Frenk7
Member
 
Join Date: Jan 2019
City & State: Zagreb
My Country: Croatia
I'm a: Knowledge Seeker
Posts: 25
Default Re: Acer Aspire 5742ZG working on battery only!

Yes, boardview is mirror image, but on boardviewer software on view, you can flip board. The problem was that pq77 mosfet, i replaced it and now laptop is working fine.
Thanks for your help!
Frenk7 is offline   Reply With Quote
Old 02-13-2019, 03:36 PM   #37
shandybass
New Member
 
Join Date: Nov 2018
City & State: Nuneaton
My Country: United Kingdom
I'm a: Hobbyist Tech
Posts: 16
Default Re: Acer Aspire 5742ZG working on battery only!

Well done Frenk7
shandybass is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 12:21 PM.
Did you find this forum helpful?