Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Tablets, and Mobile Devices > BIOS Requests ONLY!
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-06-2021, 03:57 AM   #1
Zilicon
Member
 
Join Date: Nov 2020
City & State: Osun
My Country: Nigeria
I'm a: Knowledge Seeker
Posts: 53
Default Lenovo Thinkpad T480 BIOS and EEPROM request

please I need BIOS for T480 and the EEPROM for 20L6 type of board.

and here is the board number: ET480 NM-B501
Zilicon is offline   Reply With Quote
Old 01-06-2021, 10:06 AM   #2
bobotheklown
New Member
 
Join Date: Jan 2021
City & State: Seattle. WA
My Country: United States
I'm a: Knowledge Seeker
Posts: 8
Default Re: Lenovo Thinkpad T480 BIOS and EEPROM request

Also looking for these files (lenovo t480), anybody had luck with the lenovo instructions in the sticky? going to try that soon...
bobotheklown is offline   Reply With Quote
Old 01-06-2021, 10:15 AM   #3
LenBios
Senior Member
 
Join Date: Jan 2018
City & State: Hon
My Country: Ker
I'm a: Knowledge Seeker
Posts: 119
Default Re: Lenovo Thinkpad T480 BIOS and EEPROM request

Please try...
Attached Files
File Type: zip (4)BIOS Lenovo ThinkPad T480 NM-B501 Bios.zip (8.57 MB, 306 views)
LenBios is offline   Reply With Quote
Old 07-18-2021, 12:46 AM   #4
Zilicon
Member
 
Join Date: Nov 2020
City & State: Osun
My Country: Nigeria
I'm a: Knowledge Seeker
Posts: 53
Default Re: Lenovo Thinkpad T480 BIOS and EEPROM request

Quote:
Originally Posted by LenBios View Post
Please try...
thank you so much @LenBios. i'm very sorry that it took me a while to thank you. I was off for a very long time.
thank again pappy
Zilicon is offline   Reply With Quote
Old 12-05-2021, 01:31 PM   #5
Alexsandr4772
New Member
 
Join Date: Sep 2021
City & State: Belgorod
My Country: Russia
I'm a: Knowledge Seeker
Posts: 18
Default Re: Lenovo Thinkpad T480 BIOS and EEPROM request

Quote:
Originally Posted by LenBios View Post
Please try...
Your BIOS is most likely damaged. Read the firmware again and upload it
Alexsandr4772 is offline   Reply With Quote
Old 02-25-2022, 02:25 AM   #6
grzechqu
New Member
 
Join Date: Mar 2018
City & State: Przeworsk
My Country: Polska
I'm a: Knowledge Seeker
Posts: 5
Default Needed T480 BIOS cleared ME

The BIOS is OK, but the computer works only at 0.40GHz, maybe clearing the ME will solve the problem.

Motherboard NM-B501 Rev: 1.0

Anyone able to help?
Attached Files
File Type: zip Bios T480_.zip (6.06 MB, 35 views)
grzechqu is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:22 AM.
Did you find this forum helpful?