Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Members List Social Groups Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 11-25-2011, 02:25 AM   #1
RobPhotoPro
Learning Fast
 
RobPhotoPro's Avatar
 
Join Date: Jun 2011
City & State: Charlotte, North Carolina, U.S.A.
Posts: 29
Question Samsung HP-R4252 42" Plasma No Picture

No picture symptom on this plasma TV suggested a problem with Y-sustain board and Y-buffers. It features problematic LJ92-01203A / LJ41-02761A and LJ92-01202A / LJ41-02760A with 6 ICs. I checked out Coppell Repair Blogs and some threads here, that helped me to identify shorted buffer and a shorted power FET.

I replaced a shorted lower buffer and one bad IXTA36N30P power fet under the heat sink on the Y-sustain board.

The TV still powers up and stays on with NO picture. I even tried connecting one buffer at a time - no half picture. Checked the voltages, Vscan is present and stable with Y-sustain connected or disconnected. Nothing is getting hot, both Y-sus and Z-sus are making a normal "hum". Ve for Z-sustain present and stable.

I checked the Y-sustain board's main IC - no shorts. The fuse was also fine.
Output voltages to Y-buffers are around -71V.

Looks like something else might go bad on Y-sustain board. Any ideas?

All suggestions very appreciated!
Thanks,
Rob
RobPhotoPro is offline   Reply With Quote
Old 11-25-2011, 07:52 AM   #2
PlainBill
Badcaps Veteran
 
PlainBill's Avatar
 
Join Date: Feb 2009
City & State: Phoenix, AZ
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Hobbyist
Posts: 7,013
Default Re: Samsung HP-R4252 42" Plasma No Picture

Forget about it. That -71 volts indicates there is another problem. As indicated, these are problematic. By the time you replace all buffer ICs and the Y-sustain you have spent the major part of the cost of a new 42" plasma TV.

PlainBill
__________________
For a number of reasons, both health and personal, I will no longer be active on this board. Any PMs asking for assistance will be ignored.

Never be afraid to try something new. Remember, amateurs built the ark. Professionals built the Titanic.
PlainBill is offline   Reply With Quote
Old 11-25-2011, 09:46 AM   #3
RobPhotoPro
Learning Fast
 
RobPhotoPro's Avatar
 
Join Date: Jun 2011
City & State: Charlotte, North Carolina, U.S.A.
Posts: 29
Default Re: Samsung HP-R4252 42" Plasma No Picture

Well, I was lucky to get a replacement lower Y-buffer board from E-bay for $ 36.00, shipping included. The upper buffer tests okay.

So the only problem seems to somewhere on Y-sustain board. I replaced the shorted FET and the main IC tested okay. What else does usually go bad on this board? How can I test the board to make sure, the problem is not somewhere else? Too bad I don't have a similar, working TV to test the boards.... :-(

Thanks,
Rob
RobPhotoPro is offline   Reply With Quote
Old 11-25-2011, 12:15 PM   #4
RobPhotoPro
Learning Fast
 
RobPhotoPro's Avatar
 
Join Date: Jun 2011
City & State: Charlotte, North Carolina, U.S.A.
Posts: 29
Default Re: Samsung HP-R4252 42" Plasma No Picture

This is, how I tested the main Y-sus IC:

http://blog.coppelltvrepair.com/2011...s-ipm-for.html

My IC passed all tests okay.
RobPhotoPro is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:32 PM.


Badcaps.net Technical Forums 2003 - 2014
Powered by vBulletin ®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Did you find this forum helpful?