Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 08-14-2019, 11:29 AM   #21
kca
Badcaps Veteran
 
Join Date: Feb 2016
City & State: Morgan Hill, CA
My Country: United States
I'm a: Knowledge Seeker
Posts: 388
Default Re: LG 60PB6900 ~ Relay with cyclical, repeated clicking upon startup

Thanks, R_J. That's what I figured. I did a little comparison shopping in the last hour and found a board that was/is an exact match for only $57 (shipping + tax included), so I decided to buy that one and go from there. Figured the extra $27 over the cost of the repair kit was worth it to save time. Should be here in about a week. I will keep you and anyone else reading this updated. I am going to check over the buffer boards even more carefully now, in order to make sure as best I can that nothing blew out on those and caused the Ysus failure in the first place. Not common in this model, according to the video I linked up above, but still could have happened. If you have any further insight as to what I can and should test while I wait for the new Ysus to arrive, please let me know. Thank you very much.

~ kca
kca is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 06:00 AM.
Did you find this forum helpful?