No announcement yet.

Badcaps - Explore our electronics repair forums

  • Filter
  • Time
  • Answered
  • Show
  • New Topics
Clear All
new posts


    Friends, PRIME H510M-K R2.0 motherboard requires bios software. I do not have the original file. I would appreciate it if you could share it.
    See more | Go to post

  • Xiaomi Mi 15 Pro - R15-6050A2940901 Schematic

    A while ago I got hold of a Schematics but was full of Chinese watermarks with embedded links and crap.
    Also Page 6 was mangled with overlapping diagrams of the charging circuit from Page 5.
    Same messy version going around the internet on multiple sites.

    I've brushed, cleaned and polished this up, and publishing it here.
    Perhaps I'm the only one who's done this.

    I'm sure you'll all appreciate this cleaned up version....
    See more | Go to post

  • Allview phone charger A248-NB2-501000

    I've got an old phone charger which cannot hold voltage, it goes from 5V to 4V the fault only seems to happen when charger has been on for a while e.g. when warm. Fault happens when high current or low current is being drawn from charger. I've checked capacitors for capacity and ESR and I think they are still good, I've even replaced a cap to get better ESR. Fault still happens it goes slowly from 5V to 4V then interrupts power and restarts. Because it performs on high current (0.67A) and low current (20 mA) the same way I'm guessing it's not the caps but more likely the switching IC. However...
    See more | Go to post

  • alirafee
    started a topic BIOS dell precision 5530

    BIOS dell precision 5530

    dell precision 5530 la-g341p
    need clear bios
    thank you all!
    vga not detect​
    service tag 5XQZVT2...
    See more | Go to post

  • Phil916
    started a topic Marshall Emberton

    Marshall Emberton


    i'm looking for information as schematics about this speaker for a repair
    power up and charge ok but give no sound and no bluetooth detection, reset is uneffective to solve problem.
    seems to me a bluetooth card problem (no sound at startup and not visible for pairing)
    i failed finding any information about it.

    [ATTACH=JSON]{"alt":"Click image for larger version Name:\tIMG_20240222_024651.jpg Views:\t0 Size:\t392.0 KB ID:\t3221029","data-align":"none","data-attachmentid":"3221029",&q...
    See more | Go to post

  • macbook A1707 Board (820-00928) (Board Schematic 820-00281) U3905 BGA Corroded pin 21

    I'm trying to get this A1707 macbook working. There was some liquid damage under U3905 and corrosion around the Tantalum capacitors C3502 C3504.
    Removing the U3905 (PN66VEU3-A101D004) shows that the pad is somewhat damaged. I'm not reading continuity between pin 21 and the filter cap C3919.

    Researching that part shows that its an NFC chip, which makes me go huhhh? And Why??? Why does a macbook even have and NFC chip, and if I just leave it out will it cause issues?

    If I can get away with just replacing the tantalum caps and ignoring the NFC chip that would be...
    See more | Go to post

  • Sony KD 49X8307C

    Hi again all. Picked the above model up a couple of days ago. Information was that it just stopped working all of a sudden. Was from a nice house with no kids or pets and no reason to think it's suffered impact damage.

    Working my way through it. I get a flashing silver light on the front which indicates an attempt to start?? Then it turns off and doesn't attempt to reboot.

    Had the back panel off and with the plugs disconnected to the backlights, on the connectors I'm getting 63v DC on CN 6801 and 4.0v DC on all pins on CN 6802. All except the not connected ones I should...
    See more | Go to post

  • MacBook Pro 13" 2020 A2289 - Board issue

    Customer brought in computer for data recovery, was successful in retrieving data however it would not let us reinstall or load an operating system. Did a DFU RESTORE and that was successful, computer launches and goes into internet recovery, however it crashes once it hits 3/4 the way and starts over again. It did this when we tried to load recovery before the DFU restore and assumed maybe a restore would resolve this issue, sadly it does not. Removed the logic board and inspected the board and it does not have any signs of visible liquid damage or any signs of burns or faulty chip areas....
    See more | Go to post

  • Brand name and Model Type for Lenovo error 2202 product name is invalid

    Info for error 2202 LenovoThinkPad models and type

    Extract from ThinkPad Maintenance Utilities Configuration File
    plnsrv.ini Version 1.01

    Some information that may be useful

    There must also be missing models, add them to the list if you know of any
    [brand name]
    20B1=ThinkPad Edge E445
    20B2=ThinkPad Edge E545
    20BC=ThinkPad Edge E145
    20BM=ThinkPad X140e
    20BL=ThinkPad X140e
    20A3=ThinkPad X230s
    20AH=ThinkPad X230s
    20AK=ThinkPad X240s
    20AJ=ThinkPad X240s
    See more | Go to post

  • Bios bin for DAY 11AMB6E0 REV:E

    I need bios bin for this
    See more | Go to post

  • Asus S510U no display (board X510UN)

    Asus S510U no display (board X510UN)

    Replaced ram.
    Flashed bios.

    Same issue.No display.Any technical idea would be highly appreciated.
    No caps lock, Num lock lighting and no display to external monitor

    PL8901 - 12.67
    PL8701 - 5.142
    PL8702 - 3.392
    PL9301 - 1.371
    PL8101 - 0
    PL8102 - 0.871
    PL8103 - 0.871
    PL9103 - 0.917
    PL9101 - 0.916
    PL8302 - 1.072
    PL8601 - 1.233

    PLT_RST - 3.381
    PM_RSMRST - 3.306
    PM_RSMRST_PCH - 3.006
    DRAMRST - 0

    consumption with/without...
    See more | Go to post
    Last edited by Vesko356; Yesterday, 11:06 AM. Reason: Attached boardview removed and replaced with link

  • r9 280 no picture and shorts coils

    Hi, I have this graphic card no image, when power on fans spin but I measured and has only +12v from PCI and power 12v both connectors. also +5v linear present, 3v3 from PCI present. MCU is cold, then I I tried measure again and on coils, 1.5V,1v0, 1.8v, on mcu 0.8v all present and mcu slictly warmed up. After that I tried to put on motherboard and still no image, but now also all those voiltages missing again , only +12v present and 5v
    Then I measured (see image in red colour) and all those coisl has dead shorts, 0 ohm. I thing when first measuring voltage (I didnt check resistance) was...
    See more | Go to post

  • Acer Aspire E5-574-52RH - black screen

    Hi everyone,
    I have this strange behaviour with Acer Aspire E5-574-52RH, i5 6200U, intel graphics, DA0ZRWMB6G0 Rev G, model ZRW.
    Laptop came in for a SSD upgrade, took everything apart to install the SSD.
    Everything started after modifying BIOS settings to boot UEFI instead of Legacy.
    Laptop works fine, i installed windows 10 and drivers/updates, everything works ok(when it works)
    The black screen problem is random, maybe 5 out 10 times, laptop remains with the black screen, no image

    Symptoms are:
    - random black screen after displaying Acer logo...
    See more | Go to post
    Last edited by Vesko356; Yesterday, 05:59 PM. Reason: Attached bios removed

  • Sintez
    started a topic bios dell optiplex micro 3060

    bios dell optiplex micro 3060

    dell optiplex micro 3060
    The IPCFL-CG platform, after replacing the SR405 chipset, turns on and is fully operational only after resetting the bios battery.
    If you turn it off, it blinks twice or once in orange and does not turn on, you need to reset the battery again..
    Help me clear the region in the bios firmware, please.
    Service Tag 5XGNNR2
    Express Service Tag 12907273214
    See more | Go to post

  • Please help Asus ROG G713QY-K4005T (SN: MANRKD03332840C), motherboard ref: G713-6050A3254002-MB-A01 (A1) Bios

    Hi there,
    I have an Asus G713QY that won't boot. The machine fire up to a black screen, no post but everything seems to check out on the board. I believe the motherboard needs the bios reloaded but I can't find the bios file. I've looked on the [URL=""]Asus website[/URL] but what is available for download is the .exe to run in windows (which won't help). I've tried to unzip it but can't see the bios file that I need. Can anyone share the bios file for an Asus ROG G713QY-K4005T (SN:...
    See more | Go to post

  • Resistor value - Motherboard dumbledo - 6050a2985501

    Help me determine the resistor value
    laptop hp 17-ca
    Motherboard dumbledo - 6050a2985501

    Thank you

    Help me determine the resistor value
    laptop hp...
    See more | Go to post


    Hi, for anyone who can help me, I'm looking for Dump for SAMSUNG TV Q43Q60TAUXZT - FOR MEMORY 25Q40CLSP - motherboard BN41-02756B DATE 2019-12-17 MODEL - BN41-02756 - DFVC2025 BN41 - 02756B-000. I read the memory and it is completely blank.
    Sorry if I write badly but I use the Italian English translator, please be patient, thanks.​...
    See more | Go to post

  • 820-00840 PP3V3_S5 shorted

    Hi all,

    i am working on macbook pro A1708 820-00840 water damage around USB iC U3200 and PMIC U7800. took out U3200 and U7800 but still has shorted on PP3V3_S5.
    i tried to inject 1V and 3.5A but can not detect the heat.

    any suggestion will be appreciated.
    See more | Go to post

  • I have a Lenovo Thinkpad E420 and I have the following problem, let's see if someone can help me or help me, thank you

    The Notebook turns on correctly as long as it has not been used for the last 20 Minutes. While it is on everything works correctly, but if I turn it off and want to turn it on again it does not turn on. I have to wait more or less 20 minutes and then it turns on again. Does anyone know where to start checking to see where the problem is? Thank you so much!

    See more | Go to post

  • Dell AC adapter - 1 wire protocol. How to initiate to check if adapter works.

    Hi all. Trying to troubleshoot issues with the Dell Laptop power supply (a lot of info here). Now I am waiting for a DC power Jack, as there is a loose contact. Want to check if the ID line of the adapter works - I have given abt 3.2 V to this line through the voltage divider, but can't see any signal on the oscilloscope. Same with the 100500% working AC adapter as well. How to initiate 1-Wire protocol transmission? As I understand, the circuit in the AC adapter should send a package for a while as soon as the supply comes to the SPID line. How to initiate this transmission correctly without...
    See more | Go to post

  • Rca rnsmu6540 65 4k led tv

    Hello this tv the led lights stopped coming on tv works just no lights if I take flashlight to it I can see screen and it has sound. Thanks assuming I'm looking at a bad led stopping the circuit or?
    See more | Go to post

  • I need chip identification help. ab238p1n692-65e4

    I am new to the forum and may be posting to the wrong area. I did do a search and it may be that I should be searching for a smaller set of numbers to identify it. I am a newbie into electronics repair as a hobby. Does anyone have a good source for obscure integrated circuits and component's in general. This is one of the 2 chips I am looking for. ab238p1n692-65e4. I think it could possibly a Bluetooth chip? I have a Bluetooth shower speaker the has less and less battery life. The Battery checks good. I wanted to replace the Leds with a non emitting diode or a resister, I to save the charge....
    See more | Go to post

  • MacBook Pro 13'' M2 A2338 get 5V 0.01-0.02a does not boot. 820-02773

    I bought this laptop with water damage. There is corrosion on the logic board (ive included some pics). I removed the cr634 capacitor that was burnt on the ppbus line. The pad is still shorted to ground. I'm not sure how to proceed from here, any suggestions would be greatly appreciated.

    The other areas ive included in the pics are the backlight circuit....
    See more | Go to post

  • tvtimmy
    started a topic BN44-00515a


    I have one from a pn64e533. I replaced the 3BR2565JF and the two 18n50 (used 22n60 that I had on hand). I now have standby, vs, va, and 15 volt rails. When I reinstall it the relay just clicks. Swapped it out with a good power supply and the tv works. What do I have to do now to repair it?
    See more | Go to post

  • Nitro AN515-55 not booting

    i am currently trying to fix an ACER Nitro AN515-55. Originally the 19V was shorted by the VCCGT Powerstage. After removing it the short was gone. I tried replacing the mosfet and also booting the system without it and a Monitor connected to HDMI. In both cases the system lights up, cpu, gpu and pch get warm but there is nothing on the screen. Is it possible that the short took out the igpu and the cpu at the same time or is the system just unable to boot without an functioning igpu. The system also didn't boot with a functioning mosfet for the igpu rail. Resistance on VCCGT is 4 ohm,...
    See more | Go to post

  • BigTroll
    started a topic The last AM4 upgrade

    The last AM4 upgrade

    Back in 2017 for the launch of Ryzen I bought an Asrock x370 Killer SLI/AC and Ryzen 1700 motherboard combo from newegg, it was a good deal but I didn't think it would last me so long. I originally had 16gb ram a EVGA GTX 970 latter the 970 was replaced with a EVGA GTX 1080 and finally a Nvidia Geforce 3080 Founders Edition. the CPU went from a 1700 to 2700x, 3900x and now finally to a 5950x and I got 32gb ram. I still cant believe how long AM4 lasted and the 5950x was $348 with tax included from antonline using the 20% presidents day coupon. I got a ID cooling 360 water cooler on her and shes...
    See more | Go to post

  • Macbook Air A1466 No light on charger

    Hi everyone,

    I have a MacBook Air 2015 (820-00165-02) that had some liquid damage. It was working for a while only on Adapter power, but that stopped working. Thunderbolt (external display) did not work. There was a bit of corrosion on the board, and I've cleaned that up. The adapter light does not turn on when I plug it in.

    PP3v42_G3H: 3.42V
    PPBUS_G3H: 0V
    PPDCIN_G3H: 16.4V

    A lot of this is new to me, but following the schematic, I think that Q7180 is not producing the PPDCIN_G3H_INRUSH voltage, which in turn drives...
    See more | Go to post

  • XBox 360 All Polymer Capacitors

    As the title says, Xbox 360 Polymer Capacitors, replacing all on a Kronos 1 revision board.

    I went over a thread here (Xbox 360 with blown caps) and gather some extremely useful knowledge!

    If I have things right, I can replace them TO

    x9 : 1500uF 16V 10x20mm
    TO: 470uF Nichicon FPCAP R7

    x2 : 820uF 6.3V 8x12mm
    TO: 2.5V 820uF Nichicon FPCAP R5

    On this revision, there are other 820uF polymer capacitors for GPU/CPU - I'll be replacing those anyway with the above FPCAP R5

    What's a good replacement for the smaller...
    This can be anything from game consoles to arcade games to anything else that doesn't really fit into any of the above categories. When starting a new thread, please put the make AND model of your device in the thread title. Also be VERY descriptive of your issue, that way you'll get the best answer possible!
    See more | Go to post

  • Al-Umar
    started a topic HP Pavilion - 17-ab405na

    HP Pavilion - 17-ab405na

    Please repair my bios file not display: Here is the info
    HP Pavilion - 17-ab405na
    Board Number: DAG37LMBAD0 REV
    S/N# 5CD8239TF7
    ProdID 4CK41EA#ABU...
    See more | Go to post

  • Vizio M55-E0 won't power on - fuse intact

    Vizio PSLL241206M inside an M55-E0.

    Here's an odd one. Why in the world do I have 76 VAC on the fuse when I have measured 115 VAC on the input power cord? Does this point to something known or simply another SMPS problem I need to run down?...
    See more | Go to post

  • trying to repair imac motherboard model A1311 (late 2009)

    Hello everyone,
    Some time ago I acquired an imac computer model A1311 that does not boot (motherboard ref. 820-2494-A).
    The power supply is working properly (I have two), it delivers the 12V on pin 4 of the power connector (PP12V_S5).
    As I have the schematic diagram and the boardview, I have made a series of measurements, obtaining the following results:

    PP12V_S5 -> 12V
    3V3REG_VCC -> 3.12V (something low?)
    PP5V_S5_LDO -> 0.02V
    3V3REG_VCC -> 0.0066V

    I have also measured the resistance to ground on the coils, and I can't find...
    See more | Go to post

  • Please help Lenovo G713QY (SN: MANRKD03332840C), motherboard ref: G713-6050A3254002-MB-A01 (A1) Bios

    Hi there,
    I have a motherboard that needs the bios reloaded but I can't find the bios file. Can anyone share the bios file for an Asus ROG G713QY (SN: MANRKD03332840C), motherboard ref: G713-6050A3254002-MB-A01 (A1). Thanks
    See more | Go to post

  • Marantz SR5007 USB firmware update image

    Does anyone happen to have the latest firmware for the SR5007? Marantz took their update server down and customer support refuses to provide the image to flash over USB. They offered to let me pay a service center to do the update (has to be over USB).

    See more | Go to post

  • djazeiry
    started a topic H5 Zener diode

    H5 Zener diode

    hello guys ,
    i'm a beginner in electronics and laptop repairs, i had a diode that was blown on my face it's coded as H5 (ZD5245BS2) , i wanna know how come it blown on my face , and secondly is there any equivalent zener diode i that i can replace it with, thank you.
    See more | Go to post


    I am sorry i wants ok bios without serial no
    I recieved only motherboard with bios error. dont have serial no etc. Perhaps somebody already changed its bios, i am not confirm. No display. Ram Volts, processor volts, 3v+5v all are ok
    clock is ok, ossilation is ok. processor worns, fan spins but no display
    Board code: PW-CI7B75A-MA
    Attaching available bios backup with motherboard picture
    Regard, thanks in advance...
    See more | Go to post

  • Toshiba EM131A5C-BS microwave oven- noisy EE16 2.7 mH inductor

    This poor microwave oven was purchased by my former employer in 2019 (it's a 7/2018 build) and lasted for about 3 months before making a terrible noise when in use. I determined that it was the main transformer and contacted Toshiba. They asked for a picture of the cord cut in half and the serial number, and then credited my boss' credit card. Rather than sending it to the e-waste, I bought a transformer on eBay and thought I'd try flipping it. Discovered that used microwave ovens aren't worth much but in for a penny, in for a pound as they say. It sat in my basement getting kicked and shoved...
    See more | Go to post

  • Fireballcz
    started a topic ASUS Pro Q670M-C BIOS

    ASUS Pro Q670M-C BIOS

    ASUS Pro Q670M-C BIOS anyone? Many thanks in advance!
    See more | Go to post

  • dihcar84
    started a topic dell precision 7680

    dell precision 7680

    please help

    after trying to unlock it ,i had 3 amber 4 white,mybe bad copy with rt809

    See more | Go to post

  • Any Schematic with an AMD Ryzen 5 CPU is needed

    Hi, please can anyone help with a schematic of any motherboard with an AMD Ryzen 5 R5-3500 CPU. I need the Ryzen 5 CPU pinout or Datasheet if possible. I still won't mind if it is Ryzen 3 or Ryzen 7 as well.

    See more | Go to post

  • Elitebook x360 1030 G2 laptop goes off when about to boot to windows

    A customer brought to Elitebook x360 1030 G2 the issue is when the machine is about to boot to windows it goes off. i have flash both the bios and EC but still same and i need help please
    See more | Go to post

  • Hitachi 43HAK6150 No Booting

    A friend of mine gave me this VESTEL crap, since it was not working.
    But actually it is working - the backlight is ON, but it seems like the firmware is bricked or gone bad - I have no info if it was flash, but as i assume it is not.
    I checked the voltages of the PSU board - they seems OK, also checked the voltages on the Mainboard - it has power to USB ports(tried to put a USB stick but it is not recognizing it, the stick led don't light up, but i can charge my phone from it).
    Since this is an eMMC flashchip can it be bad ? In order to flash it i will also need...
    See more | Go to post

  • HP 800 G4 DM Blank BIOS dump with MPM UNLOCKED!

    Hello hello!!!
    Today i bring you something unique, i bet not even the most expensive paysites have it, UNLOCKED MPM bios for HP 800 G4 DM plus it's blank! Meaning no serial number, no featurebyte, Build ID, no SKU number etc.
    With it you can set all info or setting you desire and after some reboots for testing, to lock MPM.
    I used another fully working G4 to extract BiosConfig.txt and then i just edited the model ( from 800 G4 35w to 800 G4 65W and i also kept the System Board ID from the BiosConfig.txt of the blank board.
    It will probably work on SFF and MT sizes and also...
    See more | Go to post

  • Lenovo E15 / NM-C421 Charging Problem

    Hello guys,

    I have a problem with charging circuit in this laptop. Unit came with no power at all (USB-C meter was cycling turning off and on). I discovered that when I unplug battery laptop works on charger only. So after few measurements I found shorted 1st dual mosfet AONY36324. Unfortunately i was not able to order exact this one, so i ordered AONY36352 which i believe is the similar one. Now the problem is, when i connect battery and charger USB-C meter is not cycling anymore, it starts charging (reading 20V@2,7A) but after few seconds it is going down to 20V@0,20A and laptop...
    See more | Go to post


    I would like your opinion about this particular television.
    For a few days now, horizontal lines appear at the bottom of the screen every 3 seconds.
    I have the impression that it is the T-con board.
    See more | Go to post

  • Help need bios for bdl51 LA-D771P REV3.0

    Help need bios for bdl51 LA-D771P REV3.0 for hp 15-ba009dx ....
    See more | Go to post

  • How can I test coil whether it is really broken or not?

    I have old game console which have connected to 220v outlet by previous owner and It is not able to turn on.

    I checked continuity of fuse in PSU unit with a multimeter which is shown in the below picture with a orange circle around it, and It seems that fuse became open circuit.
    [ATTACH=JSON]{"alt":"Click image for larger version Name:\ Views:\t0 Size:\t2.30 MB ID:\t3219795","data-align":"none","data-attachmentid":"3219795","data-size":"full","title":""}[/ATTACH]...
    See more | Go to post

  • fujitsu lifebook a3511 bios dump Needed

    The laptop itself downloaded the BIOS and after the update does not start. If anyone can help. Please help I can't find it anywhere​...
    See more | Go to post

  • Corsair HX 750W - DC Leakage at 12V Output Rail in Standby Mode

    Just received it today from a friend.
    Auto shutdown by the supervisor IC because of an under voltage condition with 12V output rail (dropped to 10.5V)

    The same rail also does this when the PSU is in standby mode.


    The leakage keeps climbing at a steady rate but slowing down when it reaches over 800mV or so. I didn't measure exactly at what value it stopped or if it's even stopped at all.

    What could have caused that?

    First time I have seen such behavior.

    3.3V and 5V rails don't have...
    See more | Go to post
    Last edited by прямо; 02-19-2024, 11:22 PM.

  • Bad BN44-0809A power supply board.

    I started troubleshooting the samsung 75inch tv board, that died suddenly one day. I disconnected the power supply board and noticed that the fuse is blown. Replaced the fuse and new fuse is blown immediately. Any next steps to troubleshoot?

    The board is BN44-00809A

    Is there a schematic for the board? I read online that rectifiers might be bad, How to check if the rectifiers are good?
    See more | Go to post

  • MaC_ToC
    started a topic Zbook 15 G6 Need files for chip

    Zbook 15 G6 Need files for chip

    Hello everyone,

    I need your help. I have a Zbook 15 G6.
    I made a request to unlock my bios here 1 year ago.
    Everything went fine but since then the bios is no longer updating.
    So I decided to take some time to flash the update.
    But like an idiot I unsoldered and flashed the wrong chip! (Yes, I know you can say that, I'm a real idiot).
    And of course I have no backup!
    Can anyone help me if they have the original file?

    The chip is an MXIC x202-27
    [ATTACH=JSON]{"alt":"Click image for larger version Name:\t2024-2-19...
    See more | Go to post

  • alex39t
    started a topic Bios Lenovo thinkbook 15 g2 request

    Bios Lenovo thinkbook 15 g2 request

    I want a new dumps for this model the motherboard is La-k052p my s/n is MP28SL1M for 20VE00U7GM please help
    See more | Go to post

  • SarCleric
    started a topic Looking for a dump of EC and MAIN

    Looking for a dump of EC and MAIN

    Laptop: Lenovo 13s-iml
    Board: BM5918_Rev1.3A
    EC: Lenovo IT5576E-128
    Flash: AH1929 25B127DSIG

    I'm looking for a dump of EC and MAIN. Moreover, the EC firmware is the most interesting at the moment.​
    See more | Go to post

  • BIOS request for Evoo gaming laptop EG-LP10-BK

    Please, I need working BIOS firmware for the above PC. The board number is GK5MP5X MB V1.0

    Background information: The PC at first, started with the screen going blank when HD video is played or whenever a game is launched. the laptop will not turn off, it will be working in the background but with no display. However, it worked very fine with 720p screen, but no display with 1080p screen. 1080p screen came with the PC origininally.

    I checked the continuity of the display cable, all were ok.

    meter readings when 1080p screen was installed:
    See more | Go to post

  • motherboard short - lenovo thinkbook 13s-iml model name 20rr

    hi , my motherboard is short after ram change. here is some pics. i think this component is short. thank you...
    See more | Go to post

  • industrial PC, CPU, BIOS

    Hello all

    i have industrial pc which doesn't power on, it has ATOM cpu on it

    the voltages are ok, but the system is frozen, doesn't post

    if i dump BIOS is there a way to checked it if it's OK? or should i just order new CPU?

    BR and thanks for answers

    See more | Go to post

  • Boardview/Schematic_LAIKA-6050A3156701-MB-A01

    [B]Hello dear forum participants,[/B]

    I am kindly looking for the mainboard:

    (Laptop: x360 Pavilion HP-14-dw0156ng)[/B]

    the boardview (possibly also the schematic and EC.bin)

    Thank you very much for your efforts.

    [B]Kind regards
    [B]Hello dear forum participants,[/B]

    I am kindly looking for the mainboard:

    (Laptop: x360 Pavilion HP-14-dw0156ng)[/B]

    the boardview (possibly also the schematic and EC.bin)
    See more | Go to post

  • Need bios for Hp 15-cs DAG7BMB58C0 rev C

    Hi, Need bios for Hp 15-cs2032nm DAG7BMB58C0 revC

    See more | Go to post
No content found
Show More
  • Filter
  • Time
  • Show
  • New Topics
Clear All
new posts
Please log in to your account to view your subscribed posts.

What's Going On?


There are currently 290095 users online. 4264 members and 285831 guests.

Most users ever online was 1,196,122 at 03:31 PM on 12-14-2023.

Badcaps Statistics


Topics: 100,658   Posts: 1,250,754   Members: 480,539   Active Members: 16,030
Welcome to our newest member, poiiop.