Announcement

Collapse
No announcement yet.

Latitude 7420 - BIOS repair possible?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Latitude 7420 - BIOS repair possible?

    Hi,
    I finally got managed to desolder my BIOS-Chip and create a dump.

    My Latitude 7420 won't post, but keyboard-backlight and fans are on.

    Mainboard: GDC31 LA-K371P Rev:3.0(A02)
    BIOS-Chip: Winbond w25r256jv
    Service-Tag: 9SWP2J3

    Can you please have a look at it and maybe fix it?
    Attached Files

    #2
    Originally posted by Mirenia View Post
    Hi,
    I finally got managed to desolder my BIOS-Chip and create a dump.

    My Latitude 7420 won't post, but keyboard-backlight and fans are on.

    Mainboard: GDC31 LA-K371P Rev:3.0(A02)
    BIOS-Chip: Winbond w25r256jv
    Service-Tag: 9SWP2J3

    Can you please have a look at it and maybe fix it?
    do you have image on external monitor/tv via HDMI or on USB KEYBOARD CAPS LOCK LIGHT BLINK when you press caps lock on keyboard

    Comment


      #3
      Originally posted by qayyum786 View Post

      do you have image on external monitor/tv via HDMI or on USB KEYBOARD CAPS LOCK LIGHT BLINK when you press caps lock on keyboard
      Nope, no image on external monitor. Capslock on internal keyboard lights up permanently. External Keyboard is not recognized.
      I already tried flashing BIOS with a bootable USB-Stick (solution from Dell support page) and NVRAM-Reset. But nothing works

      Comment


      • Vesko356
        Vesko356 commented
        Editing a comment
        It's under highest Dell support service plan "Pro Support Plus" until 26 SEPT 2024. It's best to contact the manufacturer first for a warranty repair before you've made things worse by trying to do it yourself.

      #4
      your posted bios is 65 mb it should be 32 mb only

      Read and post again
      Last edited by qayyum786; 02-04-2024, 05:53 AM.

      Comment


        #5
        Originally posted by qayyum786 View Post
        your posted bios is 65 mb it should be 32 mb only
        Yes, I also suspected that my BIOS file is much too large.
        But it is exactly what I read out of the chip using the programmer.

        So is this maybe a mistake of my programmer or is something really wrong with my BIOS?

        Comment


        #6
        Vesko356 The Laptop was gifted to me. So I had no proof of ownership and unfortunately no longer contact to the gifter.
        Do you think I can try to contact the support despite it?

        Comment


        • Vesko356
          Vesko356 commented
          Editing a comment
          Yes of course. At least try, it's possible they won't ask you for any papers, besides the warranty support level is highest possible as I said, and the location of the warranty is exactly in Germany.

        #7
        Originally posted by qayyum786 View Post
        your posted bios is 65 mb it should be 32 mb only

        Read and post again
        His bios is repeated at bit 2000000h.


        ----------------------------------------------------------------------------------------------------------------------------------------------------------
        All donations to Badcaps are welcome.
        Become a Badcaps supporter
        >>>>> click on this link to donate <<<<<
        Thanks to all supporters.
        ----------------------------------------------------------------------------------------------------------------------------------------------------------‚Äč

        Comment


          #8
          Originally posted by hoaca388 View Post

          His bios is repeated at bit 2000000h.
          yes you are right i got it

          Comment


            #9
            Service-Tag: 9SWP2J3

            Try
            Attached Files
            Last edited by qayyum786; 02-04-2024, 08:17 AM.

            Comment


              #10
              Thanks a lot!!!!

              I flashed the chip with your file and soldered it back onto the board.
              But now the laptop seems completely dead. Only the LED lights up in red as long as I press the power button.
              No charging and no reaction.
              Maybe I shorted/damaged something while soldering (I will check this tomorrow)

              P.S: I am a she and not a he

              Comment


                #11
                My Latitude 7420 won't post, but keyboard-backlight and fans are on, power led is white and stays white no flash codes, was working until it did a bios update and hasn't come back up.
                Can some one please help me clean the file. Thanks

                Mainboard model no is GDC31 LA-K371P Rev:3.0(A02)
                BIOS-Chip is a Winbond w25r256jv
                Service-Tag: J2JRCB3
                Attached Files

                Comment


                  #12
                  Originally posted by devp62 View Post
                  My Latitude 7420 won't post, but keyboard-backlight and fans are on, power led is white and stays white no flash codes, was working until it did a bios update and hasn't come back up.
                  Can some one please help me clean the file. Thanks

                  Mainboard model no is GDC31 LA-K371P Rev:3.0(A02)
                  BIOS-Chip is a Winbond w25r256jv
                  Service-Tag: J2JRCB3
                  here use this
                  Attached Files

                  Comment


                    #13
                    Thanks Rex98 all up and running again

                    Comment


                      #14
                      Dell Latitude 7420 won't post, but keyboard-backlight and fans are on, power led is white and stays white 3amber and 6 white flash codes, was working until it did a bios update and hasn't come back up. 2 were given to me but both in same state semi power up but no display.
                      Can some one please help me clean the file. Thanks
                      Mainboard model no is GDC31 LA-K371P Rev:3.0(A02)
                      BIOS-Chip is a Winbond w25r256jv
                      Service-Tag: 57QT9K3
                      Attached Files

                      Comment


                        #15
                        Hi I tried but get the following errors and have done several reads from the chip and they are all the same size byte by byte.

                        Any Suggestion or help please, have looked on line and cant find any solutions.


                        errors:
                        Error: BPDT partition SMIP (0x34A43F - 0x4E943F) overlaps with Unknown (0x34A440 - 0x4FB440)

                        Error: BPDT partition SMIP (0x34A43F - 0x4E943F) overlaps with SMIP (0x34A441 - 0x50B441)

                        Error: BPDT partition SMIP (0x34A43F - 0x4E943F) overlaps with SMIP (0x34A448 - 0x55B448)

                        Error: BPDT partition SMIP (0x34A43F - 0x4E943F) overlaps with RBEP (0x482000 - 0x49A000)

                        Error: BPDT partition SMIP (0x34A43F - 0x4E943F) overlaps with FTPR (0x4DA000 - 0x61F000)

                        Error: BPDT partition SMIP (0x34A43F - 0x4E943F) overlaps with PMCP (0x49A000 - 0x4DA000)

                        Error: BPDT partition Unknown (0x34A440 - 0x4FB440) overlaps with SMIP (0x34A441 - 0x50B441)

                        Error: BPDT partition Unknown (0x34A440 - 0x4FB440) overlaps with SMIP (0x34A448 - 0x55B448)

                        Error: BPDT partition Unknown (0x34A440 - 0x4FB440) overlaps with RBEP (0x482000 - 0x49A000)

                        Error: BPDT partition Unknown (0x34A440 - 0x4FB440) overlaps with FTPR (0x4DA000 - 0x61F000)

                        Error: BPDT partition Unknown (0x34A440 - 0x4FB440) overlaps with PMCP (0x49A000 - 0x4DA000)

                        Error: BPDT partition SMIP (0x34A441 - 0x50B441) overlaps with SMIP (0x34A448 - 0x55B448)

                        Error: BPDT partition SMIP (0x34A441 - 0x50B441) overlaps with RBEP (0x482000 - 0x49A000)

                        Error: BPDT partition SMIP (0x34A441 - 0x50B441) overlaps with FTPR (0x4DA000 - 0x61F000)

                        Error: BPDT partition SMIP (0x34A441 - 0x50B441) overlaps with PMCP (0x49A000 - 0x4DA000)

                        Error: BPDT partition SMIP (0x34A448 - 0x55B448) overlaps with RBEP (0x482000 - 0x49A000)

                        Error: BPDT partition SMIP (0x34A448 - 0x55B448) overlaps with FTPR (0x4DA000 - 0x61F000)

                        Error: BPDT partition SMIP (0x34A448 - 0x55B448) overlaps with PMCP (0x49A000 - 0x4DA000)

                        Error: Skipped EFS partition at 0x464FF0, unrecognizable format!

                        Warning: Could not find any File System Platform, assuming 0x01 (ICP)!

                        Warning: Could not find any File System Dictionary, assuming 0x0A!

                        Warning: Data in Engine/Graphics region padding, possible data corruption!

                        Note: Multiple (4) Intel Flash Partition Tables detected!

                        Comment


                          #16
                          Originally posted by devp62 View Post
                          Dell Latitude 7420 won't post, but keyboard-backlight and fans are on, power led is white and stays white 3amber and 6 white flash codes, was working until it did a bios update and hasn't come back up. 2 were given to me but both in same state semi power up but no display.
                          Can some one please help me clean the file. Thanks
                          Mainboard model no is GDC31 LA-K371P Rev:3.0(A02)
                          BIOS-Chip is a Winbond w25r256jv
                          Service-Tag: 57QT9K3

                          try flash my post # 12

                          Comment


                            #17
                            Hi Rex98 that brings the machine to life but it won't recognise the ssd and flashes 2 amber and 8 white leds. This was a working machine prior to the failed bios update. Any suggestions

                            Comment


                              #18
                              hi Rex98, can you please fix this dump.
                              symtoms
                              1-laptop does not turn on with this original bios.
                              2-service tag is : 7QRTLN3

                              thanks in advance
                              Attached Files

                              Comment


                                #19
                                Originally posted by malangg View Post
                                hi Rex98, can you please fix this dump.
                                symtoms
                                1-laptop does not turn on with this original bios.
                                2-service tag is : 7QRTLN3

                                thanks in advance
                                try post #12

                                Comment


                                  #20
                                  Originally posted by rex98 View Post

                                  try post #12
                                  Already tried, but laptop turned on, worked, after restarting, dead now.. not coming on..

                                  Comment

                                  Working...
                                  X