Announcement

Collapse
No announcement yet.

Thinkpad Tablet 2 (2679) No Power

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Thinkpad Tablet 2 (2679) No Power

    Hello,

    I recently got my hands on a batch of Thinkpad Tablet 2 that a local business was throwing away. They all have the same issue, no Power.
    I do have a working one that i also took and the first thing i did was trying to power it without the battery being inserted.
    It seems that these tablets do not work unless the battery is in (my PSU is 5V5A so i doubt it's a current thing, probably design).
    I thought i'd be lucky so i took the battery from the working one and i tried it in 2-3 of the broken ones, but no luck, still no power.
    The current draw is 18mA while just plugged that spikes to 120-150mA while the power button is pressed, stays there for couple seconds, then back to 18mA.
    As they all have the same "no power", i thought that historically there could have been a bad bios deploy, so i took the working one, extracted it's bios with an CH431A flasher and flashed it on one of the broken ones, still no luck.
    I started probing around, the 5V is correctly transferred from the separate power board to the motherboard, and while plugged in, something that looks like a buck converter is whining, probing the diode it seems to turn the 5V into 3.8V.
    I also checked and while plugged in the battery pins are correctly at 3.7V, so technically charging should be working.
    I tried fingering around but nothing gets hot in the slightest, not even barely warm, moreover nothing looks burned, scorched or inflated, everything looks immaculate.

    At this point i'm out of ideas, i do not own an oscilloscope, just a variable power supply with current measuring and a multimeter.
    Any other troubleshooting steps i can look into?
    Does anyone by chance have a schematic and board file for this motherboard?
    The motherboard has a Lenovo FRU code of 04X4644
    https://pcsupport.lenovo.com/us/en/p...splay/as-built
    Thank you for your support.
    Attached Files

    #2
    I've got relatively many of them, would it help my cause if i promised a free one to whoever helps with a final solution? 😁
    As long as you're based in Europe i can ship you one if you help me get them working.
    Also i'd like to clarify that i am fixing them not for profit, i don't plan to sell them but to give them to family and friends, together with some embedded applications i have in mind, their processor is still quite nice.

    Comment


      #3
      See attached. Does this boardview look like yours?

      Click image for larger version

Name:	tablet2_bv.png
Views:	58
Size:	213.1 KB
ID:	3305964

      Comment


        #4
        I cannot believe i made such mistake in the title, i just noticed the "2679" while it should be "3679". But anyway the detail URL is correct so the board pictures are too.
        The picture you posted looks about right i'd say

        Comment


          #5
          Ok. How are you powering this thing? Do you have the official power supply recommended for use for this model?

          Download the boardview file from here:

          Thinkpad Tablet 2 Boardview file - Badcaps
          Last edited by mon2; 07-09-2024, 02:01 PM.

          Comment


            #6
            The working one powers without issue from the battery, charges well with a 5V5A charger i have (although original one is 5V2A).
            The working one does not power with AC only it needs to have a battery inserted, even if flat.

            The non-working one(s) do not power from AC, even with a fully charged known-good battery inserted. If a battery is inserted, it will charge (the device will draw 5V 1.3A-ish) but no signs of life other than the coil whine from what looks like a boost circuit (working unit has this whine too)

            Comment


              #7
              Since you have a good working unit, this is gold. You will need to carefully measure the voltage to ground of each and every inductor (boardview will be with 'L' = coils) onboard. Make a table and location of each such inductor. Each inductor = power supply rail.

              Then pick any of the non-working units and compare their inductor voltage to ground. Stop if you have a mismatch. An alternative option is to remove all power / remove battery. Meter in resistance mode. Measure the resistance to ground of each inductor of the good sample board.

              Then compare to the non-working board. If there is a short on any of the power rails, the power supply and board will shut off due to an excessive current draw. Too much of a load condition. This 2nd approach is safer since no voltages to short with the meter

              Comment


                #8
                Thank you for your reply, i tried checking every inductor on both boards and i have to say the difference in resistance to ground is pretty big.
                Code:
                Component,Working,Broken
                L2001, 324, 70
                L2401, inf, inf
                L2101, 280, 31
                L2604, 991, 1084
                L1904, 290, 32
                L1901, 1328, 1388
                L1902, 1328, 1390
                L1903, 287, 33
                OTHER SIDE
                L2105, inf, inf
                L2503, 757, 757
                L2501, 1305, 1340
                L1906, 21000, 25000
                L1101, 6.5, 6.5
                L1102, 740, 345
                i also noticed that the mask layer is a different shade of green, but the components are all exactly in the same position everywhere so i don't think its 2 different revisions.

                All the inductors with "big dip" in resistance are those connected to the V_1P80_VCCAON rail, would it be correct to guess that the short is here somewhere?

                Thank you
                Attached Files

                Comment

                Working...
                X