No announcement yet.

ThinkPad T14s Gen 1 boot loop (instability)

  • Filter
  • Time
  • Show
Clear All
new posts

    ThinkPad T14s Gen 1 boot loop (instability)

    Hi all, I'm looking at what seems to be a nice puzzle

    A ThinkPad T14s Gen 1 that stopped working more or less a month after the warranty expired. I tried to boot both Windows 10 and Debian 12 from a USB stick. In the first case, the system just reboots after showing the Windows logo for a few seconds, while I'm able to see the Linux kernel crashing if I boot the second in failsafe mode.

    Interestingly, some times (unfortunately it's difficult to replicate) I manage to boot into Debian 12 live. Moreover, the kernel doesn't seem to crash always at the same point during the boot process. But more or less between 52 and 56 seconds after the kernel initializes.

    The system always reliably POSTs and starts the bootloader (e.g. GRUB). I even managed to successfully upgrade the BIOS to the latest available version using the Lenovo USB bootable image. Unfortunately, it didn't make any difference.

    I ran a couple of passes of memtest86 and the system is rock solid, no errors whatsoever.

    I also tried to remove both SSD and Wi-Fi card without any notable differences, and disconnected from the board fingerprint and smartcard readers, trackpad, and one of the USB A ports that lives on a separate board. Still no changes.

    Taking some measurements on the board, I noticed that VCOREs range from about 1v to 2.2v, while the VDDCR_SOC (here on the schematics excerpt) it's more within 0.76v and 0.9v. VCORE-SOC is at 10.9v

    Could such low voltage cause the instability I'm experiencing? The APU is a Ryzen Pro 5.

    In general, I have the feeling it could be something linked to the SOC part of the APU (e.g. I/O) that causes the system to crash as soon as it gets activated during a regular boot process.

    Considering the amount of dust I found in the heat sink, I suspect the APU overheated over the years. I was also considering to attempt a reflow as last try.

    Any ideas?

    Do not recommend a reflow of the CPU / APU.

    Does SAFE MODE on Windows work for you?

    Reflash the bios and test again.


      Yeah, reflowing the APU is definitely not my first pick, more like a last resort measure. I'm trying anything else before that

      I can't get to boot Windows in safe mode. The system reboots just after a few seconds it starts booting. Same for Debian. However, the system remains stable if I simply leave it idle on GRUB. The issue raises as soon as the full boot process starts (drawing more current). That's also why I'm trying to troubleshoot the SOC power stage to make sure it looks good.

      Edit: I already tried two different BIOS versions (i.e. the original one and the latest from Lenovo), but no difference.


        Very conveniently, I found out that Lenovo offers a couple of diagnostic options

        Interestingly, I'm able to run the UEFI version and the laptop completes the extended test (about 6 hours of checks) with flying colors. However, the Linux version of the diagnostic software doesn't boot. The system reboots a few seconds after the boot starts, just after GRUB. So exactly like when I boot Win10 or another Linux distro.


          Very very likely Its a APU fault. Reballing normally dont fix it.