First and foremost, Welcome to the Badcaps Capacitor Search Engine & Forums!

New members that have activated their accounts have limited access to certain features of the site until established. Members with zero posts have no access to the private messaging system. Also, members with zero posts may not edit certain profile attributes, such as signatures. New members also may not create new threads. However, new members with zero posts have full access to all technical information contained on this forum, and that also includes attachments (images and files that other members have uploaded), and new members that have activated their accounts are free to post replies to existing threads. If you wish to create a new thread, the fix is simple! All you need is ONE post to be able to have full unrestricted access, and that can be simply posting an introduction of yourself or say hello in THIS THREAD. This may seem a little strange, but it helps keep spam and abuse curved. Please note, that it may take up to one hour from your first post for the limits to be removed. If you make a post and don't immediately see the restrictions gone, be patient. The promotion system updates every hour.

Please complete your profile after making your first post, with your name, locale, and other info. It's nice to know members on a first name basis, and know where they're from. Makes for a much friendlier environment!

Posting rules for this forum will be STRICTLY enforced by myself as the owner/administrator, and my moderator crew. IS A BUSINESS!!! If you are a servicer, service center, or vendor of any kind in the computer/capacitor industry, you are NOT permitted to advertise, link, promote, or plug your business on this forum in ANY way! NO EXCEPTIONS!! This includes asking for "donations" in exchange for BIOS passwords or tech advice for anything! If I see you doing that, your post will be edited or deleted, and you warned. If it happens again, you will be banned. The only exceptions are the references to the companies quoted in the FAQ which the administration have added for the convenience of those around the world who have difficulty to source caps for their repair.

This also includes using this forum's private message system to solicit business. Members, if you receive a PM from anyone offering repair services or components, please alert me immediately! Myself or any of my moderators, will never private message a user soliciting business, for, or any other servicer/vendor. If you PM me about repairing your device, I will reply and take care of you, however, I will not message you first.


Posting rules:

This forum was created to be a technical support forum primarily for the do-it-yourselfers who choose to repair their own boards. Any and all technical questions are welcome!

1) Please use the SEARCH feature!! Your question may have been answered in another thread! Please search first and see if it has!

2) When posting a technical question, be as detailed as possible in your thread. The more information we have about your specific problem, the better we can answer your question.

3) Please use COMPLETE sentences, punctuation, and grammar! Nobody is perfect, hence, a spelling error on occasion is no biggie. However, posts/threads that are unreadable will be deleted. This includes any and all forms of 'ebonics', leet, chatroom jargon, and 'text message' shorthand and slang. This forum is not a chatroom/text message, please use full words and complete sentences.

4) Keep discussion on topic!! DO NOT HIJACK THREADS! It's easy to do (I've done it myself a few times...) Lets try to keep it down to a minimal!! If you have something really off topic, that's what the lounge is for!

5) Keep things civil! There will be no tolerance for flaming, bashing, hateful remarks, racial remarks, adult material of ANY kind, and so on.

6) THE LOUNGE RULES! The lounge is a place for off topic chit-chat! If you post something that might be considered questionable or something you don't want kids to see, or something you can't view at work/school, etc, please label that thread *NWS* or NOT WORK SAFE in the thread title as a warning. The Lounge is NOT moderated, anything is welcome... Feel free to post rants, jokes, cars, hot women (remember the NWS warning in the title), or just about anything within reason. It's an open forum! Please refrain from participating in political topics if you have thin skin, they can get heated sometimes!! Remember that we have members here from all over the world, with many different views and cultures. Political debates can turn really ugly, and really fast, and if they degrade to personal attacks and useless banter/bashing, moderator action will ensue. I want this forum to be a safe haven for technical discussions from all walks of life, so lets keep off topic discussions civil and friendly.

7) Spamming and spammers will NOT be tolerated or accepted in any way, shape, or form! Spam bots are instantly and permanently banned, and their threads deleted! The mod crew is really quick to zap spammers, we typically pop them before they even get to post. This also includes regular members as well. be courteous and not post spam. This includes links to off-site information that's not relevant to the thread at hand. Do not plug other websites, forums, or businesses in your signatures. You may do so in a thread if the off-site link you're posting is relevant to the topic, but otherwise, don't do it. If you see a thread which clearly a spam bot posting that we have not removed yet, DO NOT click any links in it!! Simply click the 'report bad post' button, and it'll be taken care of, usually within minutes.

8) Account removals & closures: Since no personal information is given in the creation of your Forum account, requests to remove and/or delete accounts will be declined. Any requests for removal of threads & posts you created will also be declined. The reason is the missing posts can/will leave threads incomplete and fragmented. For the threads to be of help to others later on, information can't and won't be missing. However, if you inadvertently posted personal identifiable information in a post (such as an email address, real name, or phone number), please contact a staff member. In those cases, the post may be edited or removed, at the staff members discretion.

That's about it for the rules, the setup here is pretty loose. However, if you're caught violating any of the rules above, here's what will happen:

First offense: Warning by me or a moderator
Second offense: Banning for 1 day
Third offense: Banning for 3 days
Fourth offense: Banned permanently.

If you do something really dumb, or are just a troll, I will skip the warning and the temporary banning, and ban you permanently!

The rules are pretty cut and dry... However, if you have any questions about this policy, feel free to contact me.
See more
See less

RT809F faulty?

  • Filter
  • Time
  • Show
Clear All
new posts

    RT809F faulty?

    Hi all,

    I have recently purchased the RT809F and am doing some test dumps/erase/reads of bios chips before I attempt anything in anger. While my unit is capable of identifying the correct chip types, it keeps telling me there is no chip attached.

    I've tried both the clip and the spring loaded holder that came with the unit, both are giving me the same result. I've cleaned the legs of my test chips with alcohol, lightly sanded them and cleaned them up with an eraser! Here's an example;

    001: Serial number:20210324115525-026373, Programmer firmware version: V5.0 .
    002: Auto identified 44 ID is match with the partnumber.
    004: The currently selected:W25Q64BV, capacity: 64Mbits, 8Mbytes.
    005: >------------------------------------OK---------------------------------------<

    At this point I click 'Erase'

    006: No chip on the adapter, or socket locking not properly!
    007: No chip on the adapter, or socket locking not properly!
    008: No chip on the adapter, or socket locking not properly!

    Click 'Ignore'

    009: Chip ID verification OK.
    010: UniqueID:0x35174383312465D1
    011: Start erasing chip, please be patient......
    012: Erase successful£¬Elapsed time£º21.16 seconds¡£
    013: Auto blank checking...
    014: Blank check successful£¬Elapsed time£º13.05 seconds¡£
    015: Erase successful£¬Elapsed time£º34.21 seconds¡£
    016: >------------------------------------OK---------------------------------------<

    Chip Erased. I then try writing an image;

    019: File has been loaded, checksum: 16bits_0x9300 £¬32bits_0x71319300 :
    020: No chip on the adapter, or socket locking not properly!
    021: No chip on the adapter, or socket locking not properly!
    022: No chip on the adapter, or socket locking not properly!

    Again I have to click 'Ignore' to proceed;

    023: Chip ID verification OK.
    024: UniqueID:0x35174383312465D1
    025: Start writing chip......
    026: Auto erasing...
    027: Erase successful£¬Elapsed time£º20.77 seconds¡£
    028: Start writing...
    029: Write successful£¬Elapsed time£º25.84 seconds¡£
    030: Auto verifying...
    031: Verification successful£¬Elapsed time£º2.979 seconds¡£
    032: Status register1 values: 0x0, Status register2 values: 0x2 .
    033: Elapsed time: 28.85 seconds£¬average speed of 290736 bytes/sec.
    034: >------------------------------------OK---------------------------------------<

    Click Verify to check that the chip has been written to;

    035: No chip on the adapter, or socket locking not properly!
    036: No chip on the adapter, or socket locking not properly!
    037: No chip on the adapter, or socket locking not properly!

    Again I have to click 'Ignore' to proceed

    038: Chip ID verification OK.
    039: UniqueID:0x35174383312465D1
    040: Start verifying chip......
    041: Chip verification OK, Elapsed time: 2.984 seconds, average speed of 2811195 bytes/sec.
    042: >------------------------------------OK---------------------------------------<

    Verification apparently successful. After erasing the chip, and reading it back I get 'Chip is empty, all are 0xFF!', the contents change after writing the image.. So why at every step does it say that there is no chip and I have to 'Ignore' to get the programmer to do anything? This doesn't give me any confidence that this unit is working as it should.. Should I return it ? Is this experience common?

    Re: RT809F faulty?

    try a different usb cable first - and use a different socket on the computer too.


      Re: RT809F faulty?

      Thanks for the suggestions. Tried both different cable and a front port instead of rear, got the same and a new error;

      026: Programmer is connected error.


        Re: RT809F faulty?

        sounds like a faulty programmer.
        i would try it on a different machine just to confirm 100% that it's the programmer.
        but right now i'm already 99% sure it's the problem


          Re: RT809F faulty?

          i'm having the same problem. have you found a solution? I've changed the cable, changed the software, replaced the laptop and replaced the bios chip, the result is still the same.


            Re: RT809F faulty?

            That programmer is powered by 9v, had the same problem and connected it to a 9v lab power supply and never had the problem again.
            Last edited by SMDFlea; 04-21-2023, 01:52 AM.


              Re: RT809F faulty?

              I think Connector 5.5mm x 2.1mm goes
              Last edited by SMDFlea; 04-21-2023, 01:52 AM.


                Re: RT809F faulty?

                Probably the ZIF socket is bad, but also could be an adapter that’s faulty, or the adapter / chip in backwards.


                  Re: RT809F faulty?

                  Originally posted by CapLeaker View Post
                  Probably the ZIF socket is bad, but also could be an adapter that's faulty, or the adapter / chip in backwards.

                  The thing is, when you buy that programmer, you don't get a power adapter, just a usb cable.


                    Re: RT809F faulty?

                    My RT809H didn’t come with a psu either. So far I didn’t need it. Not sure about the F version.