Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-29-2013, 08:32 PM   #1
kleini
New Member
 
Join Date: Oct 2013
City & State: Bielefeld
My Country: Germany
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 5
Default Samsung LE40D550K1W no backlight

TV starts up, shows picture (checked with flashlight) and plays sound but the backlight doesn't come on. Very seldom the backlight flickers for a few seconds (usually a few minutes after being powered on).

Part # (Haven't found any matching datasheets so far.)
PSU: BN44-00440A
MainBoard: BN41-01751
Inverter: SST400_12A01 INV40T12A

What i did so far:

1) Visually checked all electrolytic capacitors. They looked fine but i replaced them anyway, except the big main caps.

2) Checked for cold solder joints.

3) Measured voltages. The 13V lane seems a bit low but should be OK I think? High Voltage towards the inverter is missing.

Main Caps: 390V

CN801 (towards inverter - see attachment - not listed Pins are NC)
Pin# Label: measured voltage (target voltage)
1 High(FET): 0V (280VAC)
3 Low(FET): 0V (190V ACDC?)
8 GND: 0V (0V)
9 OVP: 0V (?V) (Seems to be a backlight-confirm Signal.)
10 CNT_PRT: 11.79V (?V)
11 VCC: 12.38V (13V)
12 LD: 11.04V (?V)

CN802 (towards main/interface -board)
Pin# Label: measured voltage (target voltage)
1, 3, 5, 7 B13V: 12.38V (13V)
2 P_DIM: 1.43V
6 BLU_ON: 5.07V
8, 9, 10 GND: 0V (0V)
11, 13 B5V: 5.2V (5.3V)
12 A5V: 5.2V (5.3V)

4) Checked the two MOSFETS (MI801S, MI802S) that drive the Inverter. Both are OK!
Realised there is no voltage at the gate pin of the MOSFETS.

5) Traced it back to UI801 - marking is SEM2106 1132 - found a datasheet (attached).

6) Measured voltages on SEM2106.
Pin1,24 VREF,P_DIM: 0.7V
Pin14 VCC: 12.36V
Pin16 Enable: 4.91V
Pin 12,13 N1,N2: 0V (These are connected to a tiny transformer that drives the two aforementioned MOSFETS)


Everything seems to point towards the SEM2106 being damaged but would that result in a sporadically flickering backlight?
Attached Images
File Type: jpg overview.JPG (1.02 MB, 203 views)
File Type: jpg PS_top.JPG (796.8 KB, 207 views)
File Type: jpg PS_bottom.JPG (985.0 KB, 187 views)
File Type: jpg main_board.JPG (1.42 MB, 146 views)
File Type: jpg inverter.JPG (494.4 KB, 148 views)
Attached Files
File Type: pdf SEM2106 Inverter Samsung.pdf (349.8 KB, 896 views)
kleini is offline   Reply With Quote
Old 11-27-2013, 04:58 PM   #2
luisparada
New Member
 
Join Date: Nov 2013
City & State: MEXICO DF
My Country: Mexico
I'm a: Knowledge Seeker
Posts: 2
Default Re: Samsung LE40D550K1W no backlight

Did you solve your problem? I have the same issue, but in my power board (same as yours) I found capacitor CP811 completly fried.

do you happen to know the specs for that capacitor?
luisparada is offline   Reply With Quote
Old 11-27-2013, 08:05 PM   #3
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 30,539
Default Re: Samsung LE40D550K1W no backlight

The snubber cap (in parallel with the Diode DP804) CP811 for the PFC Diode DP804 is 100pf 1KV ceramic cap.
See similar cap CP811 used in the similar circuit.
Attached Images
File Type: jpg Samsung BN44-00264A_REDLINED_Page_1.jpg (276.7 KB, 377 views)
__________________
Never stop learning
Basic LCD TV and Monitor troubleshooting guides.
http://www.badcaps.net/forum/showthr...956#post305956

Voltage Regulator (LDO) testing:
http://www.badcaps.net/forum/showthr...999#post300999

Inverter testing using old CFL:
http://www.badcaps.net/forum/showthr...er+testing+cfl

Tear down pictures : Hit the ">" Show Albums and stories" on the left side
http://s807.photobucket.com/user/budm/library/

TV Factory reset codes listing:
http://www.badcaps.net/forum/showthread.php?t=24809
budm is offline   Reply With Quote
Old 11-27-2013, 08:31 PM   #4
luisparada
New Member
 
Join Date: Nov 2013
City & State: MEXICO DF
My Country: Mexico
I'm a: Knowledge Seeker
Posts: 2
Default Re: Samsung LE40D550K1W no backlight

Thank you a lot for your help! I made a quick call to my local store, would a 100pf/500 V work?
luisparada is offline   Reply With Quote
Old 11-27-2013, 09:48 PM   #5
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 30,539
Default Re: Samsung LE40D550K1W no backlight

No, do not go lower than 1000V rating
budm is offline   Reply With Quote
Old 12-01-2013, 05:56 PM   #6
kleini
New Member
 
Join Date: Oct 2013
City & State: Bielefeld
My Country: Germany
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 5
Default Re: Samsung LE40D550K1W no backlight

Hi luisparada, sorry for the late reply...
I just took a look at CP811 and on my board the value is 220pF ±10%/1kV, if I decoded the markings correctly. The complete marking is "LB 221K 1KV".
At the moment I'm still waiting for the ICs to arrive (had some trouble with a seller on Alibaba).
I'll post results when they get here (in one or two weeks).
kleini is offline   Reply With Quote
Old 12-10-2013, 10:39 AM   #7
kleini
New Member
 
Join Date: Oct 2013
City & State: Bielefeld
My Country: Germany
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 5
Unhappy Re: Samsung LE40D550K1W no backlight

Well I'm back at the beginning.
Replacing the SEM2106 changed nothing.
If anybody has any ideas I'm all ear.
kleini is offline   Reply With Quote
Old 12-19-2013, 09:49 AM   #8
kleini
New Member
 
Join Date: Oct 2013
City & State: Bielefeld
My Country: Germany
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 5
Smile Re: Samsung LE40D550K1W no backlight

Problem solved.
Since replacing UI801 didn't fix my problem I started checking the diodes and z-diodes around it.
Sure enough one of the zeners was broken. ZDI805 a 6.8V zener had a breakdown voltage of ~4.5V.
Replaced it and now everything works.
kleini is offline   Reply With Quote
Old 03-23-2014, 03:27 AM   #9
HANSPAL4U
New Member
 
Join Date: Mar 2014
City & State: jalandhar
My Country: india
I'm a: Knowledge Seeker
Posts: 1
Default Re: Samsung LE40D550K1W no backlight

Hi Kleini

I found MOSFETS (MI801S)completly fried , but Mosfets (mI801s) is seem to be fine advise tha part name/ details of MI801s

Thanks & Brgds
Singh
HANSPAL4U is offline   Reply With Quote
Old 03-13-2015, 06:06 AM   #10
digital
New Member
 
Join Date: Jan 2010
Posts: 1
Default Re: Samsung LE40D550K1W no backlight

zdi804 6,8 v ,radi nje neradi inverter
digital is offline   Reply With Quote
Old 03-13-2015, 06:30 AM   #11
rauffmia
New Member
 
Join Date: Mar 2015
City & State: colombo
My Country: Sri lanka
I'm a: Knowledge Seeker
Posts: 8
Default Re: Samsung LE40D550K1W no backlight

invetoreka ti kassu kama toa
rauffmia is offline   Reply With Quote
Old 07-30-2016, 11:40 AM   #12
S7YH
New Member
 
Join Date: Jul 2016
City & State: PHOENIXVILLE
My Country: United States
I'm a: Knowledge Seeker
Posts: 1
Default Re: Samsung LE40D550K1W no backlight

Quote:
Originally Posted by kleini View Post
Problem solved.
Since replacing UI801 didn't fix my problem I started checking the diodes and z-diodes around it.
Sure enough one of the zeners was broken. ZDI805 a 6.8V zener had a breakdown voltage of ~4.5V.
Replaced it and now everything works.


solved and working.......
You were correct....replaced the Zener ZDI805 ans ZDI804 and presto...all is working fine
S7YH is offline   Reply With Quote
Old 08-31-2016, 01:22 AM   #13
raj mehra
New Member
 
Join Date: Aug 2016
City & State: jalandhar
My Country: india
I'm a: Knowledge Seeker
Posts: 1
Default Re: Samsung La32d450 no backlight

sir pls help me about repair inverter circut useing with sem2106 or mosfet 5n52u
raj mehra is offline   Reply With Quote
Old 10-18-2016, 02:58 AM   #14
Donazan
New Member
 
Join Date: Oct 2016
City & State: Imo
My Country: Nigeria
I'm a: Knowledge Seeker
Posts: 2
Default Re: Samsung LE40D550K1W no backlight

Samsung LA32E420 LCD 32 INCH TV, power not coming on at all. there is about 390v dc on the main power capacitor I have replaced STR W6052S and 10N60 transistor on the same heat sink of the STR but still not working. any idea pls help me out.
Donazan is offline   Reply With Quote
Old 09-19-2017, 03:57 PM   #15
Herendi László
New Member
 
Join Date: Sep 2017
City & State: Bonyhád
My Country: Hungary
I'm a: Knowledge Seeker
Posts: 1
Default Re: Samsung LE40D550K1W no backlight

Quote:
Originally Posted by S7YH View Post
solved and working.......
You were correct....replaced the Zener ZDI805 ans ZDI804 and presto...all is working fine
My problem was the ZD1801 9.1 zener

Best regards László
Herendi László is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2017
Powered by vBulletin ®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 01:13 AM.

Did you find this forum helpful?