Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 05-22-2020, 09:18 PM   #1
Dakay
New Member
 
Join Date: Apr 2020
City & State: Pomeroy
My Country: United States
I'm a: Knowledge Seeker
Posts: 15
Default 2015 MacBook Pro Retina 820-3787

Iím stuck. Working on an 820-3787, 2015 MBP Retina. PPBUS_G3H does not have 12V, only about 2V. I discovered that mosfet Q9330 near the GPU was getting hot. I removed it and sure enough it restored my 12V. However, when I replaced it the short returned. I replaced all three mosfets in the area, Q9330, Q9331, and Q9361. No dice. So I resoldered and eventually replaced U9300. Still no luck. In fact now, even when I remove Q9330, thereís a short on PPBUS_G3H. When I send power to it, it draws .2 amps, pin 1 on Q9330 sparks and gets hot, which is the UGATE from U9300, only showing about 1V on it.

U9300 isnít getting the right amount of voltage in, which would cause the gate to not open, but im not too sure why itís not getting the voltage. I think it might be a faulty GPU. Does anyone have any ideas? Someone else had worked on this board before me and Iíd rather not waste a ton of time on something I canít fix.
Dakay is offline   Reply With Quote
Old 05-22-2020, 11:11 PM   #2
robertpritchard
Member
 
Join Date: Dec 2016
City & State: orillia
My Country: Canada
I'm a: Knowledge Seeker
Posts: 61
Default Re: 2015 MacBook Pro Retina 820-3787

isl6259 sends voltage to u9300 opening logic gate to its 5volt if no dice check for your short on gpu
robertpritchard is offline   Reply With Quote
Old 05-23-2020, 03:25 AM   #3
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,125
Default Re: 2015 MacBook Pro Retina 820-3787

U9300 and Q9330 must be replaced at the same time.
Chances are GPU is damaged since it got 12V. You can at least measure exact resistance to ground on PPVCORE_S0_GFX_REG.

However I'm confused about what "pin 1 on Q9330 sparks and gets hot" and "U9300 isn’t getting the right amount of voltage in" mean.
If someone worked on this board already there must be signs of rework. Make sure GPU itself hasn't been messed with.
__________________
OpenBoardview ó http://openboardview.org | IRC ó #[email protected]
piernov is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:36 AM.
Did you find this forum helpful?