Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Audio Equipment
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-13-2021, 06:53 PM   #1
Uranium-235
Derp
 
Uranium-235's Avatar
 
Join Date: Aug 2007
City & State: tehas
My Country: US
Line Voltage: 120VAC 60Hz
I'm a: Professional Tech
Posts: 4,542
Default Think I would need to recap this Sunfire bi-wired amp ?

Sunfire bi-wired amp. Not sure if it's the 300w version or 600w version

stored in a cool place. Not turned on for like, 30 years

I'm worried about the big two after the rectifier. But if anything else catches your eye please speak up

dried out, obviously not bloated
Attached Images
File Type: jpg 20211013_180651.jpg (616.1 KB, 46 views)
File Type: jpg 20211013_180719.jpg (567.2 KB, 38 views)
File Type: jpg 20211013_180857.jpg (637.8 KB, 35 views)
File Type: jpg 20211013_180919.jpg (538.4 KB, 31 views)
File Type: jpg 20211013_180924.jpg (396.3 KB, 25 views)
File Type: jpg 20211013_181301.jpg (428.0 KB, 27 views)
__________________
Cap Datasheet Depot: http://www.paullinebarger.net/DS/
^If you have datasheets not listed PM me

Last edited by Uranium-235; 10-13-2021 at 06:56 PM..
Uranium-235 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 09:02 AM.
Did you find this forum helpful?