Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Game Consoles & Other Weird Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-04-2018, 03:43 PM   #1
DJ_MIX
Member
 
DJ_MIX's Avatar
 
Join Date: May 2005
Posts: 70
Default Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

Guys need your help.
I believe it got wet a bit which then cause it to only run at full speed, no longer can adjust speed.

Opened up and notice burn near resistor. I guess I need new resistor but what value? I did not test any further, I guess I can remove resistor and check.

Let me know what you think. Also what is ntc 60?
Attached Images
File Type: jpg dremel1.jpg (224.4 KB, 22 views)
File Type: jpg dremel2.jpg (206.4 KB, 17 views)
File Type: jpg dremel3.jpg (223.3 KB, 16 views)
File Type: jpg dremel4.jpg (257.8 KB, 15 views)
File Type: jpg dremel5.jpg (267.9 KB, 17 views)
DJ_MIX is offline   Reply With Quote
Old 06-04-2018, 04:00 PM   #2
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 2,701
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

I would guess the triac is shorted, looks like that resistors been running hot for a while and it may still be ok. Remove it and check its value, look and see if there are any values still visible on the resistor

Last edited by R_J; 06-04-2018 at 04:02 PM..
R_J is offline   Reply With Quote
Old 06-04-2018, 04:52 PM   #3
DJ_MIX
Member
 
DJ_MIX's Avatar
 
Join Date: May 2005
Posts: 70
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

Remove it but didn't see any values on the resistor. It did measure 5.2 ohms with multi meter. Which one would be the triac?
DJ_MIX is offline   Reply With Quote
Old 06-04-2018, 04:54 PM   #4
petehall347
Badcaps Veteran
 
Join Date: Jan 2015
City & State: worcester
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 1,245
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

yes the triac is suspect . or the pot is damaged .. maybe still damp .
petehall347 is offline   Reply With Quote
Old 06-04-2018, 04:55 PM   #5
petehall347
Badcaps Veteran
 
Join Date: Jan 2015
City & State: worcester
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 1,245
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

triac is the one with 3 legs
petehall347 is offline   Reply With Quote
Old 06-04-2018, 05:11 PM   #6
DJ_MIX
Member
 
DJ_MIX's Avatar
 
Join Date: May 2005
Posts: 70
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

Thanks Guys, the trace near the resistor was lifting so I glued it back. Once I but it back I will retest.
DJ_MIX is offline   Reply With Quote
Old 06-04-2018, 05:47 PM   #7
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 2,701
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

Remove the old solder and resolder the resistor, if the trace is bad just replace it with a piece of wire, Provide the number off the triac (3 leg part) if there is one.

Last edited by R_J; 06-04-2018 at 05:51 PM..
R_J is offline   Reply With Quote
Old 06-05-2018, 02:18 PM   #8
redwire
Badcaps Veteran
 
Join Date: Dec 2010
City & State: Alberta
My Country: Canada
Posts: 984
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

It looks like the speed controller was overloaded, cooked the resistor and triac. The NTC was useless, it was supposed to limit power.

Drew a schematic but not sure what the cooked R3 resistor's value is.
The circuit did not make sense unless there is a diac or something underneath the hot glue blob.

If you can give the resistor ohms and triac part number, I will update the sch.
Attached Images
File Type: png Dremel Speed Controller schematic MD95.PNG (59.9 KB, 10 views)
redwire is offline   Reply With Quote
Old 06-05-2018, 05:34 PM   #9
DJ_MIX
Member
 
DJ_MIX's Avatar
 
Join Date: May 2005
Posts: 70
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

WOW, thanks

The resistor is mwntion above at 5.2 ohms
triac is Z0409MF A149

Sorry had no time to mess with unit.
DJ_MIX is offline   Reply With Quote
Old 06-05-2018, 06:00 PM   #10
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 2,701
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

It's very likely the triac shorted, that would cause the motor to run full speed
R_J is offline   Reply With Quote
Old 06-06-2018, 04:16 PM   #11
DJ_MIX
Member
 
DJ_MIX's Avatar
 
Join Date: May 2005
Posts: 70
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

I will remove and try to test it.
DJ_MIX is offline   Reply With Quote
Old 06-08-2018, 02:28 PM   #12
DJ_MIX
Member
 
DJ_MIX's Avatar
 
Join Date: May 2005
Posts: 70
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

Problem solved, appears it was the Pot, I cleaned it and now have variable speeds..
DJ_MIX is offline   Reply With Quote
Old 06-08-2018, 03:32 PM   #13
sam_sam_sam
Badcaps Veteran
 
Join Date: Jul 2011
City & State: Sunny Jacksonville FL
My Country: USA
Line Voltage: 120 Volts 60 HZ
I'm a: Knowledge Seeker
Posts: 1,030
Default Re: Benchtop Pro MD95 Dremel Burnt resistor now works at Full speed only

If you can find a new pot I would recommend replacing it
It might do the same thing again
__________________
9 PC LCD Monitor
6 LCD Flat Screen TV
30 Desk Top Switching Power Supply
10 Desk Top Power Supply
10 Battery Charger Switching Power Supply for Power Tool
6 18v Lithium Battery Power Boards for Tool Battery Packs
1 XBox 360 Switching Power Supply and M Board
25 Servo Drives 220/460 3 Phase
6 De-soldering Station Switching Power Supply 1 Power Supply
1 Dell Mother Board
15 Computer Power Supply
1 HP Printer Supply & Control Board * lighting finished it *


These two repairs where found with a ESR meter...> Temp at 50*F then at 90*F the ESR reading more than 10%

1 Over Head Crane Current Sensing Board
2 Hem Saw Computer Stack Board

All of these had CAPs POOF
All of the mosfet that are taken out by bad caps
sam_sam_sam is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2018
Powered by vBulletin ®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 11:31 PM.

Did you find this forum helpful?