Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-11-2019, 06:39 PM   #1
Ovalking
Member
 
Join Date: Jul 2013
City & State: Brooks Kentucky
My Country: Usa
Line Voltage: 120vac 60hz
I'm a: Knowledge Seeker
Posts: 56
Default Kdl-75w850c

I have a Sony kdl-75w850c wonít turn on no lights or noise havenít tore apart yet was looking for advice thanks
Ovalking is offline   Reply With Quote
Old 06-11-2019, 07:13 PM   #2
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 39,206
Default Re: Kdl-75w850c

Get meter, take the back off and do visual inspection and then start taking Voltage measurement.
Also need to upload good clear pictures of the whole back side of the TV showing all the boards so we can see what we are dealing with.
__________________
Never stop learning
Basic LCD TV and Monitor troubleshooting guides.
http://www.badcaps.net/forum/showthr...956#post305956

Voltage Regulator (LDO) testing:
http://www.badcaps.net/forum/showthr...999#post300999

Inverter testing using old CFL:
http://www.badcaps.net/forum/showthr...er+testing+cfl

Tear down pictures : Hit the ">" Show Albums and stories" on the left side
http://s807.photobucket.com/user/budm/library/

TV Factory reset codes listing:
http://www.badcaps.net/forum/showthread.php?t=24809
budm is offline   Reply With Quote
Old 06-13-2019, 02:48 AM   #3
Ovalking
Member
 
Join Date: Jul 2013
City & State: Brooks Kentucky
My Country: Usa
Line Voltage: 120vac 60hz
I'm a: Knowledge Seeker
Posts: 56
Default Re: Kdl-75w850c

Thanks it has power red light blinks 6 times
Ovalking is offline   Reply With Quote
Old 06-13-2019, 03:41 AM   #4
mmartell
Badcaps Veteran
 
Join Date: Oct 2013
City & State: Windsor ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 3,022
Default Re: Kdl-75w850c

Probably backlight.
mmartell is offline   Reply With Quote
Old 06-13-2019, 05:27 AM   #5
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,187
Default Re: Kdl-75w850c

Unplug power cord, unplug cable from powerboard to mainboard, plug power cord in, see if backlights come on and stay on.
nomoresonys is offline   Reply With Quote
Old 06-15-2019, 08:50 AM   #6
SLK001
Badcaps Veteran
 
SLK001's Avatar
 
Join Date: May 2014
City & State: Coral Springs, FL
My Country: USA
Line Voltage: 120V AC @ 60Hz
I'm a: Knowledge Seeker
Posts: 244
Default Re: Kdl-75w850c

Quote:
Originally Posted by Ovalking View Post
Thanks it has power red light blinks 6 times
Indicates problem with backlights. Probably lost an LED or two (losing one LED will render the set "dead").

Do you see "SONY" flashed briefly when you turn on from a reset? If not, your problem may lie on the power supply end of the backlight (if you're lucky).
SLK001 is offline   Reply With Quote
Old 06-15-2019, 08:56 AM   #7
SLK001
Badcaps Veteran
 
SLK001's Avatar
 
Join Date: May 2014
City & State: Coral Springs, FL
My Country: USA
Line Voltage: 120V AC @ 60Hz
I'm a: Knowledge Seeker
Posts: 244
Default Re: Kdl-75w850c

Here are the blink codes for your unit:

Attached Images
File Type: jpg SONY BLINKS.jpg (143.7 KB, 158 views)
SLK001 is offline   Reply With Quote
Old 07-08-2019, 07:44 PM   #8
bstewara
Member
 
Join Date: Jun 2019
City & State: Spring Hill Florida
My Country: USA
Line Voltage: 120VAC
I'm a: Knowledge Seeker
Posts: 34
Default Re: Kdl-75w850c

Hi,
I have a 75 inch Sony with the same error code. (6 blinks)
Pretty sure that the issue is defective leds in backlight.
I had spare boards that I swapped out with no success.
My next step is to tear down and test leds.

Good Luck
bstewara is offline   Reply With Quote
Old 07-09-2019, 06:49 PM   #9
SLK001
Badcaps Veteran
 
SLK001's Avatar
 
Join Date: May 2014
City & State: Coral Springs, FL
My Country: USA
Line Voltage: 120V AC @ 60Hz
I'm a: Knowledge Seeker
Posts: 244
Default Re: Kdl-75w850c

There are two LED zones. If only one LED is bad, then you should see a flash of the good zone, which should light up the SONY logo (less than 0.25 seconds). If that happens, then you will have to perform open heart surgery to get at the LEDs. I have a post for a KDL-65W850C version of this series TV detailing my successful replacement of an LED.
SLK001 is offline   Reply With Quote
Old 05-02-2020, 08:45 PM   #10
brucetv
Badcaps Veteran
 
Join Date: May 2015
City & State: springdale ar
My Country: united states
I'm a: Professional Tech
Posts: 234
Default Re: Kdl-75w850c

I just finished doing a backlight repair on this Tv now that the backlight kits are available again at ShopJimmy but it's a nightmare to do compared to most backlight repairs. Teardown went normal once you get all the various brackets, IR sensor and wifi out of the way. Each side has it's own wrap around bezel and the panel has side tabs that protects them. One thing I advise is pay attention to the corner L shaped brackets and bottom bezel brackets before they fall out once you take out the screws because they are a pain in the butt to align when you put everything together. Be careful removing the clear plastic stations that holds the defusers and panel away from the leds because they clip back in and never fit tight when reinstalling so I used a dab of clear silicone to hold them down. Take a picture of where everything goes and in what order you took it apart. The bottom bezel is a pain to line up to get the small screws in those brackets. Total time was about 8 hours. That's twice the time I usually spend on a backlight repair. There was one burnt out strip in the middle which caused the six blink error code. I rarely see Sony's come in for backlight repairs and that is good because they are never easy compared to most models.
brucetv is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 03:50 AM.
Did you find this forum helpful?