Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-30-2019, 12:16 PM   #1
bstewara
Member
 
Join Date: Jun 2019
City & State: Spring Hill Florida
My Country: USA
Line Voltage: 120VAC
I'm a: Knowledge Seeker
Posts: 34
Default Sony XBR75X850C

Hello,

I am currently trying to repair a Sony Model XBR75X850C.
The set has the dreaded 6 blinking error lights flashing. The set tries to startup with the screen illuminating but shuts down immediately
I have replaced the main board but no change.

So voltages from the G4 board are within range except one anomaly.
I keep getting a 1.9 voltage reading from pin out location CN 6402 pin 4 BL_ERR. I don’t see where I should be getting any voltage reading from this pin?
Anyone have any suggestions/recommendations?

TIA

Last edited by bstewara; 06-30-2019 at 01:17 PM.. Reason: Add photo
bstewara is offline   Reply With Quote
Old 06-30-2019, 12:31 PM   #2
diif
Badcaps Veteran
 
Join Date: Feb 2014
City & State: Midlands
My Country: England
I'm a: Professional Tech
Posts: 6,109
Default Re: Sony XBR75X850C

The LED flashing 6 times is a back-light error I believe.
diif is offline   Reply With Quote
Old 06-30-2019, 03:55 PM   #3
bstewara
Member
 
Join Date: Jun 2019
City & State: Spring Hill Florida
My Country: USA
Line Voltage: 120VAC
I'm a: Knowledge Seeker
Posts: 34
Default Re: Sony XBR75X850C

You are correct on the error code.
I’m just wondering if I don’t have an issue with the ps board as well.

Thank You
bstewara is offline   Reply With Quote
Old 06-30-2019, 04:33 PM   #4
diif
Badcaps Veteran
 
Join Date: Feb 2014
City & State: Midlands
My Country: England
I'm a: Professional Tech
Posts: 6,109
Default Re: Sony XBR75X850C

It's possible, it could also be the LED driver board.
diif is offline   Reply With Quote
Old 06-30-2019, 06:33 PM   #5
bstewara
Member
 
Join Date: Jun 2019
City & State: Spring Hill Florida
My Country: USA
Line Voltage: 120VAC
I'm a: Knowledge Seeker
Posts: 34
Default Re: Sony XBR75X850C

I found a flow chart and it points to the LD or the G board.
Thanks again

Attached Images
File Type: jpg D150414B-0776-4B83-9F0A-B6C0E0AA665C.jpg (147.8 KB, 20 views)

Last edited by bstewara; 06-30-2019 at 07:56 PM.. Reason: Add photo
bstewara is offline   Reply With Quote
Old 07-02-2019, 09:26 AM   #6
tibimakai
Badcaps Veteran
 
Join Date: Jan 2012
City & State: Los Angeles/San Dimas, CA
My Country: USA
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 3,468
Default Re: Sony XBR75X850C

Anybody knows, what is a 4 blink code could be? It is for a 65X900C
tibimakai is offline   Reply With Quote
Old 07-02-2019, 10:16 AM   #7
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,187
Default Re: Sony XBR75X850C

Quote:
Originally Posted by tibimakai View Post
Anybody knows, what is a 4 blink code could be? It is for a 65X900C
one here, also suggests doing a self diagnostic might clear up some issues.

Four blinks
- No vertical Deflection (V STOP), Screen goes to a single horizontal line then the video signal muted. Check IC1509, Q1505


Last edited by nomoresonys; 07-02-2019 at 10:20 AM..
nomoresonys is offline   Reply With Quote
Old 07-02-2019, 10:34 AM   #8
diif
Badcaps Veteran
 
Join Date: Feb 2014
City & State: Midlands
My Country: England
I'm a: Professional Tech
Posts: 6,109
Default Re: Sony XBR75X850C

Quote:
Originally Posted by tibimakai View Post
Anybody knows, what is a 4 blink code could be? It is for a 65X900C
Panel or LD board.
diif is offline   Reply With Quote
Old 07-02-2019, 10:46 AM   #9
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,187
Default Re: Sony XBR75X850C

Possibly backlight led failure.
nomoresonys is offline   Reply With Quote
Old 07-02-2019, 11:18 AM   #10
budm
Badcaps Veteran
 
budm's Avatar
 
Join Date: Feb 2010
City & State: S.F. Bay area
My Country: USA
Line Voltage: 120V 60Hz
I'm a: Knowledge Seeker
Posts: 39,206
Default Re: Sony XBR75X850C

https://www.youtube.com/watch?v=DyRdHSN43Y4

Bad LED is more likely. Do you have LED tester?
__________________
Never stop learning
Basic LCD TV and Monitor troubleshooting guides.
http://www.badcaps.net/forum/showthr...956#post305956

Voltage Regulator (LDO) testing:
http://www.badcaps.net/forum/showthr...999#post300999

Inverter testing using old CFL:
http://www.badcaps.net/forum/showthr...er+testing+cfl

Tear down pictures : Hit the ">" Show Albums and stories" on the left side
http://s807.photobucket.com/user/budm/library/

TV Factory reset codes listing:
http://www.badcaps.net/forum/showthread.php?t=24809
budm is offline   Reply With Quote
Old 07-02-2019, 07:35 PM   #11
bstewara
Member
 
Join Date: Jun 2019
City & State: Spring Hill Florida
My Country: USA
Line Voltage: 120VAC
I'm a: Knowledge Seeker
Posts: 34
Default Re: Sony XBR75X850C

4 red blinking error maybe LED driver or G board

Last edited by bstewara; 07-02-2019 at 07:37 PM.. Reason: Add text
bstewara is offline   Reply With Quote
Old 07-03-2019, 10:01 AM   #12
bstewara
Member
 
Join Date: Jun 2019
City & State: Spring Hill Florida
My Country: USA
Line Voltage: 120VAC
I'm a: Knowledge Seeker
Posts: 34
Default Re: Sony XBR75X850C

Attached Images
File Type: jpg E862E03B-C31F-4322-97D6-8D4BCFD2E69A.jpg (89.7 KB, 24 views)
bstewara is offline   Reply With Quote
Old 07-03-2019, 07:36 PM   #13
Davi.p
Badcaps Veteran
 
Davi.p's Avatar
 
Join Date: Sep 2009
City & State: Milan
My Country: Italy
I'm a: Hobbyist Tech
Posts: 2,491
Default Re: Sony XBR75X850C

Tibimakai why did you entered here with your own different problems? Better to open your own thread..
Davi.p is offline   Reply With Quote
Old 07-09-2019, 06:43 PM   #14
SLK001
Badcaps Veteran
 
SLK001's Avatar
 
Join Date: May 2014
City & State: Coral Springs, FL
My Country: USA
Line Voltage: 120V AC @ 60Hz
I'm a: Knowledge Seeker
Posts: 244
Default Re: Sony XBR75X850C

The six flash error code is a backlight issue. Most probably, it is a dead LED. I have the 65" version of this TV and all it took was a $0.05 LED to fix. But you really "earn" the fix, because you have to dig all the way to the heart of the set to fix it.
SLK001 is offline   Reply With Quote
Old 07-09-2019, 06:45 PM   #15
bstewara
Member
 
Join Date: Jun 2019
City & State: Spring Hill Florida
My Country: USA
Line Voltage: 120VAC
I'm a: Knowledge Seeker
Posts: 34
Default Re: Sony XBR75X850C

You are exactly right.
Itís a big job for such a small item to repair
bstewara is offline   Reply With Quote
Old 08-01-2019, 02:27 PM   #16
Marty-Club
Member
 
Join Date: Aug 2019
City & State: Skelton-in-cleveland,saltburn-by-the-sea
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 22
Default Re: Sony XBR75X850C

Hi i have the 65 inch version sony bravia with 6 blinking lights , back light error.....
can you give me some advice how to remove the pannel......

i have done a few Philips 42 inch.......
Marty-Club is offline   Reply With Quote
Old 08-01-2019, 02:42 PM   #17
SMDFlea
Super Moderator
 
Join Date: Jan 2018
City & State: York
My Country: UK
I'm a: Knowledge Seeker
Posts: 10,760
Default Re: Sony XBR75X850C

Quote:
Originally Posted by Marty-Club View Post
Hi i have the 65 inch version sony bravia with 6 blinking lights , back light error.....
can you give me some advice how to remove the pannel......

i have done a few Philips 42 inch.......
Here`s the service manual for the xbr-55x850c, same type of chasis i think. The disassembly instructions start on page 12 .
Attached Files
File Type: zip xbr55x850c.zip (21.50 MB, 42 views)
SMDFlea is online now   Reply With Quote
Old 08-01-2019, 04:35 PM   #18
SLK001
Badcaps Veteran
 
SLK001's Avatar
 
Join Date: May 2014
City & State: Coral Springs, FL
My Country: USA
Line Voltage: 120V AC @ 60Hz
I'm a: Knowledge Seeker
Posts: 244
Default Re: Sony XBR75X850C

Quote:
Originally Posted by Marty-Club View Post
Hi i have the 65 inch version sony bravia with 6 blinking lights , back light error.....
can you give me some advice how to remove the pannel...
Do a forum search. This has been discussed in other threads. I started a thread on exactly this issue.
SLK001 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 03:15 AM.
Did you find this forum helpful?