Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 11-30-2013, 09:32 AM   #1
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default LG 60PZ950 purple and green color artifacts

The color artifacts seems to change flickering at times and steady other times on background and faces. After tv warms up it seems to get worse. I've checked external input conntections and have tried different HDMI inputs. Problem persists.
Purple on menu bar picure and green with some blues on garage of other picture.
I've also noticed a flickering of brightness of the green field when watching football games. Other times when a different scene comes on the problem goes away.

Not sure if related but sound quality at times sounds distorted.

Any ideas?
Attached Images
File Type: jpg 20131129_172549.jpg (390.8 KB, 236 views)
File Type: jpg 20131130_074232.jpg (335.6 KB, 222 views)
brewman is offline   Reply With Quote
Old 11-30-2013, 10:10 AM   #2
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

Looks like one of the main voltages (Vs, -Vy or Vsc) could be wrong, possibly drifted out. To adjust, you need to have a digital multimeter and the back of the set off.
__________________
Please do not PM me with questions! Questions via PM will not be answered. Post on the forums instead!
Free service manuals: http://www.toms-service-manuals.com/ -- 72 LED/LCD TVs, 5 monitors, 28 plasma TVs, and 2 AVR 6.1 amplifiers fixed! -- I repair Pioneer 9G Plasma Main Boards & KRP-M01 Media Receivers (PM me for info)

2 Pioneer KURO 9G, 12 Panasonic LCD/Plasma, 1 Sony LCD, 1 NEC Plasma, 2 Yamaha HTS, 5 Sharp LCDs, 5 Toshiba LCDs, 7 Philips Plasma/LCD, 1 Hitachi Plasma, 11 LG LCD/Plasma, 18 Samsung LED/LCD/Plasma, 1 Thomson Plasma, 1 Atec LCD, 1 Hanspree LCD, 1 Xerox LCD, 1 Harwa LCD, 2 Proview LCD, 2 Hyundai LCD, 1 "Onn" LCD, 1 Grundig LCD, 1 Dell LCD, 1 iiyama LCD, 1 Acer LED, 1 Logik LCD, 1 Baird (China) LCD, 6 Bush LCDs, 22 Vestel LCDs (Best->Worst)
tom66 is offline   Reply With Quote
Old 11-30-2013, 11:39 AM   #3
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

Thanks for the quick reply.

I set the voltages dead on. Prior voltage close within 1 volt.

Now

Vs = 201
Va = 55
Vy = 180
VSC = 150

No noticable difference.
Attached Images
File Type: jpg 20131130_102328.jpg (414.2 KB, 115 views)
brewman is offline   Reply With Quote
Old 11-30-2013, 11:40 AM   #4
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

BTW. adjustments made while in white screen mode.
brewman is offline   Reply With Quote
Old 11-30-2013, 11:44 AM   #5
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

OK, can you post a picture of the whole back chassis, showing all the boards?
tom66 is offline   Reply With Quote
Old 11-30-2013, 12:04 PM   #6
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

back of 60PZ950
Attached Images
File Type: jpg 20131130_105135.jpg (554.1 KB, 197 views)
File Type: jpg 20131130_105508.jpg (458.2 KB, 124 views)
File Type: jpg 20131130_105519.jpg (560.7 KB, 116 views)
File Type: jpg 20131130_105543.jpg (490.7 KB, 215 views)
brewman is offline   Reply With Quote
Old 11-30-2013, 01:08 PM   #7
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

Bottom left board here
http://www.badcaps.net/forum/attachm...8&d=1385834586

Do you see two points marked EXT AUTO GEN?
tom66 is offline   Reply With Quote
Old 11-30-2013, 01:40 PM   #8
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

No. I looked at all visable boards and couldn't find.
brewman is offline   Reply With Quote
Old 11-30-2013, 02:01 PM   #9
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

Can you post a close up picture of the board I referenced. That position should be marked there somewhere.
tom66 is offline   Reply With Quote
Old 11-30-2013, 02:16 PM   #10
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

60PZ950 control board
Attached Images
File Type: jpg 20131130_130610.jpg (1.04 MB, 147 views)
brewman is offline   Reply With Quote
Old 11-30-2013, 02:45 PM   #11
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

OK, it's not marked on this board, but the blue holes should be jumpered. Then the red connector should be unplugged. TV should then be plugged in. You should get test patterns. Are they poor?
Attached Images
File Type: jpg ctrl-test.jpg (1.18 MB, 137 views)

Last edited by tom66; 11-30-2013 at 02:47 PM..
tom66 is offline   Reply With Quote
Old 11-30-2013, 03:36 PM   #12
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

Sorry about all the reflections. Best I could do with light conditions.
Artifacts apparent here as well. Test was moving and changing colors took pictures of artifacts on white screen.
Noticed IR at bottom of screen.
Attached Images
File Type: jpg 20131130_142240.jpg (261.2 KB, 140 views)
File Type: jpg 20131130_142243.jpg (265.0 KB, 128 views)
brewman is offline   Reply With Quote
Old 11-30-2013, 04:01 PM   #13
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

OK, top right board:
http://www.badcaps.net/forum/attachm...8&d=1385834586

Can you see any points marked "Vzbias"? What do you measure across them?
tom66 is offline   Reply With Quote
Old 11-30-2013, 04:22 PM   #14
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

VZB = 120

I set it to 110.
Rechecked other settings. They are the same.

Vs = 201
Va = 55
Vy = 180
VSC = 150
brewman is offline   Reply With Quote
Old 11-30-2013, 04:41 PM   #15
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

OK, on the Y-sustain, you should have some potentiometers (adjustments, like on the PSU for Vs and Va) marked SET UP or RAMP UP, and SET DN or RAMP DN. Unfortunately you can't measure the voltage for these settings, so it is trial and error. Mark the original factory setting (a marker pen works.) Then try SET DN. Try to reduce the clouding. If that fails, try SET UP.
tom66 is offline   Reply With Quote
Old 11-30-2013, 05:27 PM   #16
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

Tried tweeking set_up and set_dn pots made a slight difference but problem remained. Returned those to original setting. However, I recheck voltages on other test points all were fine except Vy = 166 Set it back to label setting of Vy = 178. (Don't ask me where I got the Vy = 180 on earlier post.)
brewman is offline   Reply With Quote
Old 12-05-2013, 04:42 PM   #17
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

I have the tv working again without the artifacts.
The upper right hand board, VZB board ( z-bias?) has 3 copper coils that appeared to get very hot discoloring the pcb. I took the board off and observed the solder joints on the back, noted on attachment circled in red. Resoldered the joints now circled green. Picture is now back to normal.
Attached Images
File Type: jpg VZB Board.jpg (701.2 KB, 291 views)
File Type: jpg Before solder.jpg (912.5 KB, 289 views)
File Type: jpg After solder.jpg (904.2 KB, 264 views)
brewman is offline   Reply With Quote
Old 12-05-2013, 04:50 PM   #18
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

If Vzb is good, there is nothing further to suggest but try adjusting voltages for best image. Perhaps panel has problem and firmware update can fix it, which was an issue with early LG plasmas.
tom66 is offline   Reply With Quote
Old 12-05-2013, 05:05 PM   #19
brewman
New Member
 
Join Date: Nov 2013
City & State: Colorado
My Country: USA
I'm a: Knowledge Seeker
Posts: 12
Default Re: LG 60PZ950 purple and green color artifacts

Tom66 tv is fixed. Loose solder joints were the problem.
brewman is offline   Reply With Quote
Old 12-05-2013, 05:32 PM   #20
tom66
EVs Rule
 
tom66's Avatar
 
Join Date: Apr 2011
City & State: Leeds
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Professional Tech
Posts: 32,166
Default Re: LG 60PZ950 purple and green color artifacts

That's good to hear but I can't see how those caused that fault. They are ERC inductors... Anyway, enjoy the TV!
tom66 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2018
Powered by vBulletin ®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 06:23 PM.

Did you find this forum helpful?