Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-06-2017, 10:42 PM   #1
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default panasonic tc-p50s60 bricked after firmware update?

I was updating the firmware on my panny plasma tc-p50s60, and at the end of the process when the TV prompts me to remove the USB drive, and hold the power button for 5 seconds (the TV is supposed to automatically come back on after this) the TV turned off and hasn't come back on since.

There is no blinking red codes, just a solid red LED. As if the TV is stuck in standby mode. If I hold the power button on the TV in for 5 seconds the red LED will turn off, but as soon as I let go of the power button it comes right back on (no blinking). I've tried hard resets by holding volume - on the tv and menu on the remote, but to get any sort of response for that I have to first hold the power button for 5 seconds until it turns off, then I hold volume- and menu for about 10 seconds and I get a quick burst from the LED of about 5 blinks. After which it just goes back to being a solid red.

I've unplugged all components and power cables and let it sit for over an hour. I removed the back of the TV just to see if I could spot anything out of sorts, but everything looks fine. As soon as I plug the TV back in the solid red LED lights up and the TV won't turn on.

So I've been after this all day long. Any feedback or suggestion is greatly appreciated as before today I didn't know a whole hell of a lot about troubleshooting TVs. I found the service manual online and even found/ordered a new A-Board as that's what I'm thinking is the issue.

Could it just be that the firmware update didn't complete properly and now I've got a very heavy paperweight on my kitchen table for now? The new mainboard was just under $100 and took forever to find in stock.

20171006_233346.jpg

20171006_233357.jpg

20171006_233416.jpg
mushchampion is offline   Reply With Quote
Old 10-07-2017, 02:12 AM   #2
dick_barton
Badcaps Veteran
 
dick_barton's Avatar
 
Join Date: Aug 2015
City & State: Cardiff
My Country: Wales
Line Voltage: 230V AC, 50Hz
I'm a: Hobbyist Tech
Posts: 4,796
Default Re: panasonic tc-p50s60 bricked after firmware update?

Is it possible for you to try the firmware update again?
__________________
Willing to help but I'm no expert.
dick_barton is offline   Reply With Quote
Old 10-07-2017, 04:05 AM   #3
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default Re: panasonic tc-p50s60 bricked after firmware update?

I've tried, but the screen doesn't come on, so it's kind of difficult. I've inserted the usb stick again while the red light is on, and attempted to put in the correct inputs with the remote to do it again but haven't had any luck.

I recently found a pretty comprehensive technical guide put out by Panasonic's "National Training Department" in 2013 that has all the board lay outs, connection locations and trouble shooting flowcharts. Most signs are pointing toward replacing the main or 'A' board, but I haven't broken out the multi-meter yet. I already ordered the A board so I'll see what happens after I get that.
mushchampion is offline   Reply With Quote
Old 10-07-2017, 04:08 AM   #4
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: QLD
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 6,359
Default Re: panasonic tc-p50s60 bricked after firmware update?

Quote:
Originally Posted by mushchampion View Post
I've tried, but the screen doesn't come on, so it's kind of difficult. I've inserted the usb stick again while the red light is on, and attempted to put in the correct inputs with the remote to do it again but haven't had any luck.

I recently found a pretty comprehensive technical guide put out by Panasonic's "National Training Department" in 2013 that has all the board lay outs, connection locations and trouble shooting flowcharts. Most signs are pointing toward replacing the main or 'A' board, but I haven't broken out the multi-meter yet. I already ordered the A board so I'll see what happens after I get that.
If it fixes it and you're confident it's bricked you can order the IC loaded, just a matter of desoldering the old and on with the new. Advanced soldering skils
tw2005 is offline   Reply With Quote
Old 10-07-2017, 04:37 AM   #5
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default Re: panasonic tc-p50s60 bricked after firmware update?

Quote:
Originally Posted by tw2005 View Post
If it fixes it and you're confident it's bricked you can order the IC loaded, just a matter of desoldering the old and on with the new. Advanced soldering skils
An advanced solderer I am not. I'm intimidated to even get the multi-meter out to test Voltages. The Technical Guide I found goes super in depth with a lot of terms I'm not familiar with.
mushchampion is offline   Reply With Quote
Old 10-07-2017, 05:18 AM   #6
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: QLD
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 6,359
Default Re: panasonic tc-p50s60 bricked after firmware update?

Quote:
Originally Posted by mushchampion View Post
An advanced solderer I am not. I'm intimidated to even get the multi-meter out to test Voltages. The Technical Guide I found goes super in depth with a lot of terms I'm not familiar with.
Well, keep the old board just in case you find someone who can or maybe reflash the chip.
tw2005 is offline   Reply With Quote
Old 10-12-2017, 11:26 PM   #7
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default Re: Panasonic tc-p50s60 bricked after firmware update?

Update : I Received and installed the new A-Board. I plugged in the TV expecting my problems to be solved but alas now the LED is blinking 6 times.

So after consulting all the documents I previously gathered

I was hoping it would be just a loose connection on the A-board I just installed, but after rechecking all the ribbons and connections everything seems to be properly connected.

When I was removing the ribbon connections from the old board one of them took a bit more force than the others to come out, resulting in this :

(click to zoom, then expand to actual size)

I don't know if that could be causing the 6 blinks or not, it doesn't look especially damaged to me, but idk if minor scrapes/dents in those ribbons is enough to cause failure.

I went ahead with the troubleshooting flowchart

After disconnecting the SC Board and plugging the TV back in, I still get 6 blinks, but it takes a lot longer(+11 seconds) for the blinks to happen. According to the flowchart that means the SC Board needs to be replaced.

The good news is SC Boards are in stock on multiple websites and go for as low as $30. Finding the A-Board replacement took hours of scouring to find in stock and cost $94.

My concern is if I buy a new SC Board and put it in, will that be the end of it? Will it solve the problem or just present a different one? Do I have to replace the buffer boards (SU and SD) as well?

I guess at least for now I have a real error code to work with

Last edited by mushchampion; 10-12-2017 at 11:32 PM..
mushchampion is offline   Reply With Quote
Old 10-13-2017, 12:53 AM   #8
Moreno83
Badcaps Veteran
 
Join Date: Jun 2014
City & State: Overijssel
My Country: The Netherlands
Line Voltage: 230V
I'm a: Professional Tech
Posts: 1,888
Default Re: panasonic tc-p50s60 bricked after firmware update?

Is the suffix sticker exactly the same as your old mainboard? It is a white sticker with "TXN/A..... "

Maybe you just checked the TNPH number only.
Moreno83 is offline   Reply With Quote
Old 10-13-2017, 03:11 AM   #9
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default Re: panasonic tc-p50s60 bricked after firmware update?

The new mainboard came with a long white sticker reading TXN/A1USUUS. However, the old board has no such sticker. They have Panasonic's suffix grid and the jumpers are in the same location on both boards. The new board even has the suffix written with a black sharpie on the board above TNPH1046 (UB).
mushchampion is offline   Reply With Quote
Old 10-13-2017, 03:26 AM   #10
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: QLD
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 6,359
Default Re: panasonic tc-p50s60 bricked after firmware update?

Quote:
Originally Posted by mushchampion View Post
The new mainboard came with a long white sticker reading TXN/A1USUUS. However, the old board has no such sticker. They have Panasonic's suffix grid and the jumpers are in the same location on both boards. The new board even has the suffix written with a black sharpie on the board above TNPH1046 (UB).
It's the right board
tw2005 is offline   Reply With Quote
Old 10-13-2017, 05:06 PM   #11
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default Re: panasonic tc-p50s60 bricked after firmware update?

I went ahead and ordered the SC Board, I figure what's another $30(45 w/ shipping) if it saves me buying a new tv. I really love my Panasonic Plasma, and I got it for next to nothing from Sears shortly after Panasonic announced they wouldn't be making plasmas anymore.

I'll update again next week when I get the new SC Board.
mushchampion is offline   Reply With Quote
Old 10-13-2017, 05:34 PM   #12
petehall347
Badcaps Veteran
 
Join Date: Jan 2015
City & State: worcester
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 1,651
Default Re: panasonic tc-p50s60 bricked after firmware update?

try the old a board back in .
petehall347 is offline   Reply With Quote
Old 10-13-2017, 08:14 PM   #13
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default Re: panasonic tc-p50s60 bricked after firmware update?

Quote:
Originally Posted by petehall347 View Post
try the old a board back in .
Tried that as well, and got the original result. With the old A-Board the red LED just comes on and stays on, never blinks. TV Still doesn't work.
mushchampion is offline   Reply With Quote
Old 10-13-2017, 09:45 PM   #14
koka0011
Member
 
Join Date: Apr 2013
City & State: Gampaha
My Country: Sri Lanka
I'm a: Knowledge Seeker
Posts: 27
Default Re: panasonic tc-p50s60 bricked after firmware update?

i guess you need to re-flash the ROM ic.find a programmer and re-programme tha ROM ic.
RT809F or RT809H (find the bin file)
koka0011 is offline   Reply With Quote
Old 10-17-2017, 09:02 PM   #15
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default Re: panasonic tc-p50s60 bricked after firmware update?

Update : got the new SC Board, installed it. Still getting 6 blinks. I tripled checked all the connections and screws before I even plugged the thing back in.

I'm all out of ideas on what the issue could be. Really don't want to go in on more parts (the SU and SD Boards).

Also about all out of patience, guess I'm going to start looking into new TVs.
mushchampion is offline   Reply With Quote
Old 10-17-2017, 09:11 PM   #16
heavymachines
Badcaps Veteran
 
Join Date: Mar 2011
City & State: Muskegon, Michigan
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 1,026
Default Re: panasonic tc-p50s60 bricked after firmware update?

Where did you get the board?
heavymachines is offline   Reply With Quote
Old 10-17-2017, 09:22 PM   #17
mushchampion
New Member
 
Join Date: Oct 2017
City & State: Bismarck, ND
My Country: USA
I'm a: Knowledge Seeker
Posts: 14
Default Re: panasonic tc-p50s60 bricked after firmware update?

tvpartstoday.com

Same place I got the A-board
mushchampion is offline   Reply With Quote
Old 10-18-2017, 06:57 AM   #18
heavymachines
Badcaps Veteran
 
Join Date: Mar 2011
City & State: Muskegon, Michigan
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 1,026
Default Re: panasonic tc-p50s60 bricked after firmware update?

Should be good then. Formally tristate module. i have yet to receive anything bad from them, anything but it is possible to get a bad part but i can tell you they have called me before they shipped an order of multiple parts to let me know one was damaged and failed test so the order had to be modified.
heavymachines is offline   Reply With Quote
Old 10-18-2017, 07:36 AM   #19
Moreno83
Badcaps Veteran
 
Join Date: Jun 2014
City & State: Overijssel
My Country: The Netherlands
Line Voltage: 230V
I'm a: Professional Tech
Posts: 1,888
Default Re: panasonic tc-p50s60 bricked after firmware update?

You should not have bought the sc board to be honest. I get it , you want the tv to be working again but dont go buy random boards. Waste of money.
Just looking at the picture you provided i think you received a bad A board ( mainboard ). But that is just a guess.

Can you take a clear picture of the SC board? Especially the bottom left area , is there a SC50 jumper? ( between 2 white connectors )

If so , remove the 2 buffer boards or make sure they DONT touch the sc board. Use a harddisk jumper or something else and short the 2 pins. Turn on the tv and see if it stays on.
What it does is turning on the tv without sending a image to the panel. If it stays on you got bad buffer boards.

If the 6 blink error stays on BOTH sc boards your problem seems to be the mainboard. I will look in the service manual when i get home.

Let me know what the outcome is!
Moreno83 is offline   Reply With Quote
Old 10-18-2017, 11:03 AM   #20
Moreno83
Badcaps Veteran
 
Join Date: Jun 2014
City & State: Overijssel
My Country: The Netherlands
Line Voltage: 230V
I'm a: Professional Tech
Posts: 1,888
Default Re: panasonic tc-p50s60 bricked after firmware update?

Ps , with the old mainboard installed im sure you tried the power button on the remote itself? It wont come out of standby with the power button on the tv or other buttons.
Also double check the SC20 cable , release both hatches and pull them open untill they cant go any further. Take the SC20 connector and slide it in. Maybe clean the sc20 cable wih some alcohol and look inside the connector.

It happened to me once that i had a faulty sc20 cable due to heat/dust etc

Last edited by Moreno83; 10-18-2017 at 11:12 AM..
Moreno83 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 06:27 AM.
Did you find this forum helpful?