Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 03-30-2019, 11:17 AM   #1
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Asus x751lk - first repair attempt

Hello,

I am trying to do my first repair. I have motherboard of asus x751lk rev 2.0

When I plug in the charger computer turns on, fan spins, but there is no image on the lcd or hdmi/vga output. Also the cpu and gpu are getting warm.

I have this area where is something is shorted to ground.
every other contact is shorted (some marked on the picture with squares) and it gives about 0.9v while on not shorted pins I get 19 v.


I would like to have some advice on how to proceed.

Thanks
alloallo is offline   Reply With Quote
Old 03-30-2019, 11:38 AM   #2
ktmmotocross
Boardkiller
 
ktmmotocross's Avatar
 
Join Date: Feb 2014
City & State: slovakia
My Country: slovakia
Line Voltage: 230VAC 50Hz
I'm a: Hobbyist Tech
Posts: 1,743
Default Re: Asus x751lk - first repair attempt

please stop repairing and give it to someone that have some skill and knowledge.

what u see is mostly CPU power circuit. and 0.9V is absolutely ok, it is not shorted. if it was shorted the main power rail will be turned off

dont proceed further because u dont have basic knowledge of this

u must as first learn basics to be able to understand what is going on in this circuit
ktmmotocross is offline   Reply With Quote
Old 03-30-2019, 11:51 AM   #3
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by ktmmotocross View Post
please stop repairing and give it to someone that have some skill and knowledge.

what u see is mostly CPU power circuit. and 0.9V is absolutely ok, it is not shorted. if it was shorted the main power rail will be turned off

dont proceed further because u dont have basic knowledge of this

u must as first learn basics to be able to understand what is going on in this circuit
well I am just trying to learn

Looks like I am not on the right forum. Mods you can close this topic.

thanks for your help anyway.
alloallo is offline   Reply With Quote
Old 03-30-2019, 12:00 PM   #4
ktmmotocross
Boardkiller
 
ktmmotocross's Avatar
 
Join Date: Feb 2014
City & State: slovakia
My Country: slovakia
Line Voltage: 230VAC 50Hz
I'm a: Hobbyist Tech
Posts: 1,743
Default Re: Asus x751lk - first repair attempt

if u want to learn u must start with basics to be able to understand how it works
ktmmotocross is offline   Reply With Quote
Old 03-30-2019, 12:19 PM   #5
SMDFlea
Badcaps Veteran
 
Join Date: Jan 2018
City & State: York
My Country: UK
I'm a: Knowledge Seeker
Posts: 2,280
Default Re: Asus x751lk - first repair attempt

The problem could be the bios ,do you have a bios programmer .
SMDFlea is offline   Reply With Quote
Old 03-30-2019, 01:13 PM   #6
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 565
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by SMDFlea View Post
The problem could be the bios ,do you have a bios programmer .
I agree with SMDFlea most likely BIOS issue check all the Big Gray Coils for Voltage and tell us what’s missing, try to find basic knowledge of how SMD component working & testing@ how to used multimeter

Last edited by techtiger; 03-30-2019 at 01:26 PM..
techtiger is offline   Reply With Quote
Old 03-30-2019, 02:40 PM   #7
mosfetratus
Sure Not
 
Join Date: Feb 2019
City & State: CapCity
My Country: Resistron
I'm a: Knowledge Seeker
Posts: 62
Default Re: Asus x751lk - first repair attempt

Could be faulty RAM too. Or just need to reset them in place.
mosfetratus is offline   Reply With Quote
Old 03-31-2019, 04:07 AM   #8
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by techtiger View Post
I agree with SMDFlea most likely BIOS issue check all the Big Gray Coils for Voltage and tell us what’s missing, try to find basic knowledge of how SMD component working & testing@ how to used multimeter
Hello,

I have checked all the coils and all the voltages seems to be present
1.4 around the disk port
0.9 2-coils around the nvidia gpu
1.7 around the cpu
3.3
5.0

bios chip has 3.3 (if that matters) at pin 1,2,3,7 and 8 when the computer is on.

I have tried with and without the ram (it has 1 stick and 8 pads soldered directly on the motherboard.
alloallo is offline   Reply With Quote
Old 03-31-2019, 04:10 AM   #9
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by ktmmotocross View Post
if u want to learn u must start with basics to be able to understand how it works
any suggestion where to start?
alloallo is offline   Reply With Quote
Old 03-31-2019, 04:31 AM   #10
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by SMDFlea View Post
The problem could be the bios ,do you have a bios programmer .
Not yet, but I'm looking to get one from ebay
alloallo is offline   Reply With Quote
Old 03-31-2019, 05:25 AM   #11
ktmmotocross
Boardkiller
 
ktmmotocross's Avatar
 
Join Date: Feb 2014
City & State: slovakia
My Country: slovakia
Line Voltage: 230VAC 50Hz
I'm a: Hobbyist Tech
Posts: 1,743
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by alloallo View Post
any suggestion where to start?
what gpu u have in it?
ktmmotocross is offline   Reply With Quote
Old 03-31-2019, 06:18 AM   #12
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Re: Asus x751lk - first repair attempt

It has GTX 870M N15P-GT-A2 (soldered to the motherboard)
alloallo is offline   Reply With Quote
Old 03-31-2019, 06:20 AM   #13
ktmmotocross
Boardkiller
 
ktmmotocross's Avatar
 
Join Date: Feb 2014
City & State: slovakia
My Country: slovakia
Line Voltage: 230VAC 50Hz
I'm a: Hobbyist Tech
Posts: 1,743
Default Re: Asus x751lk - first repair attempt

that can be problem. if u have allpwrgd signal


but with that great laptop i dont recommend u to repairing it for yourself. better give it to good service where is able to reball GPUs. they do diagnose and if it is in GPU they can reball it

Last edited by ktmmotocross; 03-31-2019 at 06:22 AM..
ktmmotocross is offline   Reply With Quote
Old 03-31-2019, 07:02 AM   #14
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by ktmmotocross View Post
that can be problem. if u have allpwrgd signal


but with that great laptop i dont recommend u to repairing it for yourself. better give it to good service where is able to reball GPUs. they do diagnose and if it is in GPU they can reball it
OK.. I will try to get someone who will reball the chip for me.

Will post the results here.
alloallo is offline   Reply With Quote
Old 03-31-2019, 07:55 AM   #15
SMDFlea
Badcaps Veteran
 
Join Date: Jan 2018
City & State: York
My Country: UK
I'm a: Knowledge Seeker
Posts: 2,280
Default Re: Asus x751lk - first repair attempt

Flash a new bios first, rule out the easiest things .
SMDFlea is offline   Reply With Quote
Old 03-31-2019, 09:06 AM   #16
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by SMDFlea View Post
Flash a new bios first, rule out the easiest things .
any suggestion for bios programmer?

Ebay has unlimited options available
alloallo is offline   Reply With Quote
Old 03-31-2019, 10:59 AM   #17
ktmmotocross
Boardkiller
 
ktmmotocross's Avatar
 
Join Date: Feb 2014
City & State: slovakia
My Country: slovakia
Line Voltage: 230VAC 50Hz
I'm a: Hobbyist Tech
Posts: 1,743
Default Re: Asus x751lk - first repair attempt

cheapest CH341A will be enough, but check if u have 3 or 1.8V bios chip and if u have 1.8V buy it with adapter for 1.8V

on ali is about 2euros

and offcourse u will need solder iron or beter hotair station

Last edited by ktmmotocross; 03-31-2019 at 11:01 AM..
ktmmotocross is offline   Reply With Quote
Old 03-31-2019, 01:12 PM   #18
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 565
Default Re: Asus x751lk - first repair attempt

Quote:
Originally Posted by alloallo View Post
Hello,

I have checked all the coils and all the voltages seems to be present
1.4 around the disk port
0.9 2-coils around the nvidia gpu
1.7 around the cpu
3.3
5.0

bios chip has 3.3 (if that matters) at pin 1,2,3,7 and 8 when the computer is on.

I have tried with and without the ram (it has 1 stick and 8 pads soldered directly on the motherboard.
test this points , what is the SIO IC ITEXXXX any one have the Schematic for this Mob,try to flach bios
Attached Images
File Type: jpg s-l1600.jpg (298.7 KB, 13 views)

Last edited by techtiger; 03-31-2019 at 01:13 PM..
techtiger is offline   Reply With Quote
Old 03-31-2019, 01:59 PM   #19
alloallo
New Member
 
Join Date: Mar 2019
City & State: Slovenia
My Country: Slovenia
I'm a: Knowledge Seeker
Posts: 13
Default Re: Asus x751lk - first repair attempt

Schematics attached

SIO IT8585E

I have measured the point you wanted. All the volts are as you wrote.

the most top coil in the yellow is 16.8v

voltage on smaller caps at rams are 0.7v. At the biger ones there is 1.4v
Attached Files
File Type: rar X751LK2.0.rar (162.8 KB, 9 views)
alloallo is offline   Reply With Quote
Old 04-01-2019, 06:23 AM   #20
mcplslg123
Badcaps Veteran
 
Join Date: Jun 2015
City & State: siliguri
My Country: india
Line Voltage: 220vac,60hz
I'm a: Student Tech
Posts: 1,668
Default Re: Asus x751lk - first repair attempt

I agrre with @smdflea. It seems like bios issue.
mcplslg123 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 04:35 PM.
Did you find this forum helpful?