Badcaps.net Forum
Go Back   Badcaps Forums > Motherboards with Bad Capacitors > All Others Motherboards
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-22-2015, 02:39 PM   #1
sickboy
New Member
 
Join Date: Jun 2015
City & State: England
My Country: UK
I'm a: Knowledge Seeker
Posts: 8
Default Apple MacBook Pro 820-2530

Hi everyone,
I'm needing some guidance tracking down this fault.
The logic board starts up with fan spinning full speed, and originally I thought it was just a backlight problem as there's no input voltage on the backlight driver chip as well as no enable voltage - Although there is 12v at the fuse F9800.

However when I shine a light at the back of the screen there doesn't seem to be any video there either. Also there's no chime when it starts.

I have the schematic and matching boardview file, and using this I seem to have all the correct power rails apart from the missing power at U9701.

This rail reads around 400k ohms when measured to ground so I'm not sure if that would count as short? I'm also not sure if a short on this rail would stop the video and the chime??

Any help GREATLY appreciated !
sickboy is offline   Reply With Quote
Old 06-26-2015, 10:55 AM   #2
Macman1974
New Member
 
Join Date: Jun 2015
City & State: Arlington, Texas
My Country: USA
I'm a: Knowledge Seeker
Posts: 4
Default Re: Apple MacBook Pro 820-2530

I tried resetting or the a Pram reset? Hey try taking a resistor off of the board before the LED driver and see what side you have a short on that will at least help pinpoint which direction you need to go and trace the short from.
Macman1974 is offline   Reply With Quote
Old 10-03-2017, 04:48 PM   #3
horiparts
New Member
 
Join Date: Mar 2017
City & State: Balneário Camboríu/ Santa Catarina
My Country: Brazil
I'm a: Knowledge Seeker
Posts: 4
Default Re: Apple MacBook Pro 820-2530

I received this Macbook used by another technical repair and
doesnt came green light and no started,
now we can start but dont show v-core.

Someone have a indication what can be the problem??
horiparts is offline   Reply With Quote
Old 10-04-2017, 06:48 AM   #4
kc8adu
Super Moderator
 
kc8adu's Avatar
 
Join Date: Nov 2003
City & State: dayton ohio
My Country: U.S.A!
Line Voltage: 12vdc,120/240vac,480vac 3ph on my bench
I'm a: Professional Tech
Posts: 8,172
Default Re: Apple MacBook Pro 820-2530

infamous nvidia gpu death.
kc8adu is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2017
Powered by vBulletin ®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 12:49 AM.

Did you find this forum helpful?