Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting & Designing Networks
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-16-2018, 09:01 AM   #1
metalrise
New Member
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 8
Default Boot loop TP-Link Archer C9 v1 (Europe)

Boot loop TP-Link Archer C9 v1 (Europe)

Hello,

I have a TP-Link Archer C9 v1 that is stuck in a boot loop after beeing unplug for 2 weeks. The symptom is: the power LED is blinking, after a few seconds all the leds are on, afterwards the all the led are off and power LED is again blinking.

What I tried with no success:

1) UNBRICK/Recovery TP-Link Archer C9 WIFI Router Without A Serial Connection How To (The tutorial posted by Richard Lloyd)
https://www.youtube.com/watch?v=AU8RyW82Z2M

Same symptoms using the c9v1_un-up-ver4-1-0-P31[20160517-rel35411].bin from the TP Link Archer C9 V1 Europe support page

2) UNBRICK/Recovery TP-Link Archer C9 Router (Version 1) Step-By-Step Guide Using Serial/USB Connection (The tutorial posted by Richard Lloyd)
https://www.youtube.com/watch?v=fme7kwTkttk

Again, the same symptoms using flash0.trx and mtd3.bin posted in the description section

3) Flashing the memory

Tools used:
CH341A (Black version) moded for 3.3V
The dump posted by Heinz on the Polish TP-Link forum (https://tplinkforum.pl/t/archer-c9-v1/8191)


After removing the heatsink I observed that instead of having a Spansion FL128SAIF00 serial flash memory, on the board it was a WinBond 25Q128FVFG serial flash memory.

Even with this surprise, i continued to desolder the memory.

1st attempt
Programming with CH341A programmer software v1.29
-erase, write, verify, saved the bin and compared with C9-factoryFullFlash.bin, all ok, no errors or differences in the bin files.

Result: the same symptom

2nd attempt
On CentOS 7 with flashrom
-erase, write, verify the memory with C9-factoryFullFlash.bin, all ok no errors.

Result: the same symptom


For both attempts the memory was written outside the PCB and resoldered after each flashing.


Now the weird part, if I flash with the latest stable OpenWRT build via tftpd, the router starts. WAN ok, LAN OK, USB ports ok, except for the wireless because the router has a Broadcom radio.


Basically I've run out of ideas how the make the router function with the original firmware, any help/suggestion will be appreciated.

Last edited by metalrise; 09-16-2018 at 09:02 AM..
metalrise is offline   Reply With Quote
Old 09-16-2018, 02:37 PM   #2
CapLeaker
Leaking Member
 
CapLeaker's Avatar
 
Join Date: Dec 2014
City & State: Atlantic Canada
My Country: Canada
Line Voltage: Ground, 0Hz
I'm a: Hobbyist Tech
Posts: 3,980
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

I didn't look at these links, but did you try to clear the NVRAM yet?
CapLeaker is offline   Reply With Quote
Old 09-17-2018, 05:22 AM   #3
metalrise
New Member
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 8
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

How?

With the original firmware uploaded via tftpd or with ch341a, the router its stuck in the boot loop.

For every attempt I've tried to hold hold the reset button to clear the settings.
metalrise is offline   Reply With Quote
Old 09-17-2018, 02:01 PM   #4
metalrise
New Member
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 8
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

Managed to hook up the serial console and erased the nvram

Code:
CFE> nvram erase
*** command status = 0
metalrise is offline   Reply With Quote
Old 09-17-2018, 02:07 PM   #5
metalrise
New Member
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 8
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

Serial boot log
Code:
Digital core power voltage set to 1.0V
Decompressing...done


CFE version 6.37.14.93 (r469350) based on BBP 1.0.37 for BCM947XX (32bit,SP,)
Build Date: Wed Nov  4 09:11:46 CST 2015 (root@jji315)
Copyright (C) 2000-2008 Broadcom Corporation.

Init Arena
Init Devs.
Boot partition size = 262144(0x40000)
DDR Clock: 400 MHz
Info: DDR frequency set from clkfreq=1000,*800*
Warning: invalid DDR setting of 800 MHz ignored. DDR frequency will be set to 400 MHz.
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.14.93 (r469350)
CPU type 0x0: 1000MHz
Tot mem: 131072 KBytes

CFE mem:    0x00F00000 - 0x02F80F74 (34082676)
Data:       0x00F48C54 - 0x00F49128 (1236)
BSS:        0x00F49138 - 0x00F7EF74 (220732)
Heap:       0x00F7EF74 - 0x02F7EF74 (33554432)
Stack:      0x02F7EF74 - 0x02F80F74 (8192)
Text:       0x00F00000 - 0x00F3F398 (258968)

Committing NVRAM...done
Waiting for reset button release...donDigital core power voltage set to 1.0V
Decompressing...done
Digital core power voltage set to 1.0V

SHMOO VER 1.13

PKID07DC06011801080000000000001A103F01000000

S300001BF
00001200


RDLYW0 00000004

RDENW0 00000028

RDQSW0

    0000000000111111111122222222223333333333444444444455555555556666
    0123456789012345678901234567890123456789012345678901234567890123
 00 -------+++++++++++++++++++++++X++++++++++++++++++++++-----------
 01 ----------++++++++++++++++++++++++X+++++++++++++++++++++++------
 02 -----------+++++++++++++++++++++X+++++++++++++++++++++----------
 03 ------++++++++++++++++++++++++X++++++++++++++++++++++++---------
 04 ----+++++++++++++++++++++++X++++++++++++++++++++++--------------
 05 --------++++++++++++++++++++++++X++++++++++++++++++++++++-------
 06 -----+++++++++++++++++++++++X+++++++++++++++++++++++------------
 07 ----------++++++++++++++++++++++++X+++++++++++++++++++++++------
 08 ----+++++++++++++++++++++++X+++++++++++++++++++++++-------------
 09 ------++++++++++++++++++++++++X++++++++++++++++++++++++---------
 10 --++++++++++++++++++++++++X+++++++++++++++++++++++--------------
 11 ------++++++++++++++++++++++++X+++++++++++++++++++++++----------
 12 ---+++++++++++++++++++++++X+++++++++++++++++++++++--------------
 13 -------++++++++++++++++++++++++X+++++++++++++++++++++++---------
 14 ------++++++++++++++++++++++X++++++++++++++++++++++-------------
 15 -------++++++++++++++++++++++++X+++++++++++++++++++++++---------


PW0

    0000000000111111111122222222223333333333444444444455555555556666
    0123456789012345678901234567890123456789012345678901234567890123
 00 -----++++++++++++++++++++++++X+++++++++++++++++++++++-----------
 01 ------++++++++++++++++++++++++++X++++++++++++++++++++++++++-----
 02 -------++++++++++++++++++++++++X+++++++++++++++++++++++---------
 03 ---++++++++++++++++++++++++++X+++++++++++++++++++++++++---------
 04 +++++++++++++++++++++++++X++++++++++++++++++++++++--------------
 05 ----++++++++++++++++++++++++++X++++++++++++++++++++++++++-------
 06 --+++++++++++++++++++++++++X++++++++++++++++++++++++------------
 07 -----++++++++++++++++++++++++++X++++++++++++++++++++++++++------
 08 -+++++++++++++++++++++++++X++++++++++++++++++++++++-------------
 09 --++++++++++++++++++++++++++X+++++++++++++++++++++++++----------
 10 +++++++++++++++++++++++++X++++++++++++++++++++++++--------------
 11 ---+++++++++++++++++++++++++X+++++++++++++++++++++++++----------
 12 +++++++++++++++++++++++++X++++++++++++++++++++++++--------------
 13 ----++++++++++++++++++++++++++X+++++++++++++++++++++++++--------
 14 ---++++++++++++++++++++++++X+++++++++++++++++++++++-------------
 15 ----++++++++++++++++++++++++++X+++++++++++++++++++++++++--------


NW0

    0000000000111111111122222222223333333333444444444455555555556666
    0123456789012345678901234567890123456789012345678901234567890123
 00 -------++++++++++++++++++++++X++++++++++++++++++++++------------
 01 -----------+++++++++++++++++++++++X+++++++++++++++++++++++------
 02 ----------++++++++++++++++++++++X+++++++++++++++++++++----------
 03 ------+++++++++++++++++++++++++X++++++++++++++++++++++++--------
 04 -----++++++++++++++++++++++X++++++++++++++++++++++--------------
 05 --------++++++++++++++++++++++++X+++++++++++++++++++++++--------
 06 -----+++++++++++++++++++++++X+++++++++++++++++++++++------------
 07 ----------++++++++++++++++++++++++X+++++++++++++++++++++++------
 08 ----++++++++++++++++++++++++X+++++++++++++++++++++++------------
 09 ------++++++++++++++++++++++++X+++++++++++++++++++++++----------
 10 ---++++++++++++++++++++++++X+++++++++++++++++++++++-------------
 11 ------++++++++++++++++++++++++X++++++++++++++++++++++++---------
 12 --+++++++++++++++++++++++++X++++++++++++++++++++++++------------
 13 ------++++++++++++++++++++++++X++++++++++++++++++++++++---------
 14 ------+++++++++++++++++++++++X++++++++++++++++++++++------------
 15 --------+++++++++++++++++++++++X+++++++++++++++++++++++---------


WRDQW0

    0000000000111111111122222222223333333333444444444455555555556666
    0123456789012345678901234567890123456789012345678901234567890123
 00 ++++++++++++++++++++++X++++++++++++++++++++++------++++++++++++-
 01 +++++++++++++++++++++++X++++++++++++++++++++++-------++++++++++-
 02 +++++++++++++++++++++++X++++++++++++++++++++++-------++++++++++-
 03 +++++++++++++++++++++++X++++++++++++++++++++++-----++++++++++++-
 04 ++++++++++++++++++++X+++++++++++++++++++------------+++++++++++-
 05 +++++++++++++++++++++++X++++++++++++++++++++++------+++++++++++-
 06 ++++++++++++++++++++X++++++++++++++++++++-----------+++++++++++-
 07 +++++++++++++++++++++++X++++++++++++++++++++++-----++++++++++++-
 08 ++++++++++++++++++++X++++++++++++++++++++-----------+++++++++++-
 09 ++++++++++++++++++++++X++++++++++++++++++++++------++++++++++++-
 10 ++++++++++++++++++++X++++++++++++++++++++----------++++++++++++-
 11 ++++++++++++++++++++++X++++++++++++++++++++++-------+++++++++++-
 12 +++++++++++++++++++++X++++++++++++++++++++---------++++++++++++-
 13 +++++++++++++++++++++++X+++++++++++++++++++++++-------+++++++++-
 14 ++++++++++++++++++++++X++++++++++++++++++++++------++++++++++++-
 15 +++++++++++++++++++++++X++++++++++++++++++++++-------++++++++++-


WRDMW0 00000022
WRDMW0 00000021


ADDR

    0000000000111111111122222222223333333333444444444455555555556666
    0123456789012345678901234567890123456789012345678901234567890123
 00 ++++++++++++++++++S++++++++++++X++++++++++++++++++++++++++++++++

Decompressing...done


CFE version 6.37.14.93 (r469350) based on BBP 1.0.37 for BCM947XX (32bit,SP,)
Build Date: Wed Nov  4 09:11:46 CST 2015 (root@jji315)
Copyright (C) 2000-2008 Broadcom Corporation.

Init Arena
Init Devs.
Boot partition size = 262144(0x40000)
DDR Clock: 800 MHz
Info: DDR frequency set from clkfreq=1000,*800*
et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.14.93 (r469350)
CPU type 0x0: 1000MHz
Tot mem: 131072 KBytes

CFE mem:    0x00F00000 - 0x02F80F74 (34082676)
Data:       0x00F48C54 - 0x00F49128 (1236)
BSS:        0x00F49138 - 0x00F7EF74 (220732)
Heap:       0x00F7EF74 - 0x02F7EF74 (33554432)
Stack:      0x02F7EF74 - 0x02F80F74 (8192)
Text:       0x00F00000 - 0x00F3F398 (258968)
metalrise is offline   Reply With Quote
Old 09-17-2018, 02:07 PM   #6
metalrise
New Member
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 8
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

Code:
Device eth0:  hwaddr 00-90-4C-11-20-01, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
Loading: .... 4232512 bytes read
Entry at 0x00008000
Closing network.
Starting program at 0x00008000
console [ttyS0] enabled, bootconsole disabled
serial8250.0: ttyS1 at MMIO 0x18000400 (irq = 117) is a 16550
brd: module loaded
loop: module loaded
pflash: found no supported devices
bcmsflash: squash filesystem found at block 36
Creating 5 MTD partitions on "bcmsflash":
0x000000000000-0x000000040000 : "boot"
0x000000040000-0x000000240000 : "linux"
0x000000240000-0x000000ee0000 : "rootfs"
0x000000fe0000-0x000000ff0000 : "radio"
0x000000ff0000-0x000001000000 : "nvram"
nflash: found no supported devices
PPP generic driver version 2.4.2
NET: Registered protocol family 24
usbmon: debugfs is not available
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ehci_hcd 0000:00:0b.1: EHCI Host Controller
ehci_hcd 0000:00:0b.1: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:0b.1: irq 111, io mem 0x18021000
ehci_hcd 0000:00:0b.1: USB 0.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ohci_hcd 0000:00:0b.0: OHCI Host Controller
ohci_hcd 0000:00:0b.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:0b.0: irq 111, io mem 0x18022000
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
xhci_hcd 0000:00:0c.0: xHCI Host Controller
xhci_hcd 0000:00:0c.0: new USB bus registered, assigned bus number 3
xhci_hcd 0000:00:0c.0: irq 112, io mem 0x18023000
xhci_hcd 0000:00:0c.0: Failed to enable MSI-X
xhci_hcd 0000:00:0c.0: failed to allocate MSI entry
usb usb3: No SuperSpeed endpoint companion for config 1  interface 0 altsetting 0 ep 129: using minimum values
xHCI xhci_add_endpoint called for root hub
xHCI xhci_check_bandwidth called for root hub
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 1 port detected
nf_conntrack version 0.5.0 (1960 buckets, 7840 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP cubic registered
NET: Registered protocol family 10
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
Northstar brcmnand NAND Flash Controller driver, Version 0.1 (c) Broadcom Inc. 2012
brcmnand: found no supported devices
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing init memory: 216K
init started:  BusyBox v1.01 (2014.11.12-04:38+0000) multi-call binary
This board use 2.6.36
ctf: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
et_module_init: passivemode set to 0x0
et_module_init: txworkq set to 0x0
et_module_init: et_txq_thresh set to 0x0
si_doattach: incoming bus is PCI but it's a lie, switching to SI devid:0x4715
Found chip type NAI (0x3f00cf12)
Chipc: rev 42, caps 0x48000a, chipst 0x0 pmurev 0, pmucaps 0x0
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 6.37.14.93 (r469350)
xt_time: kernel timezone is -0000
u32 classifier
    Actions configured
L2TP core driver, V2.0
PPPoL2TP kernel driver, V2.0
PPTP driver version 0.8.3

 (none) armv7l #1 SMP PREEMPT Wed Nov 12 12:33:55 CST 2014 (none)
(none) login: ====>>>>@@@@@@size is 49340@@@@@@

start uclited
             ====>>>>*****total size is 49340******
check size inited
                 device eth0.1 entered promiscuous mode
device eth0 entered promiscuous mode
br0: port 1(eth0.1) entering forwarding state
br0: port 1(eth0.1) entering forwarding state
Attempt to kill tasklet from interrupt
device eth0 left promiscuous mode
br0: port 1(eth0.1) entering forwarding state
device eth0 entered promiscuous mode
br0: port 1(eth0.1) entering forwarding state
br0: port 1(eth0.1) entering forwarding state
br0: port 1(eth0.1) entering forwarding state
br0: port 1(eth0.1) entering forwarding state
br0: port 1(eth0.1) entering forwarding state
device eth0 left promiscuous mode
br0: port 1(eth0.1) entering forwarding state
device eth0 entered promiscuous mode
br0: port 1(eth0.1) entering forwarding state
br0: port 1(eth0.1) entering forwarding state
checkSizeThread 457 1 49340 49340
                                 ====>>>>DHCP start.dhcpc.c,dhcpcStart,1100
====>>>>DHCP end.dhcpc.c,dhcpcStart,1164
nf_conntrack_rtsp v0.6.21 loading
nf_nat_rtsp v0.6.21 loading
====>>>>hasBeenCalibrated: recover rftest items form radio

wl_module_init: msglevel set to 0x1
wl_module_init: msglevel2 set to 0x0
wl_module_init: phymsglevel set to 0x1
wl_module_init: passivemode set to 0x0
wl_module_init: txworkq set to 0x0
Found chip type AI (0x15134360)
Chipc: rev 43, caps 0x58680001, chipst 0x9a6d pmurev 17, pmucaps 0x10a22b11
srom rev:0
HTAVAIL is set, so not updating BBPLL Frequency
Changing rsrc 6 res_updn_timer to 0x100001
wl0: wlc_attach: Overriding device id: 0x43a1 instead of 0x4360
Overriding device id = 0x43a1
wl0: wlc_bmac_phy_reset: band not yet set
wlc_bmac_attach, deviceid 0x43a1 nbands 1
wl0: wlc_bmac_phy_reset: band not yet set
wl0: wlc_bmac_attach: chiprev 3 corerev 42 cccap 0x58680001 maccap 0x30518c05 band 2.4G, phy_type 11 phy_rev 1
wl0: wlc_stf_txcore_shmem_write: No clock
wl0: wlc_ampdu_tx_set: AGG Mode = MAC+AQM txmaxpkts 1024
wl0: online cpus 2
eth1: Broadcom BCM4360 802.11 Wireless Controller 6.37.14.93 (r469350 WLTEST) (Compiled in . at 12:35:49 on Nov 12 2014)
Found chip type AI (0x15134360)
Chipc: rev 43, caps 0x58680001, chipst 0x9a6d pmurev 17, pmucaps 0x10a22b11
srom rev:0
Overriding boardvendor: 0x14e4 instead of 0x14e4
HTAVAIL is set, so not updating BBPLL Frequency
Changing rsrc 6 res_updn_timer to 0x100001
wl1: wlc_attach: Overriding device id: 0x43a2 instead of 0x4360
Overriding device id = 0x43a2
wl1: wlc_bmac_phy_reset: band not yet set
wlc_bmac_attach, deviceid 0x43a2 nbands 1
wl1: wlc_bmac_phy_reset: band not yet set
wl1: wlc_bmac_attach: chiprev 3 corerev 42 cccap 0x58680001 maccap 0x30518c05 band 5G, phy_type 11 phy_rev 1
wl1: wlc_stf_txcore_shmem_write: No clock
wl1: wlc_ampdu_tx_set: AGG Mode = MAC+AQM txmaxpkts 1024
wl1: online cpus 2
eth2: Broadcom BCM4360 802.11 Wireless Controller 6.37.14.93 (r469350 WLTEST) (Compiled in . at 12:35:49 on Nov 12 2014)
device eth1 entered promiscuous mode
Changing rsrc 6 res_updn_timer to 0x100001
wl0: wlc_enable_probe_req: state down, deferring setting of host flags
br0: port 2(eth1) entering forwarding state
br0: port 2(eth1) entering forwarding state
====>>>>start: eth1.

wl0: wlc_iovar_op: BCME -20 (Bad Channel)
wl0: wlc_ampdu_tx_set: AGG Mode = MAC+AQM txmaxpkts 1024
wl0: wlc_enable_probe_req: state down, deferring setting of host flags
device eth2 entered promiscuous mode
Changing rsrc 6 res_updn_timer to 0x100001
wl1: wlc_enable_probe_req: state down, deferring setting of host flags
br0: port 3(eth2) entering forwarding state
br0: port 3(eth2) entering forwarding state
====>>>>start: eth2.
metalrise is offline   Reply With Quote
Old 09-17-2018, 02:09 PM   #7
metalrise
New Member
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 8
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

Code:
wl1: wlc_iovar_op: BCME -20 (Bad Channel)
wl1: wlc_ampdu_tx_set: AGG Mode = MAC+AQM txmaxpkts 1024
wl1: wlc_enable_probe_req: state down, deferring setting of host flags
acsd: scan in progress ...
                          acsd: scan in progress ...
                                                    acsd: scan in progress ...
                                                                              acsd: scan in progress ...
                                                                                                        acsd: scan in progress ...
                                                                                                                                  acsd: scan in progress ...
      acsd: scan in progress ...
                                acsd: scan in progress ...
                                                          acsd: scan in progress ...
                                                                                    acsd: scan in progress ...
                                                                                                              acsd: scan in progress ...
                                                                                                                                        acsd: selected channel spec: 0x100b
                     acsd: Adjusted channel spec: 0x100b
                                                        acsd: selected DFS-exit channel spec: 0x100b
                                                                                                    acsd: selected channel spec: 0x100b
                                                                                                                                       acsd: Adjusted channel spec: 0x100b
                    acsd: selected channel spec: 0x100b
                                                       acsd: scan in progress ...
                                                                                 acsd: scan in progress ...
                                                                                                           acsd: scan in progress ...
                                                                                                                                     acsd: scan in progress ...
         acsd: scan in progress ...
                                   acsd: scan in progress ...
                                                             acsd: scan in progress ...
                                                                                       acsd: scan in progress ...
                                                                                                                 acsd: scan in progress ...
                                                                                                                                           acsd: selected channel spec: 0xe09b
                        acsd: Adjusted channel spec: 0xe09b
                                                           acsd: selected DFS-exit channel spec: 0xe09b
                                                                                                       acsd: selected channel spec: 0xe09b
                                                                                                                                          acsd: Adjusted channel spec: 0xe09b
                       acsd: selected channel spec: 0xe09b
                                                          wl0: link up (eth1)
wl1: link up (eth2)
====>>>>task[6151]: start ok!

====>>>>startup: start ok!
After "====>>>>startup: start ok!", the router reboots itself, and the startup process in repeated
metalrise is offline   Reply With Quote
Old 09-17-2018, 04:44 PM   #8
metalrise
New Member
 
Join Date: Jul 2010
City & State: Bucharest
My Country: Romania
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 8
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

It was never a firmware or a memory issue. The problem was due to the current draw of the wireless chip at boot.

The power supply is rated at 9V with 0.6A, but during the router startup the current reached 0.8A, the voltage of the power supply dropped well below 9V (aprox 3.5V).

I’ve managed to boot up the router and upgrade with the latest firmware using a lab power supply.

Next steps:
-modify the WAN MAC address with the one on the label
-open the TP-Link power supply to see some bulging capacitors

Last edited by metalrise; 09-17-2018 at 04:46 PM..
metalrise is offline   Reply With Quote
Old 09-20-2018, 12:21 PM   #9
CapLeaker
Leaking Member
 
CapLeaker's Avatar
 
Join Date: Dec 2014
City & State: Atlantic Canada
My Country: Canada
Line Voltage: Ground, 0Hz
I'm a: Hobbyist Tech
Posts: 3,980
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

damn power supplies... After reading post 7, I wanted to say "check the PSU"... glad you got it resolved though.
CapLeaker is offline   Reply With Quote
Old 04-30-2019, 04:22 PM   #10
Retro-Hipster
Tinkerer
 
Retro-Hipster's Avatar
 
Join Date: Apr 2019
City & State: Salt Lake City
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Hobbyist Tech
Posts: 106
Default Re: Boot loop TP-Link Archer C9 v1 (Europe)

Nice job! Glad you got it working after so much work. (Sorry it turned out to be something like a psu. lol)

Quote:
Originally Posted by metalrise View Post
It was never a firmware or a memory issue. The problem was due to the current draw of the wireless chip at boot.

The power supply is rated at 9V with 0.6A, but during the router startup the current reached 0.8A, the voltage of the power supply dropped well below 9V (aprox 3.5V).

I’ve managed to boot up the router and upgrade with the latest firmware using a lab power supply.

Next steps:
-modify the WAN MAC address with the one on the label
-open the TP-Link power supply to see some bulging capacitors
__________________


“Men always seem to think about their
past before they die, as though they were
frantically searching for proof that they
truly lived.”
– Jet (Cowboy Bebop) -
Retro-Hipster is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 03:39 PM.
Did you find this forum helpful?