Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 02-21-2021, 05:40 AM   #1
Gabr
New Member
 
Join Date: Feb 2021
City & State: Zurich
My Country: Switserland
I'm a: Knowledge Seeker
Posts: 10
Default MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Hi All,

I have a problem with a Macbook Air from 2017 (820-00165-A), after 10 seconds the fan spin starts to rise and reaches maximum speed relatively quick. I have checked the usual culprits like U5800 and U5620 camera connector. I don't see any water damage anywhere, but this laptop has been attempted to be repaired before. (a screw was missing).

I also tried a reflow of the SMC without success.
Trackpad also looks fine.
My main question at this point is I notice that gl3219 (U4500) gets quite hot relatively quickly after start-up going over 40 degrees celsius even reaching 50 degrees.
Is this normal? Usb ports work fine and I don't see a relation with SMBUS_SMC_1_S0_SDA, so I am in doubt if it even matters.

TG Pro tells me there is a potential problem with the optical drive sensor, which I don't understand.
Any help would be highly appreciated!
TIA
Gabr is offline   Reply With Quote
Old 02-21-2021, 07:15 AM   #2
mon2
Badcaps Veteran
 
mon2's Avatar
 
Join Date: Dec 2019
City & State: Windsor, Ontario
My Country: Canada
Line Voltage: 110VAC
I'm a: Knowledge Seeker
Posts: 212
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Try a PRAM reset. After a battery has been removed, the fan spin behaves like this. Hold down the attached keys on a power on and wait till the computer chimes 2 times, then let go.
Attached Images
File Type: jpg how-to-reset-Mac-PRAM.jpg (332.7 KB, 5 views)
mon2 is offline   Reply With Quote
Old 02-21-2021, 07:32 AM   #3
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,908
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Post screenshot of HWSensors https://bitbucket.org/RehabMan/os-x-...-2018-0915.zip
__________________
OpenBoardview — http://openboardview.org | IRC — #[email protected]
piernov is offline   Reply With Quote
Old 02-21-2021, 12:03 PM   #4
Gabr
New Member
 
Join Date: Feb 2021
City & State: Zurich
My Country: Switserland
I'm a: Knowledge Seeker
Posts: 10
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

See attached.
Attached Images
File Type: png Bildschirmfoto 2021-02-21 um 18.56.17.png (109.0 KB, 10 views)
File Type: png Bildschirmfoto 2021-02-21 um 19.01.27.png (127.1 KB, 11 views)
Gabr is offline   Reply With Quote
Old 02-21-2021, 12:13 PM   #5
Gabr
New Member
 
Join Date: Feb 2021
City & State: Zurich
My Country: Switserland
I'm a: Knowledge Seeker
Posts: 10
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Quote:
Originally Posted by mon2 View Post
Try a PRAM reset. After a battery has been removed, the fan spin behaves like this. Hold down the attached keys on a power on and wait till the computer chimes 2 times, then let go.
This didn't help.
Gabr is offline   Reply With Quote
Old 02-21-2021, 01:59 PM   #6
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,908
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Looks the issue is with the "Heatpipe" sensor on the LIO board.
piernov is offline   Reply With Quote
Old 02-21-2021, 02:17 PM   #7
Askic
Senior Member
 
Join Date: Sep 2018
City & State: Korce
My Country: Albania
I'm a: Knowledge Seeker
Posts: 101
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Quote:
Originally Posted by piernov View Post
Looks the issue is with the "Heatpipe" sensor on the LIO board.
Could you please what this is. Is it sensor that measure temperature of air flow from the heat sink?
Is it shown on the schematics?
Askic is offline   Reply With Quote
Old 02-21-2021, 02:20 PM   #8
Askic
Senior Member
 
Join Date: Sep 2018
City & State: Korce
My Country: Albania
I'm a: Knowledge Seeker
Posts: 101
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Quote:
Originally Posted by Gabr View Post
Hi All,

I have a problem with a Macbook Air from 2017 (820-00165-A), after 10 seconds the fan spin starts to rise and reaches maximum speed relatively quick. I have checked the usual culprits like U5800 and U5620 camera connector. I don't see any water damage anywhere, but this laptop has been attempted to be repaired before. (a screw was missing).

I also tried a reflow of the SMC without success.
Trackpad also looks fine.
My main question at this point is I notice that gl3219 (U4500) gets quite hot relatively quickly after start-up going over 40 degrees celsius even reaching 50 degrees.
Is this normal? Usb ports work fine and I don't see a relation with SMBUS_SMC_1_S0_SDA, so I am in doubt if it even matters.

TG Pro tells me there is a potential problem with the optical drive sensor, which I don't understand.
Any help would be highly appreciated!
TIA
I had similar issue except in my case 4 different sensors show 128 deg C. I also tried removing web cam wifi etc but that did‘t help.
Workaround was to install macs fan control app and to set control fan to automatic, to look for example cpu proximity between 20 and 80 deg C

Last edited by Askic; 02-21-2021 at 02:21 PM..
Askic is offline   Reply With Quote
Old 02-21-2021, 02:52 PM   #9
Gabr
New Member
 
Join Date: Feb 2021
City & State: Zurich
My Country: Switserland
I'm a: Knowledge Seeker
Posts: 10
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Quote:
Originally Posted by piernov View Post
Looks the issue is with the "Heatpipe" sensor on the LIO board.
That would be a bummer since I replaced the IO board a little while ago.
The PPBUS voltage at 8.3 looks a bit low. I notice however if I plug in the charger it goes up to 8.6v

Unfortunatly I don't have a schematic for the io board.
Gabr is offline   Reply With Quote
Old 02-21-2021, 02:54 PM   #10
Gabr
New Member
 
Join Date: Feb 2021
City & State: Zurich
My Country: Switserland
I'm a: Knowledge Seeker
Posts: 10
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Quote:
Originally Posted by Askic View Post
I had similar issue except in my case 4 different sensors show 128 deg C. I also tried removing web cam wifi etc but that did‘t help.
Workaround was to install macs fan control app and to set control fan to automatic, to look for example cpu proximity between 20 and 80 deg C

Thanks for hint, but when fan spin is high at startup I think usually the CPU is also throttled back. So fan control is not really a solution.
Gabr is offline   Reply With Quote
Old 02-21-2021, 03:06 PM   #11
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,908
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

Quote:
Originally Posted by Askic View Post
Could you please what this is. Is it sensor that measure temperature of air flow from the heat sink?
Is it shown on the schematics?
Yes. It is on the LIO board schematics, but that's not available for this LIO board. The 2012 one is available, it's slightly different but it also has this temperature sensor connected to the SMBUS.
piernov is offline   Reply With Quote
Old 02-22-2021, 04:12 PM   #12
Gabr
New Member
 
Join Date: Feb 2021
City & State: Zurich
My Country: Switserland
I'm a: Knowledge Seeker
Posts: 10
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

I have removed the thermal sensor (u4730) from the lio board and started the laptop. The heatpipe then shows 128 degrees. Which is the same as before.
This gives me the idea that its not the sensor that is the problem but the signal doesnt arrive at wherever it needs to be.
I am unable to figure out where this is pick up on the main board.
Looking at the flex cable I see no indication that it has an issue, maybe it does tho..

Any thoughts/help is highly appreciated
Gabr is offline   Reply With Quote
Old 02-23-2021, 03:46 AM   #13
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 2,908
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

A sensor that does not communicate because it has a problem, because there's an issue on the communication bus, or because it's missing may well show the same behaviour. No conclusion can be drawn here, but for sure it must be present on the board to work and during troubleshooting.

Can be caused by anything from a bad sensor, bad DC-in FFC connector on either board, bad DC-in FFC, bad pull-up on the SMC "2" SMBus, an issue with the SMC, a broken trace…
Just need to take some measurements and try another DC-in board and FFC to exclude that possibility.
piernov is offline   Reply With Quote
Old 02-23-2021, 06:48 AM   #14
Gabr
New Member
 
Join Date: Feb 2021
City & State: Zurich
My Country: Switserland
I'm a: Knowledge Seeker
Posts: 10
Default Re: MBA A1466 (820-00165-A) 2017 has high fan spin and hot GL3219

I will order a new FFC, and check the pull up SMC "2". Thanks for your posts Piernov in this thread so far.
Gabr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2021
Powered by vBulletin ®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:37 PM.
Did you find this forum helpful?