Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Printers, Copiers, Scanners and other Imaging & Printing Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 11-15-2020, 11:23 AM   #1
SuperAman
Member
 
Join Date: Dec 2018
City & State: Addis Ababa
My Country: Ethiopia
I'm a: Knowledge Seeker
Posts: 45
Default Epson L1300 printing 1 blank page with each job

I have an Epson L1300 printing 1 blank page with each job. It always prints a blank page first then prints the print job normally. It is doing this everytime something is printed. It is shared over a small network (installed on 1 pc via usb cable). It is doing this on all the computers.
SuperAman is offline   Reply With Quote
Old 11-25-2020, 12:11 PM   #2
SuperAman
Member
 
Join Date: Dec 2018
City & State: Addis Ababa
My Country: Ethiopia
I'm a: Knowledge Seeker
Posts: 45
Default Re: Epson L1300 printing 1 blank page with each job

I installed a new driver from epson website from 2015 and problem is solved.
SuperAman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2020
Powered by vBulletin ®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 04:28 AM.
Did you find this forum helpful?