Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-31-2013, 06:24 AM   #41
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

swapped the component circled in the image attached, (I believe this is PQ15) still same story

Regards
Attached Images
File Type: jpg 20130131_101910 - Copy.jpg (669.3 KB, 31 views)
grahamw01 is offline   Reply With Quote
Old 01-31-2013, 06:41 AM   #42
heavymachines
Badcaps Veteran
 
Join Date: Mar 2011
City & State: Muskegon, Michigan
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 1,026
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by grahamw01 View Post
swapped the component circled in the image attached, (I believe this is PQ15) still same story

Regards
where you getting the ic? from the other envy board? if so that is kinda pointless since that board is messing up as well.... or you getting it from random laptop boards?
heavymachines is offline   Reply With Quote
Old 01-31-2013, 07:06 AM   #43
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by heavymachines View Post
where you getting the ic? from the other envy board? if so that is kinda pointless since that board is messing up as well.... or you getting it from random laptop boards?
Yes from the other motherboard, but I believe the other board is broken because the GPU overheated. The charging circuit still works in the original.

Cheers
grahamw01 is offline   Reply With Quote
Old 01-31-2013, 12:11 PM   #44
opamp
Senior Member
 
Join Date: Dec 2012
City & State: Texas
My Country: united states
I'm a: Hobbyist Tech
Posts: 161
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by grahamw01 View Post
swapped the component circled in the image attached, (I believe this is PQ15) still same story

Regards
what do you mean same story? are you still getting 19v on pin 14? did you test the ic before putting it in?
opamp is offline   Reply With Quote
Old 01-31-2013, 12:56 PM   #45
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by opamp View Post
what do you mean same story? are you still getting 19v on pin 14? did you test the ic before putting it in?
yes, and also the other motherboard still managed to charge the battery with the swapped component,

thanks
grahamw01 is offline   Reply With Quote
Old 01-31-2013, 05:34 PM   #46
heavymachines
Badcaps Veteran
 
Join Date: Mar 2011
City & State: Muskegon, Michigan
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 1,026
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by grahamw01 View Post
Yes from the other motherboard, but I believe the other board is broken because the GPU overheated. The charging circuit still works in the original.

Cheers
ok i could have swore you said both boards stopped charging ...but ok
heavymachines is offline   Reply With Quote
Old 01-31-2013, 06:14 PM   #47
heavymachines
Badcaps Veteran
 
Join Date: Mar 2011
City & State: Muskegon, Michigan
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 1,026
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by heavymachines View Post
ok i could have swore you said both boards stopped charging ...but ok

yeah on post#19...
heavymachines is offline   Reply With Quote
Old 01-31-2013, 06:38 PM   #48
heavymachines
Badcaps Veteran
 
Join Date: Mar 2011
City & State: Muskegon, Michigan
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 1,026
Default Re: HP Envy 15 cannot charge battery!

ok ...plug in bad board good charger and do some live test without powering it on lol not that it will but, been looking at this data sheet page 42 and i realized there is 2 battery connectors we either have one of 2 things going on ..it either a failed ic to primary battery on cn5 or the stupid thing is not switching from battery 2 back to battery 1....on your kinda good board.........


so anyways lets charge your battery with the "bad" board good charging system and good board with bad charging system and do some live testing on these ic's and report what is live and what is not...specific voltage is not a critical at this point because i want to get an idea how this beast is thinking when power off and just charging.... please check this list of board addresses at their corresponding ic's and tell me what is live and what is not... and make a list for each board and please title it with "bad board good charging" and list below that and "good board with bad charging" with list below that and their board address with voltage or no voltage next to board addresses...

test these...
pq49
pq45
pq35
pq3
pq10
pu14
pq7
pq2
pq34
pq36

i have my suspicions but to early to fault anything at point let me know with above ic's and i will give you what to test next.... if necessary check each pin on each ic to make sure it is "dead" no voltage if you find any that are lifeless for voltage...

Last edited by heavymachines; 01-31-2013 at 06:49 PM.. Reason: details
heavymachines is offline   Reply With Quote
Old 02-01-2013, 06:04 AM   #49
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

thank you! I have found all the components, a few of them I don't think it is possible for me to test though.

I forgot to mention that the 'bad board good charge' is charging again.. U33 gets really hot though, I am scared to leave it on for too long..
grahamw01 is offline   Reply With Quote
Old 02-01-2013, 06:50 AM   #50
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

okay, well it is not obvious where PQ2 is, could you please inform how many pins, PQ2, PQ7, PQ3 and PQ10 should have?

Anyway the breakdown, both boards turned off, not charging but plugged in.

good board bad charge, bad board good charge:

PQ49: 8.3V ------------- 8.3V
PQ45: 3.4V ------------- 19.2V
PQ35: 18.6V ------------ 12.3V
PQ3: 19V and 3V ------ 3V
PQ10: 19V and 3V ------ 19V
PQ14: 3V --------------- 3V
PQ7: 18V ------------- 12.3V
PQ2: - -
PQ36: 19.5V ----------- ~mV
grahamw01 is offline   Reply With Quote
Old 02-01-2013, 09:46 PM   #51
heavymachines
Badcaps Veteran
 
Join Date: Mar 2011
City & State: Muskegon, Michigan
My Country: United States
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 1,026
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by grahamw01 View Post
thank you! I have found all the components, a few of them I don't think it is possible for me to test though.

I forgot to mention that the 'bad board good charge' is charging again.. U33 gets really hot though, I am scared to leave it on for too long..
what voltage is u33 getting on each board? and part number?

Last edited by heavymachines; 02-01-2013 at 09:55 PM..
heavymachines is offline   Reply With Quote
Old 02-01-2013, 11:00 PM   #52
opamp
Senior Member
 
Join Date: Dec 2012
City & State: Texas
My Country: united states
I'm a: Hobbyist Tech
Posts: 161
Default Re: HP Envy 15 cannot charge battery!

U11 Pin 14 should be at 0volts with out battery and 12v with battery. That's why the good board keeps cycling and the bad board get U33 hot, which by the way is going to get fried if you keep plugging in the ac adapter.
opamp is offline   Reply With Quote
Old 02-02-2013, 01:49 AM   #53
Tuomo
Senior Member
 
Join Date: Jan 2013
City & State: Sievi
My Country: Finland
I'm a: Professional Tech
Posts: 165
Default Re: HP Envy 15 cannot charge battery!

PU11 Pin 23 should be 0 so there is no voltage PL6 or +BATCHG.
Tuomo is offline   Reply With Quote
Old 02-02-2013, 04:21 AM   #54
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by heavymachines View Post
what voltage is u33 getting on each board? and part number?
u33 is an ene kb3926qf d2, i checked a few voltages around the chip and they were both the same at about 3.3V, but I don't know what power is going into the chip, there is over 100 pins
grahamw01 is offline   Reply With Quote
Old 02-02-2013, 04:25 AM   #55
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by opamp View Post
U11 Pin 14 should be at 0volts with out battery and 12v with battery. That's why the good board keeps cycling and the bad board get U33 hot, which by the way is going to get fried if you keep plugging in the ac adapter.
okay, so whats my next move?

I think U33 getting hot is something new and something I have done.. with in seconds if i lick my finger and touch the top of it it will boil off the liquid, but before attempting to fix the second board I used the original one to charge my battery for a few hours at a time.

Thanks
grahamw01 is offline   Reply With Quote
Old 02-02-2013, 04:26 AM   #56
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by Tuomo View Post
PU11 Pin 23 should be 0 so there is no voltage PL6 or +BATCHG.
Thank's Tuomo for joining this topic, I will look into it
grahamw01 is offline   Reply With Quote
Old 02-02-2013, 06:22 AM   #57
Tuomo
Senior Member
 
Join Date: Jan 2013
City & State: Sievi
My Country: Finland
I'm a: Professional Tech
Posts: 165
Default Re: HP Envy 15 cannot charge battery!

EC chip quide charger chip when chargin by PU11 PIN2 if that PIN changes its state ON/OFF.

When high 3.3V OFF and ON 0V.

It is possible test which chip problem is PU11 or EC chip.

This can tested by removing PR 155 and take somewhere else 3.3V PU11 PIN 2.

When there is 3.3V ( OFF ) PL6 should be 0V no chargin.

Last edited by Tuomo; 02-02-2013 at 06:58 AM..
Tuomo is offline   Reply With Quote
Old 02-02-2013, 06:44 AM   #58
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by Tuomo View Post
You can also remove PR155 if there is no voltage on PL6 problem is EC chip.
sorry what is ec chip?
thanks!
grahamw01 is offline   Reply With Quote
Old 02-02-2013, 06:56 AM   #59
Tuomo
Senior Member
 
Join Date: Jan 2013
City & State: Sievi
My Country: Finland
I'm a: Professional Tech
Posts: 165
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by grahamw01 View Post
sorry what is ec chip?
thanks!
Just edit my early post when noticed signal OFF = 3.3V chargin OFF.

EC chip is U33 which control PU11 chargin chip.
Tuomo is offline   Reply With Quote
Old 02-02-2013, 07:01 AM   #60
grahamw01
Badcaps Veteran
 
Join Date: Jan 2013
City & State: London
My Country: UK
I'm a: Knowledge Seeker
Posts: 254
Default Re: HP Envy 15 cannot charge battery!

Quote:
Originally Posted by Tuomo View Post
Just edit my early post when noticed signal OFF = 3.3V chargin OFF.

EC chip is U33 which control PU11 chargin chip.
Ah yes, well the reason I thought that chip is okay is because it also controls a lot of other things like USB right? The laptop works absolutely fine, either running off battery or just with the adaptor plugged in, it just wont charge, and I cant have the battery in when running off the AC because of the cycling which I am sure is not good for it..

Also, I am not sure if it is a big problem, but the voltage from PR155 is 3.03V not 3.3V. It is 3.33V on the motherboard that will charge though!

Cheers
grahamw01 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 05:04 AM.
Did you find this forum helpful?