Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-10-2014, 03:58 PM   #61
rievax_60
Badcaps Veteran
 
Join Date: May 2012
City & State: mackay
My Country: australia
Line Voltage: 240
I'm a: Hobbyist Tech
Posts: 893
Default Re: Toshiba L650 power problem

What voltages are you seeing now? Its hard for me to know what is wrong, so many possible reasons.

This is the description of pin 14 from the data sheet.
"Power-Source n-Channel MOSFET Switch Driver Output. When the adapter is not present or an overvoltage event is detected at the input, the PDSL output is pulled to GND with a 2.5kI (typ) resistor. Otherwise, it is typically 8V above the adapter voltage when the part is not using the battery. This is powered by an internal charge pump"
So the Gates of Q6002 and Q6005 should be about 19 + 8 = 27v above ground when they are supposed to be on.

Last edited by rievax_60; 01-10-2014 at 03:59 PM..
rievax_60 is offline   Reply With Quote
Old 01-10-2014, 06:32 PM   #62
rtstorm
Badcaps Veteran
 
rtstorm's Avatar
 
Join Date: Feb 2012
City & State: Croatia, Osijek
My Country: Croatia
Line Voltage: 230V 50Hz
I'm a: Knowledge Seeker
Posts: 703
Default Re: Toshiba L650 power problem

on gate Q6002 and Q6005 i have 26.5V. That left only Q6000 to suspect
__________________
...the quieter you become the more you are able to hear...
rtstorm is offline   Reply With Quote
Old 01-10-2014, 07:40 PM   #63
rtstorm
Badcaps Veteran
 
rtstorm's Avatar
 
Join Date: Feb 2012
City & State: Croatia, Osijek
My Country: Croatia
Line Voltage: 230V 50Hz
I'm a: Knowledge Seeker
Posts: 703
Default Re: Toshiba L650 power problem

i remove Q6002, Q6005, R6020, Q6000, L6020, C6037. And i still have fluctuates voltage on +VBAT
rtstorm is offline   Reply With Quote
Old 01-10-2014, 07:43 PM   #64
rievax_60
Badcaps Veteran
 
Join Date: May 2012
City & State: mackay
My Country: australia
Line Voltage: 240
I'm a: Hobbyist Tech
Posts: 893
Default Re: Toshiba L650 power problem

Does +VBAT fluctuate in a regular way or a random way? What is the average voltage?
rievax_60 is offline   Reply With Quote
Old 01-10-2014, 07:47 PM   #65
rievax_60
Badcaps Veteran
 
Join Date: May 2012
City & State: mackay
My Country: australia
Line Voltage: 240
I'm a: Hobbyist Tech
Posts: 893
Default Re: Toshiba L650 power problem

I am starting to think we might be seeing the result of something trying to start and pulling +VBAT down.
I need to think a bit more.
rievax_60 is offline   Reply With Quote
Old 01-10-2014, 07:59 PM   #66
rtstorm
Badcaps Veteran
 
rtstorm's Avatar
 
Join Date: Feb 2012
City & State: Croatia, Osijek
My Country: Croatia
Line Voltage: 230V 50Hz
I'm a: Knowledge Seeker
Posts: 703
Default Re: Toshiba L650 power problem

it go 5.18, 4.85, 5.62, 8.52, 6.93, 5.40, i think there is a pattern
rtstorm is offline   Reply With Quote
Old 01-10-2014, 08:10 PM   #67
rievax_60
Badcaps Veteran
 
Join Date: May 2012
City & State: mackay
My Country: australia
Line Voltage: 240
I'm a: Hobbyist Tech
Posts: 893
Default Re: Toshiba L650 power problem

You really need to use an oscilloscope to be certain.
Can you isolate the +VBAT at other points by removing those solder blob jumpers that most Toshibas have?
rievax_60 is offline   Reply With Quote
Old 01-10-2014, 11:17 PM   #68
rievax_60
Badcaps Veteran
 
Join Date: May 2012
City & State: mackay
My Country: australia
Line Voltage: 240
I'm a: Hobbyist Tech
Posts: 893
Default Re: Toshiba L650 power problem

The fluctuating +VBAT might not be a real worry. The most important thing is the Gate voltage on Q6002 ans Q6005 remain stable at that 26.5v.
rievax_60 is offline   Reply With Quote
Old 01-11-2014, 05:13 AM   #69
rtstorm
Badcaps Veteran
 
rtstorm's Avatar
 
Join Date: Feb 2012
City & State: Croatia, Osijek
My Country: Croatia
Line Voltage: 230V 50Hz
I'm a: Knowledge Seeker
Posts: 703
Default Re: Toshiba L650 power problem

Ok i am waiting for new Q6002
rtstorm is offline   Reply With Quote
Old 01-28-2014, 05:20 PM   #70
rtstorm
Badcaps Veteran
 
rtstorm's Avatar
 
Join Date: Feb 2012
City & State: Croatia, Osijek
My Country: Croatia
Line Voltage: 230V 50Hz
I'm a: Knowledge Seeker
Posts: 703
Default Re: Toshiba L650 power problem

i replace Q6002 and i have stable gate on Q6002 at 25.88V. I have fan spin and LED turn on. Did not try with LCD but i think all ok now. Do i need to test Q6002 gate for some time?
rtstorm is offline   Reply With Quote
Old 01-28-2014, 05:29 PM   #71
rtstorm
Badcaps Veteran
 
rtstorm's Avatar
 
Join Date: Feb 2012
City & State: Croatia, Osijek
My Country: Croatia
Line Voltage: 230V 50Hz
I'm a: Knowledge Seeker
Posts: 703
Default Re: Toshiba L650 power problem

yep, i check and i have picture on screen
rtstorm is offline   Reply With Quote
Old 01-28-2014, 06:54 PM   #72
rievax_60
Badcaps Veteran
 
Join Date: May 2012
City & State: mackay
My Country: australia
Line Voltage: 240
I'm a: Hobbyist Tech
Posts: 893
Default Re: Toshiba L650 power problem

Quote:
Originally Posted by rtstorm View Post
i replace Q6002 and i have stable gate on Q6002 at 25.88V. I have fan spin and LED turn on. Did not try with LCD but i think all ok now. Do i need to test Q6002 gate for some time?
Yes, check it a few hours later or next day if you want to keep it open for that long.
rievax_60 is offline   Reply With Quote
Old 01-28-2014, 07:06 PM   #73
rtstorm
Badcaps Veteran
 
rtstorm's Avatar
 
Join Date: Feb 2012
City & State: Croatia, Osijek
My Country: Croatia
Line Voltage: 230V 50Hz
I'm a: Knowledge Seeker
Posts: 703
Default Re: Toshiba L650 power problem

you mean to keep running laptop for few hours and then check Q6002?
rtstorm is offline   Reply With Quote
Old 01-28-2014, 07:26 PM   #74
rievax_60
Badcaps Veteran
 
Join Date: May 2012
City & State: mackay
My Country: australia
Line Voltage: 240
I'm a: Hobbyist Tech
Posts: 893
Default Re: Toshiba L650 power problem

I try to do both. Test it during along run, then again after it has been off for some time.
I had an A200 fail after a week. I think it was caused by the TF4300 flux causing leakage.
rievax_60 is offline   Reply With Quote
Old 02-01-2014, 04:21 PM   #75
rtstorm
Badcaps Veteran
 
rtstorm's Avatar
 
Join Date: Feb 2012
City & State: Croatia, Osijek
My Country: Croatia
Line Voltage: 230V 50Hz
I'm a: Knowledge Seeker
Posts: 703
Default Re: Toshiba L650 power problem

laptop worked, i leave it to run some time and all ok. Thank you
rtstorm is offline   Reply With Quote
Old 02-20-2015, 06:30 PM   #76
nstnkt
New Member
 
Join Date: Apr 2012
City & State: torino
My Country: italy
I'm a: Knowledge Seeker
Posts: 1
Default Re: Toshiba L650 power problem

hi to all, I think I already made a presentation when I first register but if not I'll do very soon.
Please can you point me to the right direction with a l650 toshiba.
it wil start on the battery without ac, it will start on ac without battery but sometimes shutoff after power button press in precisely 28 seconds 9/10 times if no battery is present, when log in windows it says "plugged in,charging" but the level of the battery always stay on the same percentage so i suspect not charging.
thanks you very much for every point.
nstnkt is offline   Reply With Quote
Old 07-06-2015, 05:46 PM   #77
HarryPK
Senior Member
 
Join Date: Mar 2014
City & State: banjarmasin
My Country: barabai
Line Voltage: 220VAC 50Hz
I'm a: Knowledge Seeker
Posts: 193
Default Re: Toshiba L650 power problem

thanks
HarryPK is offline   Reply With Quote
Old 09-06-2015, 03:32 AM   #78
koshari
New Member
 
Join Date: Jul 2015
City & State: gippsland
My Country: aus
I'm a: Knowledge Seeker
Posts: 2
Default Re: Toshiba L650 power problem

hi,

i have just found this site and have an l650 with pretty much the same symptoms as posted in this thread, i are waiting on some deliveries before i attempt to replace the max charging chip.

i will post the progress as i go.

btw is there any way to fool the MoBo in to thinking there is a battery connected to attemp to boot from the battery pins?

cheers.

jason
koshari is offline   Reply With Quote
Old 09-06-2015, 04:01 AM   #79
koshari
New Member
 
Join Date: Jul 2015
City & State: gippsland
My Country: aus
I'm a: Knowledge Seeker
Posts: 2
Default Re: Toshiba L650 power problem

Quote:
Originally Posted by koshari View Post
hi,
btw is there any way to fool the MoBo in to thinking there is a battery connected to attemp to boot from the battery pins?
or alternatively a way to charge the battery outside the l650?
koshari is offline   Reply With Quote
Old 05-09-2018, 04:47 PM   #80
rievax_60
Badcaps Veteran
 
Join Date: May 2012
City & State: mackay
My Country: australia
Line Voltage: 240
I'm a: Hobbyist Tech
Posts: 893
Default Re: Toshiba L650 power problem

I'm working on an L650 with a suspect faulty MAX17435. It was totally lifeless.
The voltage on the ACIN pin is correct but ACOK stays high. The cause of this should only be because of a problem in the MAX17435.
After connecting the ACOK pin to ground and bridging the power source MOSFET, the laptop works normally on adapter power with one exception. Before pressing the power button, the adapter has to be initially disconnected then connected.
If the laptop is shutdown and then turned on again without interrupting adapter power, the laptop will always shutdown about 30 sec later.
I realize that it would be very difficult to find a detailed reason for this behavior and hope that all will work properly after I replace the MAX17435.

Last edited by rievax_60; 05-09-2018 at 04:59 PM..
rievax_60 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 11:35 AM.
Did you find this forum helpful?