Badcaps.net Forum
Go Back   Badcaps Forums > General Topics > General Capacitor Questions & Issues
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-02-2015, 05:18 PM   #1
marty-clubber
Member
 
Join Date: Oct 2014
City & State: middelsbrough
My Country: u k
I'm a: Knowledge Seeker
Posts: 54
Default Sapphire AMD Radeon R9 280X Graphics card

Hi my Sapphire AMD Radeon R9 280X Graphics card, just stopped working
any one know anything about them or what the problem is?

Rgs Marty
marty-clubber is offline   Reply With Quote
Old 09-03-2015, 04:07 AM   #2
Stefan Payne
Badcaps Veteran
 
Join Date: Dec 2009
City & State: Northern Germany
My Country: Germany
Line Voltage: 230VAC/50Hz or 400VAC/3P/50Hz
I'm a: Knowledge Seeker
Posts: 1,259
Default Re: Sapphire AMD Radeon R9 280X Graphics card

It died...
Stefan Payne is offline   Reply With Quote
Old 09-19-2015, 11:10 AM   #3
Dangermoose007
Member
 
Join Date: Sep 2013
City & State: Lubbock, Texas
My Country: US
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 31
Default Re: Sapphire AMD Radeon R9 280X Graphics card

What do you mean it stopped working, are you getting no video signal or BSOD? Do the fans spin when you power on the computer, and does the comp work when the card isn't in?

Was it reference design or using an aftermarket cooler/Overclock? What were temps while idle and under load?
Dangermoose007 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:48 AM.
Did you find this forum helpful?