Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-24-2019, 06:54 PM   #1
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Apple macbook a1278 820-2936 need some help

Well i started playing with apple boards since i have a few laying arround here.
I wen ahead checking always-present lines and when i was measuring the input of u7200 (tps51125) i accidentally shorted pin 16 with 17...
12.5v pin16 input to 5v pin17 output...
Then the output was 1v
I changed the ic with an used one and now i have 5v
I went back measuring and i am missing pp5v_s3_p18v5s5.
This is created by u5805 (tps61045) right? As is a buck converter in the schematics...
I have pp5v_s5 comming in to uc5805 on pin 2, but no pp5v_s3_p18v5s5 and of course no pp18v5_s5
I have changed u5805 also with a used one, but because i donít know if i should have pp18v5_s5 at this moment i am not sure if the ic is good...

I have to mention i have green light and fan is spinning...
Actually the fan started to spin once i changed u7200.

Do i have to have pp18v5_s5 at this moment?
Any suggestions where to look?

Thanks!
justin35 is offline   Reply With Quote
Old 01-25-2019, 05:19 AM   #2
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 1,329
Default Re: Apple macbook a1278 820-2936 need some help

This is a bit confusing… What was the original issue? What state the board is in right now? Did you plug everything back in to test?
__________________
OpenBoardview ó http://openboardview.org | IRC ó #openboardview@irc.freenode.net
piernov is online now   Reply With Quote
Old 01-25-2019, 08:01 PM   #3
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

Sorry about that!
The board was dead, no green light nothing. I restored the power rails to get a green light and fanspeen. Then I accidentally shorted u7200 resulting in no fanspeen, replaced u7200 now i have fanspeen again, but nothing else...
Digging more into the board i found 2 power rails missing:
Memvtt_en which is created by pm_sLp_s3_L(pm_sLps3_L is present)
And
Plt_reset_L
As far as i understood from schematics, in order to create memvtt_en, pLt_reset_L must be high, opening half of the Q3210 mosfet, and pulling down memvtt_en_L.
This results in no power for ram memory... 0.75v missing
justin35 is offline   Reply With Quote
Old 01-26-2019, 04:18 AM   #4
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 1,329
Default Re: Apple macbook a1278 820-2936 need some help

ALL_SYS_PWRGD, PM_PCH_SYS_PWROK and CPU VCore present?
piernov is online now   Reply With Quote
Old 01-26-2019, 09:51 AM   #5
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

I will check them tonight.
But it looks like the machine is going to the s3 state from s0
Isolate cpu mem l -0 0v
Plt reset l -0 0v (on r1125 i can measure 0,13v)
Pm slp s3 l -1 3,3v
Pm slp s4 l -1 3,3v
Cpu mem reset l -1 1,5v
Mem reset l -1 1,5v
Memvtt en -0 0v
P1v5cpu en -0 0v
justin35 is offline   Reply With Quote
Old 01-26-2019, 10:21 AM   #6
ktmmotocross
Boardkiller
 
ktmmotocross's Avatar
 
Join Date: Feb 2014
City & State: slovakia
My Country: slovakia
Line Voltage: 230VAC 50Hz
I'm a: Hobbyist Tech
Posts: 1,736
Default Re: Apple macbook a1278 820-2936 need some help

as u put 12V line to 5V line u must check all ic on that line for damage
ktmmotocross is offline   Reply With Quote
Old 01-26-2019, 10:35 AM   #7
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

All sys pwrgd ok
U7960 missing from board by factory and 0v on pad 8

Measuring pm pch sys pwork on r2863, r2862, r2861, stops the fan from spinning.
R2504 no v at all

U7200 measuring voltage on pin 6 stops the fan, and i measure 0- 0,7v fluctuating. Once i remove the multimeter fan spins...
Measuring on pin1 it shutsdown the fan and wonít come back spinning unless i remove the power...
Iím confused now ...
justin35 is offline   Reply With Quote
Old 01-27-2019, 03:52 PM   #8
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 1,329
Default Re: Apple macbook a1278 820-2936 need some help

Measuring with a proper multimeter with a decent input impedance (usually in the 10Mohms range) either ENTRIP1 or ENTRIP2 of U7200 is not supposed to do anything. Is your multimeter good? And not set to low impedance mode? Not making contact with anything else? (skin is enough to mess things up)

U7960 and R7962 are not populated, it's normal. ALL_SYS_PWRGD is 3.3V on U2850?
Measure voltage on all pins of U2850 and U2860.
piernov is online now   Reply With Quote
Old 01-28-2019, 12:47 AM   #9
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

I donít know the impedance of my multimeter, itís a fluke 287, barely used which is working fine... anyway i switched to a uni-t dmm and itís behaving a little better, when i measure pin6 of u7200 it stops the fan for a split of second and then it continues to spin, measured voltage 0,7v
Also using my finger over that resistor stops the fan from spinning....

Measured u2850
Pin1 3,3v all sys pwrgd
Pin2 0,04v cpuimvp pgood
Pin3 0 gnd
Pin4 0v pm s0 pgood
Pin5 3,3v pp3v3 s5

Measured u2860
Pin1 0v pm s0 pgood
Pin2 3,3v smc delayed pwrgd
Pin3 0v gnd
Pin4 0v sys pwork r
Pin5 3,3v pp3v3 s5
justin35 is offline   Reply With Quote
Old 01-28-2019, 08:56 AM   #10
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 1,329
Default Re: Apple macbook a1278 820-2936 need some help

Hum… U7200 outputs PP5V_S3/PP3V3_S5/PP5V_S5 are stable?
Seems like a strange behaviour but if the outputs are present and stable it should be ok.

Anyway CPUIMVP_PGOOD is missing, you should look around U7400 and make sure it has 5V on VCC/VDDA/VDDB, and 3.3V on CPUIMVP_VR_ON. Maybe try to replace it.
piernov is online now   Reply With Quote
Old 01-29-2019, 12:43 PM   #11
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

Well right now i can’t measure anything...
Last night i was measuring u7200 area again to see what is wrong with the fan which stops when i measure voltages when measuring on pin6 and pin 2, the fan stopped. I noticed u7400 are was warm...
Measured again cpuvimp_ton 2.2v instead 5v as it was before...
Resistance to ground 24ohms
took out u7400 resistance to ground 8ohms
Plugged in charger and wait 2-3 min
Q7510 getting warm
Took out q7510 then the short is gone...
I have to investigate and see what’s wrong again
Once i replace it, i’ll get back

Last edited by justin35; 01-29-2019 at 01:09 PM..
justin35 is offline   Reply With Quote
Old 01-29-2019, 02:44 PM   #12
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

Quote:
Originally Posted by justin35 View Post
I noticed u7400 are was warm...
I noticed u7400 AREA was warm...

I managed to replace Q7510 and now i have 12.5v back
Now i have to put back U7400 and repair a loose pad...

Ps: without Q7510 and U7400 The fan was spinning... any idea why?
Whith Q7510 and without u7400 the fan spins for one second then stops one second and so on...
justin35 is offline   Reply With Quote
Old 01-30-2019, 06:38 AM   #13
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 1,329
Default Re: Apple macbook a1278 820-2936 need some help

Q7510 getting warm would be normal when CPU VCore is present. But I think you didn't have CPU VCore so it should have been cold.
For good measure I'd replace U7400, Q7510 and Q7520 (and maybe Q7550) to be sure CPU VCore buck converter is good. Also check R7402.

For the fan changing behaviour I'm not sure… Shouldn't make a difference as in both cases CPUIMVP_PGOOD was missing. On these boards I think when in a S0 state but CPU VCore supply doesn't work, the fan keeps spinning but obviously no VCore and it doesn't chime.
piernov is online now   Reply With Quote
Old 01-30-2019, 12:27 PM   #14
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

I think i am going to put this on hold for now... or maybe put it in the donor pile...
now i have another short, on p5v s0 cpuvimp_vdd...
today i took another board which i manage to fix it and make it boot, restore keyboard, pad and usb.
BUT is very very slow... and i don't think is because of the sensors...
I am trying to boot from usb dongle to install the os, but it takes forever, and the board gets pretty hot on the u1800 and u3600 area.
I ran the diagnostics using D key and it passes. It says it's mid 2012 i7 @2,5 macbook pro 9,2 13inch"
Also checked serial number on apple and it corresponds.
BUT i did not find any i7 @ 2,5 ghz on everymac.com only i5 @ 2,5ghz
I also got the asd efi on a stick and ran the test which came back with chipset error "Chipset(test1) - Management engine presence test
ERROR - Not Found-
Test failed"
I ran a test without chipset and everything is ok
I only have asd 3s155 which wors, every other files i got is corrupt
the board is 820-3115-B

any idea where to start?
Should i open another thread?
justin35 is offline   Reply With Quote
Old 01-30-2019, 02:56 PM   #15
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 1,329
Default Re: Apple macbook a1278 820-2936 need some help

Yes open another thread for different problem.
piernov is online now   Reply With Quote
Old 02-03-2019, 03:03 PM   #16
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

Well i m back on tracks with this board...

Measured u2850
Pin1 3,3v all sys pwrgd
Pin2 3,48v cpuimvp pgood
Pin3 0 gnd
Pin4 3,3v pm s0 pgood
Pin5 3,3v pp3v3 s5

Measured u2860
Pin1 3,3v pm s0 pgood
Pin2 3,3v smc delayed pwrgd
Pin3 0v gnd
Pin4 3,3v sys pwork r
Pin5 3,3v pp3v3 s5



Fan spins gradually up to full speed...

Still working on it... as i don t have a chime or ram warning if no ddr installed

Last edited by justin35; 02-03-2019 at 03:18 PM..
justin35 is offline   Reply With Quote
Old 02-03-2019, 04:29 PM   #17
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

Now i have a different state of the machine, s0 going to s3 first step:
Isolate cpu mem l 0v
Plt reset l 3,3v
Pm slp s3 l 3,3v
Pm spl s4 l 3,3v
Cpu mem reset l 1,5v
Mem reset l 1,5v
Memvtt en 3,3v
P1v5cpu en 1,5v

So i am missing isolate cpu mem l
justin35 is offline   Reply With Quote
Old 02-04-2019, 02:02 AM   #18
piernov
Moderator
 
Join Date: Jan 2016
City & State: Valbonne, 06
My Country: France
I'm a: Knowledge Seeker
Posts: 1,329
Default Re: Apple macbook a1278 820-2936 need some help

ISOLATE_CPU_MEM_L shouldn't matter I think.
You have all the voltages and signals required for the board to boot as far as I see. It should start running the BIOS.

Try a PRAM reset.
Measure exact voltage on CPU VCore.
Plug in an optical USB mouse and check if the LED lights up.
piernov is online now   Reply With Quote
Old 02-04-2019, 12:52 PM   #19
justin35
Member
 
Join Date: Jan 2019
City & State: Phen
My Country: It
I'm a: Knowledge Seeker
Posts: 78
Default Re: Apple macbook a1278 820-2936 need some help

Isolate cpu mem l it has to be high in order for the s0 state to be full high and boot the computer...
I idnít have chime
I plugged in an sata usb adaptor without hdd as i donít have a corded optical mouse, and the light is on... so i have power on usb...
I donít think i need to flash a cleam me bios as i still need isolate cpu mem l for full s0 state...
Low isolate cpu mem l is the first step for going from s0 (on state) to s3 (sleep state)
I know isolate cpu mem l is created by pch, but if itís present, itís pulled down by something on q3200 q3215 area....
Otherwise we have a dead pch, which is bad :/
justin35 is offline   Reply With Quote
Old 02-04-2019, 03:34 PM   #20
Aap123
New Member
 
Join Date: May 2018
City & State: Groningen
My Country: Nederland
I'm a: Knowledge Seeker
Posts: 1
Default Re: Apple macbook a1278 820-2936 need some help

-If ur usb mouse lights up ur PCH is working meaning u should have PM_PCH_PWROK.
-How much voltage on PPVCORE_S0_CPU.
-Check voltages on U6100 also check SPI resistors. -
And its common that ur device shuts down when u try to measure one all_sys_pwrgd (at least for me) what i usually do is put probe on all_sys_pwrgd and then connect magsafe this way it should not turn off


-I also got the asd efi on a stick and ran the test which came back with chipset error "Chipset(test1) - Management engine presence test
ERROR - Not Found-
Test failed"

This is bios related I had the exact same one i replaced bios and devices booted without problem (reflashing is also an option i think but not sure) first check the resistors tho
Aap123 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums © 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 08:59 AM.
Did you find this forum helpful?