Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Tablets, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 05-04-2021, 02:56 PM   #1
mhd_mahad
Member
 
Join Date: Jun 2016
City & State: cairo
My Country: egypt
I'm a: Knowledge Seeker
Posts: 26
Default HP G62 star reverer - missing +V5A rail

hello friends,

I have hp g62 Wont turn on.
Some corrosion around PU850 (SN0608098RHBT)
+V3.3AL OK
+V5A is 0 volt.

I've replaced PQ850 and PU850, no change.
There is no short to ground on the +5VA rail.
Measurements I've taken:

PU850 pins:

Pin 26 (DRVH2 +V3.3AL_UG_20) = 3.5V
Pin 25 (LL2 +3_3V_AL_PHASE_20) = 3.3V
Pin 24 (VBST2 +3_3V_AL_VBST_20) = 8.4V
Pin 23 (DRVL2 +V3.3AL_LG_20) = 0.9V

Pin 15 (DRVH1 DHI) = 0V
Pin 16 (LL1 +V5A_PHASE_20) = 0V
Pin 17 (VBST1 +5VA_VBST_20) = 4.8V
Pin 18 (DRVL1 +V5A_LG_20) = 0V

EC_ALW_EN missing

IT8502 vcc= 0v
+V3.3S=0v
can any one help me urgently
mhd_mahad is offline   Reply With Quote
Old 05-09-2021, 11:59 PM   #2
Tom_avia
New Member
 
Tom_avia's Avatar
 
Join Date: Jan 2020
City & State: Vilnius
My Country: Lithuania
I'm a: Knowledge Seeker
Posts: 18
Default Re: HP G62 star reverer - missing +V5A rail

Did you try to use laboratory power supply? How much Amps the motherboard is consuming?
Also do some elements are heating?
Tom_avia is offline   Reply With Quote
Old 05-10-2021, 02:25 AM   #3
jasko_jacker
Badcaps Veteran
 
Join Date: Oct 2014
City & State: roma
My Country: italy
Line Voltage: 220 V
I'm a: Knowledge Seeker
Posts: 935
Default Re: HP G62 star reverer - missing +V5A rail

In this motherboard the +5alw are present only after pushing the power button.
jasko_jacker is offline   Reply With Quote
Old 05-11-2021, 04:46 PM   #4
mhd_mahad
Member
 
Join Date: Jun 2016
City & State: cairo
My Country: egypt
I'm a: Knowledge Seeker
Posts: 26
Default Re: HP G62 star reverer - missing +V5A rail

thanks all
No elements are heating or shorting.
IT8502 IO vcc= 0v how can i check missing volt?
mhd_mahad is offline   Reply With Quote
Old 05-12-2021, 12:03 AM   #5
Tom_avia
New Member
 
Tom_avia's Avatar
 
Join Date: Jan 2020
City & State: Vilnius
My Country: Lithuania
I'm a: Knowledge Seeker
Posts: 18
Default Re: HP G62 star reverer - missing +V5A rail

I would check this area of board. I think this is an origins of +v3.3s voltage.
Attached Images
File Type: png Screenshot_1.png (100.5 KB, 9 views)
File Type: png Screenshot_2.png (94.2 KB, 8 views)
Tom_avia is offline   Reply With Quote
Old 05-12-2021, 12:06 AM   #6
Tom_avia
New Member
 
Tom_avia's Avatar
 
Join Date: Jan 2020
City & State: Vilnius
My Country: Lithuania
I'm a: Knowledge Seeker
Posts: 18
Default Re: HP G62 star reverer - missing +V5A rail

SN0608098 (PU11) is forming +v3.3al and then +v3.3s. Check there.
Tom_avia is offline   Reply With Quote
Old 05-12-2021, 12:29 AM   #7
Sametbey
Badcaps Veteran
 
Sametbey's Avatar
 
Join Date: Jan 2021
City & State: Zonguldak
My Country: Turkey
Line Voltage: 220VAC 50HZ
I'm a: Knowledge Seeker
Posts: 210
Default Re: HP G62 star reverer - missing +V5A rail

Do you have 7 pin LDO, 14 pin and 27 pin ENL voltages. System does not start without 13 and 28 PWGOD signals.
__________________
I'm not happy to be so strong. because it's not humanly
Sametbey is offline   Reply With Quote
Old 05-12-2021, 02:29 AM   #8
mhd_mahad
Member
 
Join Date: Jun 2016
City & State: cairo
My Country: egypt
I'm a: Knowledge Seeker
Posts: 26
Default Re: HP G62 star reverer - missing +V5A rail

pin 14 EN1=0v
pin 27 EN2=5v
13&28=0vi only have enable and signals for 3.3v
mhd_mahad is offline   Reply With Quote
Old 05-12-2021, 04:44 AM   #9
Tom_avia
New Member
 
Tom_avia's Avatar
 
Join Date: Jan 2020
City & State: Vilnius
My Country: Lithuania
I'm a: Knowledge Seeker
Posts: 18
Default Re: HP G62 star reverer - missing +V5A rail

Quote:
Originally Posted by mhd_mahad View Post
pin 14 EN1=0v
pin 27 EN2=5v
13&28=0vi only have enable and signals for 3.3v
EC_ALW_EN to pin 14 is going from EC.
Tom_avia is offline   Reply With Quote
Old 05-12-2021, 05:43 AM   #10
Sametbey
Badcaps Veteran
 
Sametbey's Avatar
 
Join Date: Jan 2021
City & State: Zonguldak
My Country: Turkey
Line Voltage: 220VAC 50HZ
I'm a: Knowledge Seeker
Posts: 210
Default Re: HP G62 star reverer - missing +V5A rail

AD_ID activates the charge control chip when the adapter is installed. Then the charging chip generates the signal AC_OK + 19V is supplied to the system. PU850 STBY chip generates +3.3 V LDO voltage. IO works, BIOS gets the program. It sends the signal to PU850 and output 3.3 VALW to 5VALW. PU850 pwrgood sends signal to IO. IO waits, the SYS opens when the POWER button is pressed.
Attached Images
File Type: jpg System.jpg (103.5 KB, 15 views)

Last edited by Sametbey; 05-12-2021 at 05:46 AM..
Sametbey is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 07:03 AM.
Did you find this forum helpful?