Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Power Supplies and Power Supply Design
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-04-2015, 12:04 AM   #21
moe2020
New Member
 
Join Date: Oct 2015
City & State: Dallas, Texas
My Country: USA
I'm a: Knowledge Seeker
Posts: 2
Default Re: General PSU Discussion and FAQ contributions

Hello all, this is my first post here, so please be kind
I have a couple of power SMPS power supplies, that are doing some wired stuff:
one of them, the Vcc (pin 7) of the UC3842, is fluctuating, it does seem to get to 16V, since I do see the square pulse on pin 6, but it is fluctuating between 13v and 10v!!
I have replaced the power IC, all caps and made sure all the resistors associated with this device are good. I use the light bulb to check the parts, since If I power it with the fuse in place, the rectifiers get very hot and short out...
The second one, is, I am getting about 70v after the start up resistor!! I back tracked it,
on a good board I have about 105v DC on the output of the bridge rectifier , but reading 155v DC on the non-working unit...if I lift the +dc output pin from the PCB, then it drops to 95v, put it back, the DC output voltage goes up to 155v dc.
If I am not providing enough information, please excuse me, but will be more than happy to expand on what I have posted here. your help is greatly appreciated.
moe2020 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2018
Powered by vBulletin ®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 01:59 AM.

Did you find this forum helpful?