Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Power Supplies and Power Supply Design
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 03-11-2022, 06:49 AM   #1
theone111
New Member
 
Join Date: Mar 2022
City & State: Ness Ziona
My Country: Israel
I'm a: Knowledge Seeker
Posts: 9
Default APC BR550GI Pro UPS not charging battery

I have an APC BR550GI Pro UPS
https://www.se.com/il/en/product/BR5...ckups-pro-550/

The motherboard model I have in the UPS is the 640-1172A-Z_REV05

The problem I have is that my UPS does not seem to charge the battery when ON.
After charging the battery with an external battery charger and installing into the UPS (updating change date) the battery drains slowly ~7% every 12 hours with no load connected (the PowerChute SW show decrease in jumps of ~7% not 1% decrements).

I think it does charge the battery when OFF because I measure ~0.3-0.4A on the wires to the battery. and when connecting external battery charger it does say battery is at 100%.

The UPS does switch from Mains to battery and back when it should.

I see no physical damage to the board.

The 2 fuses F4 and F5 are OK.

Does anyone have the schematics of this board or can help point me in the right direction for troubleshooting and finding the bad component/connection.

Thank you
Attached Images
File Type: jpg IMG_20220311_141423 (2).jpg (880.5 KB, 20 views)
File Type: jpg IMG_20220311_143654.jpg (980.4 KB, 16 views)
File Type: jpg IMG_20220311_143711.jpg (629.8 KB, 13 views)
theone111 is offline   Reply With Quote
Old 03-14-2022, 06:21 AM   #2
sam_sam_sam
Badcaps Veteran
 
Join Date: Jul 2011
City & State: Some times Sunny Jacksonville FL
My Country: USA
Line Voltage: 120 Volts 60 HZ
I'm a: Knowledge Seeker
Posts: 3,573
Default Re: APC BR550GI Pro UPS not charging battery

What is going on with the device that is on the heat sink it is looking odd it near T1 and I think is also near IC2 can you please post the part number for IC2
__________________
9 PC LCD Monitor
6 LCD Flat Screen TV
30 Desk Top Switching Power Supply
10 Battery Charger Switching Power Supply for Power Tool
6 18v Lithium Battery Power Boards for Tool Battery Packs
1 XBox 360 Switching Power Supply and M Board
25 Servo Drives 220/460 3 Phase
6 De-soldering Station Switching Power Supply 1 Power Supply
1 Dell Mother Board
15 Computer Power Supply
1 HP Printer Supply & Control Board * lighting finished it *


These two repairs where found with a ESR meter...> Temp at 50*F then at 90*F the ESR reading more than 10%

1 Over Head Crane Current Sensing Board ( VFD Failure Five Years Later )
2 Hem Saw Computer Stack Board

All of these had CAPs POOF
All of the mosfet that are taken out by bad caps

Last edited by sam_sam_sam; 03-14-2022 at 06:28 AM..
sam_sam_sam is offline   Reply With Quote
Old 03-14-2022, 08:49 AM   #3
theone111
New Member
 
Join Date: Mar 2022
City & State: Ness Ziona
My Country: Israel
I'm a: Knowledge Seeker
Posts: 9
Default Re: APC BR550GI Pro UPS not charging battery

Quote:
Originally Posted by sam_sam_sam View Post
What is going on with the device that is on the heat sink it is looking odd it near T1 and I think is also near IC2 can you please post the part number for IC2
IC2 is TNY278PN (I am waiting for order for replacement - maybe it will help)

What device looks odd? The silver one I marked PINK In attached picture? I don't know what it is? Why do you think it odd?
Attached Images
File Type: png Picture.png (703.1 KB, 18 views)
theone111 is offline   Reply With Quote
Old 03-14-2022, 11:15 AM   #4
sam_sam_sam
Badcaps Veteran
 
Join Date: Jul 2011
City & State: Some times Sunny Jacksonville FL
My Country: USA
Line Voltage: 120 Volts 60 HZ
I'm a: Knowledge Seeker
Posts: 3,573
Default Re: APC BR550GI Pro UPS not charging battery

Is there an ic chip that is mounted to it or something else that is mounted to it
sam_sam_sam is offline   Reply With Quote
Old 03-15-2022, 03:14 AM   #5
theone111
New Member
 
Join Date: Mar 2022
City & State: Ness Ziona
My Country: Israel
I'm a: Knowledge Seeker
Posts: 9
Default Re: APC BR550GI Pro UPS not charging battery

Quote:
Originally Posted by sam_sam_sam View Post
Is there an ic chip that is mounted to it or something else that is mounted to it
I have no idea what it is. There are no markings.
Attached Images
File Type: jpg IMG_20220315_105236.jpg (317.2 KB, 12 views)
File Type: jpg IMG_20220315_105254.jpg (323.4 KB, 15 views)
theone111 is offline   Reply With Quote
Old 03-20-2022, 03:25 AM   #6
benq32
New Member
 
Join Date: Mar 2022
City & State: BW
My Country: Germany
I'm a: Knowledge Seeker
Posts: 3
Default Re: APC BR550GI Pro UPS not charging battery

Quote:
Originally Posted by theone111 View Post
I have no idea what it is. There are no markings.
This is simply heatsink for TNY278PN.

I have the same symptoms. I've changed TNY278PN chip, but there is no changes. Problem exists.
battery will not charge!
If I switch UPS on, it makes it internal tests, shows that battery is empty, but no error message.
If I disconnect the battery and measure voltage on battery pins, it's about 9V -- this is the reason why the battery does not charge.

Has anyone Idea why it could happen? Why it does not charge the battery?

Best regards,
Q
benq32 is offline   Reply With Quote
Old 03-20-2022, 03:50 AM   #7
benq32
New Member
 
Join Date: Mar 2022
City & State: BW
My Country: Germany
I'm a: Knowledge Seeker
Posts: 3
Default Re: APC BR550GI Pro UPS not charging battery

There are two capacitors on th board -- C18 and C32

Please take a look at the capacitor C18. It is 330mkf
I've measured it with multimeter and it was about 250mkf...
I've changed it to something I've found (470mkf 50v) and UPS is working again. Charge voltage about 13v!
Hope this helps you.

Solution - change capacitor C18.

Best regards,
Q
benq32 is offline   Reply With Quote
Old 03-20-2022, 09:10 AM   #8
theone111
New Member
 
Join Date: Mar 2022
City & State: Ness Ziona
My Country: Israel
I'm a: Knowledge Seeker
Posts: 9
Default Re: APC BR550GI Pro UPS not charging battery

Quote:
Originally Posted by benq32 View Post
There are two capacitors on th board -- C18 and C32

Please take a look at the capacitor C18. It is 330mkf
I've measured it with multimeter and it was about 250mkf...
I've changed it to something I've found (470mkf 50v) and UPS is working again. Charge voltage about 13v!
Hope this helps you.

Solution - change capacitor C18.

Best regards,
Q
Did you measure them (C18, C32) out of the board (removed from board)?

I meausred them on the board (they seem to be connected in parallel and got ~600uF (they are each marked as 330uF 35v). I will try and remove them and measure outside the board.

When I power up the UPS with no battery connected I get ~5.4v and a buzzing sound (see attached zipped video)
Attached Files
File Type: zip VID_20220320_165655.zip (10.17 MB, 7 views)

Last edited by theone111; 03-20-2022 at 09:35 AM..
theone111 is offline   Reply With Quote
Old 03-29-2022, 12:20 PM   #9
benq32
New Member
 
Join Date: Mar 2022
City & State: BW
My Country: Germany
I'm a: Knowledge Seeker
Posts: 3
Default Re: APC BR550GI Pro UPS not charging battery

Yes, I've measured them by removing from board. If I measured them on the board, it was more or less normal, but it was not so.
I've orderen another elkos 330mkf 63v from Panasonic.
now all is working fine!
Change your capacitors and have a look what happens.
benq32 is offline   Reply With Quote
Old 05-04-2022, 04:49 PM   #10
stigger
New Member
 
Join Date: May 2022
City & State: Munich
My Country: Germany
I'm a: Knowledge Seeker
Posts: 1
Default Re: APC BR550GI Pro UPS not charging battery

I had exactly the same problem. My capacitors looked fine, but tried to replace them with 330uf 35V Panasonic and that helped. Thanks a lot for the tip!
stigger is offline   Reply With Quote
Old 05-10-2022, 04:21 AM   #11
theone111
New Member
 
Join Date: Mar 2022
City & State: Ness Ziona
My Country: Israel
I'm a: Knowledge Seeker
Posts: 9
Default Re: APC BR550GI Pro UPS not charging battery

So I replaced c18 and c32 (i measured them after removal and they were about 300uf instead of 330uf).

Now I get 14.1v when no battery connected and get charging current (measured on the battery wires) of about 0.5A and battery voltage increasing slowly.

Is this charging current OK?
theone111 is offline   Reply With Quote
Old 05-10-2022, 11:31 PM   #12
theone111
New Member
 
Join Date: Mar 2022
City & State: Ness Ziona
My Country: Israel
I'm a: Knowledge Seeker
Posts: 9
Default Re: APC BR550GI Pro UPS not charging battery

Quote:
Originally Posted by benq32 View Post
Yes, I've measured them by removing from board. If I measured them on the board, it was more or less normal, but it was not so.
I've orderen another elkos 330mkf 63v from Panasonic.
now all is working fine!
Change your capacitors and have a look what happens.
So I have tested the UPS after the capacitors replacement and it seems to work.

Thank you @benq32
theone111 is offline   Reply With Quote
Old 05-29-2022, 06:16 AM   #13
lego1234567
New Member
 
Join Date: May 2022
City & State: Presov
My Country: Slovakia
Line Voltage: 230VAC 50 Hz
I'm a: Knowledge Seeker
Posts: 1
Thumbs up Re: APC BR550GI Pro UPS not charging battery

Quote:
Originally Posted by benq32 View Post
There are two capacitors on th board -- C18 and C32

Please take a look at the capacitor C18. It is 330mkf
I've measured it with multimeter and it was about 250mkf...
I've changed it to something I've found (470mkf 50v) and UPS is working again. Charge voltage about 13v!
Hope this helps you.

Solution - change capacitor C18.

Best regards,
Q
I had the same problem as you, battery was not charging at all. After removing and measuring the C18 and C32, I found they had much lower capacity (not any visual damage). After soldering new ones, UPS works fine. Thanks for your efforts !
lego1234567 is offline   Reply With Quote
Old 05-30-2022, 05:16 AM   #14
sam_sam_sam
Badcaps Veteran
 
Join Date: Jul 2011
City & State: Some times Sunny Jacksonville FL
My Country: USA
Line Voltage: 120 Volts 60 HZ
I'm a: Knowledge Seeker
Posts: 3,573
Default Re: APC BR550GI Pro UPS not charging battery

More items not ending up in a landfill good work to both of you
sam_sam_sam is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 02:56 AM.
Did you find this forum helpful?