Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-07-2019, 08:04 PM   #1
mgrharry
Member
 
Join Date: Sep 2016
City & State: los angeles, ca
My Country: usa
I'm a: Knowledge Seeker
Posts: 44
Default Inspiron 5570 Charging Issue

Working on an Inspiron 5570. Initially it had a short to ground which I traced down to a blown ceramic cap (circled in attached photo). Removed the cap et voila, short was gone and the system powered on and charged -- until you unplugged the power adapter and replugged it, at which point the light on the power adapter would slowly fade out and the system would not detect the charger. Pull another cap from a junk board and soldered it back on but it still has the same behavior:

If the system has no battery it will auto power on when the charger is connected and run fine. If the battery is connected and the power adapter is hooked up it will charge and work perfectly until the first time you unplug and then replug the charger at which point the computer will stay on running off battery power but will no longer detect the charger. The light on the Dell charger will slowly fade out (vs fast off with the initial short) whereas the light on a universal charger I tested with goes to a fast pulse. If the system is powered off and the battery is unplugged it will again charge the battery the first time it is plugged in, but stops detected the charger after the first replug.

I did see a similar post about a charging problem on this model where the culprit was apparently a resistor:
https://www.badcaps.net/forum/showthread.php?p=847917
Attached Images
File Type: jpg IMG_20191007_173359.jpg (951.8 KB, 12 views)
File Type: jpg IMG_20191007_173456.jpg (779.2 KB, 10 views)
mgrharry is offline   Reply With Quote
Old 10-08-2019, 04:08 AM   #2
mcplslg123
Badcaps Veteran
 
Join Date: Jun 2015
City & State: siliguri
My Country: india
Line Voltage: 220vac,60hz
I'm a: Professional Tech
Posts: 2,189
Default Re: Inspiron 5570 Charging Issue

check fet for short on battery output path.
mcplslg123 is offline   Reply With Quote
Old 10-11-2019, 08:26 PM   #3
mgrharry
Member
 
Join Date: Sep 2016
City & State: los angeles, ca
My Country: usa
I'm a: Knowledge Seeker
Posts: 44
Default Re: Inspiron 5570 Charging Issue

Thanks for the tip brother! You were connect. Replaced the mosfet shown with one from a donor board, problem solved.
Attached Images
File Type: jpg BADMOSFET.jpg (944.5 KB, 9 views)
mgrharry is offline   Reply With Quote
Old 10-12-2019, 12:00 AM   #4
mcplslg123
Badcaps Veteran
 
Join Date: Jun 2015
City & State: siliguri
My Country: india
Line Voltage: 220vac,60hz
I'm a: Professional Tech
Posts: 2,189
Default Re: Inspiron 5570 Charging Issue

Good job. you posted the pics as well to help others.
mcplslg123 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 07:38 PM.
Did you find this forum helpful?