Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-13-2019, 10:41 AM   #1
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Asus X550C dead

Hi all,
I have problem with this laptop. Is completely dead. Power IC was very hot I replaced it with I mean good replacement from other dead board. uP1589q I replaced it with JC (RT8239B). There are 3.3V and 5V ALW rails now. But DC-IN voltage is not stable. After second mosfet I have weird readings and something clicking. There is no short on 19V power rail. Very weird fault for me. Can someone help me with this, or schematic is availible for this motherboard? I have only boardview.

Thanks for any answer..
Attached Images
File Type: jpg ECA243CB-E1C1-47C8-BAD1-C80C0FE1C809.jpg (514.9 KB, 21 views)
File Type: jpg 3E9F1EB5-4D31-4643-8CC6-3E31D0EC0246.jpg (506.6 KB, 14 views)
File Type: jpg 78659D27-0C37-4394-86BC-912EC07C64F3.jpg (343.1 KB, 10 views)
Attached Files
File Type: zip ASUS_X550CC_REV_2.0 _BoardView.zip (182.9 KB, 10 views)

Last edited by DeniS182; 10-13-2019 at 10:45 AM..
DeniS182 is offline   Reply With Quote
Old 10-13-2019, 12:54 PM   #2
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

I tried replace first two mosfets after dc-in connector but nothing changed. After second mosfet on current sensor resistor I have weird voltage readings something like 0V-5V-10V-20V my multimeter switch ranges randomly.
DeniS182 is offline   Reply With Quote
Old 10-13-2019, 01:29 PM   #3
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

https://youtu.be/ElkoKmo7dLM
DeniS182 is offline   Reply With Quote
Old 10-14-2019, 08:32 AM   #4
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 761
Default Re: Asus X550C dead

check the 2 Fets gate voltage is stable or not PQ8801/2 apply 1V to PR8806 CLR and see is its stable or not

Last edited by techtiger; 10-14-2019 at 08:36 AM..
techtiger is offline   Reply With Quote
Old 10-14-2019, 09:37 AM   #5
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

gate voltage is not stable. And no short on PR8806
DeniS182 is offline   Reply With Quote
Old 10-14-2019, 10:49 AM   #6
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 761
Default Re: Asus X550C dead

Quote:
Originally Posted by DeniS182 View Post
gate voltage is not stable. And no short on PR8806
Find out Charger IC pin ACDRV Voltage is stable or not and test all components connect to that line
techtiger is offline   Reply With Quote
Old 10-14-2019, 12:29 PM   #7
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

I resolder components connected to that line and voltage is now stable. Thanks. But laptop is still dead. Power consumption is 0.01A and after power button is pressed consumption rise up to 0.03A but all LED's stay off.
DeniS182 is offline   Reply With Quote
Old 10-15-2019, 04:19 AM   #8
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 761
Default Re: Asus X550C dead

test the voltage PU8802 ACDET ACOK , U3001 pin 14 17 56 57 107 108 85 ,U2801 pin 8 for voltage , PQ9103 PQ9101 PR9104 all pins for +V

Last edited by techtiger; 10-15-2019 at 04:26 AM..
techtiger is offline   Reply With Quote
Old 10-15-2019, 06:09 AM   #9
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

PU8802 - ACDET - 2.6V
ACOK - 3V

U3001 - 14 - 3.3V
17 - 3.3V
56 - 0V
57 - 0V
107 - 0V
108 - 0V
85 - 0V

U2801 pin8 - 3.3V

PQ 9103 - not soldered on board
PQ9101 - 0V at all pins
PR9104 - not soldered on board

Do you have schematic please?

Last edited by DeniS182; 10-15-2019 at 06:11 AM..
DeniS182 is offline   Reply With Quote
Old 10-15-2019, 06:35 AM   #10
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 761
Default Re: Asus X550C dead

Quote:
Originally Posted by DeniS182 View Post
PU8802 - ACDET - 2.6V
ACOK - 3V

U3001 - 14 - 3.3V
17 - 3.3V
56 - 0V
57 - 0V
107 - 0V
108 - 0V
85 - 0V

U2801 pin8 - 3.3V

PQ 9103 - not soldered on board
PQ9101 - 0V at all pins
PR9104 - not soldered on board

Do you have schematic please?
no i dont have it, you have to test this voltage when pressing the power button one by one
56 - 0V
57 - 0V
107 - 0V
108 - 0V
85 - 0V
112 ?
techtiger is offline   Reply With Quote
Old 10-15-2019, 07:12 AM   #11
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

0V on all these pins when power button is pressed. But on pin 125 I have 3.3V and after power button is pressed it going to zero.
DeniS182 is offline   Reply With Quote
Old 10-15-2019, 07:16 AM   #12
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 761
Default Re: Asus X550C dead

Quote:
Originally Posted by DeniS182 View Post
0V on all these pins when power button is pressed. But on pin 125 I have 3.3V and after power button is pressed it going to zero.
back up old DUMP and flash bios
techtiger is offline   Reply With Quote
Old 10-15-2019, 07:23 AM   #13
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

I desolder bios chip. Try it with other one with dump from this forum. But nothing changed.

When I open it with CH341 software it says dump is too big or something like that.. I try to find another dump

Last edited by DeniS182; 10-15-2019 at 07:24 AM..
DeniS182 is offline   Reply With Quote
Old 10-15-2019, 07:51 AM   #14
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

I flash another dump but still same laptop dead. should I repeat the measurements?
DeniS182 is offline   Reply With Quote
Old 10-15-2019, 08:12 AM   #15
SMDFlea
Moderator
 
Join Date: Jan 2018
City & State: York
My Country: UK
I'm a: Knowledge Seeker
Posts: 2,879
Default Re: Asus X550C dead

Post your bios backup in the Bios requests sub-forum ,and one of the members will fix it .
SMDFlea is offline   Reply With Quote
Old 10-15-2019, 09:09 AM   #16
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

I post my bios backup here: https://www.badcaps.net/forum/showth...142#post920142
DeniS182 is offline   Reply With Quote
Old 10-15-2019, 10:03 AM   #17
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 761
Default Re: Asus X550C dead

Quote:
Originally Posted by DeniS182 View Post
I flash another dump but still same laptop dead. should I repeat the measurements?
Pin 112 Communication between bios and SIO check again and all pins of BIOS IC for voltage ,check RTCRST RTCVCC R2002for any short

Last edited by techtiger; 10-15-2019 at 10:08 AM..
techtiger is offline   Reply With Quote
Old 10-15-2019, 12:35 PM   #18
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

R2002 was missing, pads damaged. I fix it with 22k resistor/Original 20K/. PIN 112 - 3.3V. bios pins: 1) 0.3V
2) 1.2V
3) 3.3V
4) 0V
5) 1.3V
6) 1.68V
7and8) 3.3V
DeniS182 is offline   Reply With Quote
Old 10-15-2019, 12:41 PM   #19
techtiger
Badcaps Veteran
 
Join Date: Oct 2014
City & State: paris
My Country: france
I'm a: Knowledge Seeker
Posts: 761
Default Re: Asus X550C dead

Quote:
Originally Posted by DeniS182 View Post
R2002 was missing, pads damaged. I fix it with 22k resistor/Original 20K/. PIN 112 - 3.3V. bios pins: 1) 0.3V
2) 1.2V
3) 3.3V
4) 0V
5) 1.3V
6) 1.68V
7and8) 3.3V
ok thats great now when you press power BTW pin112 will go high low 3.3V to 0V , and check voltage pin
56 - 0V
57 - 0V
107 - 0V
108 - 0V
85 - 0V


of U3001

Last edited by techtiger; 10-15-2019 at 12:44 PM..
techtiger is offline   Reply With Quote
Old 10-15-2019, 01:02 PM   #20
DeniS182
Senior Member
 
Join Date: Jun 2014
City & State: Slovakia
My Country: Slovakia
I'm a: Hobbyist Tech
Posts: 187
Default Re: Asus X550C dead

I mean measured bad pin before because now is 112pin all time zero when is pwr button pressed or not. ANd 56,57,107,108,85 still 0V - when is pwr button pressed or not.
DeniS182 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 08:51 PM.
Did you find this forum helpful?