Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 10-17-2019, 07:31 AM   #1
iceze
New Member
 
Join Date: Oct 2019
City & State: UK
My Country: UK
I'm a: Knowledge Seeker
Posts: 4
Default Dell XPS 9343 No Sound

Hi guys

Hope you can maybe help.

Have a Dell XPS and sound doesn't work in Windows 10. I have tried reloading windows 10, 8, bios and all drivers. The sound works in the Dell boot diagnostics utility and I did try a Linux live usb and it works upon second boot in that.

Having researched it looks like the motherboard has a realtor ALC 3263 which can switch between HDA or I2S audio depending on OS.

So if I load Ubuntu once then restart into windows the machine outputs in HDA mode and works all fine. As soon as the laptop is restarted or sleeps, it resumes back into I2S.

Tried so many different combinations and now I'm thinking maybe I can force HDA mode somehow. There is no option in the bios. Ive

I was looking at the motherboard schematics but I don't have much experience with electronics schematics and need help.

I see that the mode HDA and I2S is mentioned on there. Is there anyway I could maybe toggle it to only use HDA audio by physically. Could there be a reason why I2S is failing and HDA is fine?
Attached Files
File Type: pdf LA-B441P r10.pdf (1.35 MB, 7 views)

Last edited by iceze; 10-17-2019 at 07:43 AM..
iceze is offline   Reply With Quote
Old 10-17-2019, 10:31 AM   #2
lvalius
Member
 
Join Date: Jan 2017
City & State: Vilnius
My Country: Lithuania
I'm a: Knowledge Seeker
Posts: 32
Default Re: Dell XPS 9343 No Sound

I remember I had same problem with this model once, you need to download correct drivers, but I do not remember which one. Try all version from dell support page one by one, I think it should help.
Because if it is working in bios and Linux it should work in Windows too and that's just bad drivers causing the problem. Don't give up.
__________________
Original Dell parts for sale

Last edited by lvalius; 10-17-2019 at 10:36 AM.. Reason: Additional mind
lvalius is offline   Reply With Quote
Old 10-17-2019, 10:54 AM   #3
iceze
New Member
 
Join Date: Oct 2019
City & State: UK
My Country: UK
I'm a: Knowledge Seeker
Posts: 4
Default Re: Dell XPS 9343 No Sound

Tha k you for your reply Ivalius. I have tried so many drivers and reinstalls of windows I was beginning to think it must be some kind of hardware fault maybe. I have read a few threads of others with similar problems but there seems to be no one solution and the threads are from years ago.

Given me a little hope so I'll keep trying more drivers. ( Must have tried at least 7+ different ones).

I'm leaning towards some potentially intermittent fault atleast to do with I2S though. I will keep trying in the mean time.

It's just surprising how the audio works so easily after rebooting from Linux.
iceze is offline   Reply With Quote
Old 10-21-2019, 01:06 AM   #4
rediii
Member
 
Join Date: Mar 2018
City & State: nrw
My Country: germany
I'm a: Forum Junkie
Posts: 38
Default Re: Dell XPS 9343 No Sound

did you try a bios-update? i had the exact same issue on an asus-model.
rediii is offline   Reply With Quote
Old 10-22-2019, 07:52 AM   #5
iceze
New Member
 
Join Date: Oct 2019
City & State: UK
My Country: UK
I'm a: Knowledge Seeker
Posts: 4
Default Re: Dell XPS 9343 No Sound

I have now tried maybe 6 different bios', different drivers, and 3 different windows with no luck. Sound works fine on Ubuntu (no WiFi but I didn't really want to troubleshoot that).

I'm losing hope on trying to fix this in windows 10.

@rediii can I ask what laptop you had and how you resolved it?

I'm thinking maybe I can somehow boot Ubuntu kernel and then reboot into windows. All done in the background automatically. That way I can force the system into I2S atleast for each reboot. BuT that's a long-winded way and I'm not great at Linux scripting!

Any help would be a massive help.
iceze is offline   Reply With Quote
Old 10-22-2019, 01:02 PM   #6
rediii
Member
 
Join Date: Mar 2018
City & State: nrw
My Country: germany
I'm a: Forum Junkie
Posts: 38
Default Re: Dell XPS 9343 No Sound

Quote:
Originally Posted by iceze View Post
I have now tried maybe 6 different bios', different drivers, and 3 different windows with no luck. Sound works fine on Ubuntu (no WiFi but I didn't really want to troubleshoot that).

I'm losing hope on trying to fix this in windows 10.

@rediii can I ask what laptop you had and how you resolved it?

I'm thinking maybe I can somehow boot Ubuntu kernel and then reboot into windows. All done in the background automatically. That way I can force the system into I2S atleast for each reboot. BuT that's a long-winded way and I'm not great at Linux scripting!

Any help would be a massive help.
did u try to disabled all audio enhancements in windows 10? did you try (if it is there) to disable the intel audio/nvidia driver? did u try to uninstall the audio driver with DDU? did u try to uninstall any app that is combined with any audio option? pls tell me. did u test to resolve any hardware or software issue with the dell support assist (yeah it's crappy but sometimes...). and did u uninstall the drivers completely (device manager with checkbox activated, sounds stupid but u never know?). try to uninstall camera and microphone driver. reset all sound settings in windows 10 (including camera and microphone)!

Last edited by rediii; 10-22-2019 at 01:10 PM..
rediii is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 12:20 AM.
Did you find this forum helpful?