Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Computer Displays
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 11-13-2019, 09:50 AM   #1
meciu
New Member
 
Join Date: Nov 2016
City & State: Mannheim
My Country: Germany
I'm a: Knowledge Seeker
Posts: 15
Default BenQ BL2400PT no backlight

Hey!
So starting yesterday - my old 24" LED display doesn't work well - device displays image but there is no backlight and I can hear hissing from power supply.

I've tested lcd 6pin power cable and here are the :

Black standby 0.4v power on 3.7v
Brown standby 0.4 power on 3.4v
Red standby 21.8v power on 28.9v
Red standby 21.8v power on 28.9v
Yelow stand by 0.4v power on 3.7v
Green stand by 0.4v power on 4.8v

Any ideas what's wrong with it?
Attached Images
File Type: jpg IMG_20191113_163947.jpg (910.6 KB, 11 views)
File Type: jpg IMG_20191113_164002.jpg (1.17 MB, 5 views)
File Type: jpg IMG_20191113_164021.jpg (1,015.3 KB, 6 views)
meciu is offline   Reply With Quote
Old 11-13-2019, 12:58 PM   #2
meciu
New Member
 
Join Date: Nov 2016
City & State: Mannheim
My Country: Germany
I'm a: Knowledge Seeker
Posts: 15
Default Re: BenQ BL2400PT no backlight

Resistance test of (yellow) transformer 10pin
P1 P2 3.5K Ω
P1 P3 1.4MΩ
P1 P4 0.2-0.5Ω
P1 P5 200K-1MΩ
P1 P6-10 0L

P2 P3 0.3Ω
P2 P4 39MΩ
P2 P5 0.5Ω
P2 P6-P10 0L

P3 P4 6M-33MΩ
P3 P5 0.3Ω
P3 P6-P10 0L

P4 P5 0.6M-1.5MΩ
P4 P6-P10 0L

P5 P6-P10 0L

P6 P7+P8 0.18Ω
P6 P9 0.16Ω
P6 P10 0.16Ω

Pin7 and pin8 are soldered together

P7+P8 P9 0.12Ω
P7+P8 P10 0.12Ω

P9 P10 0.19Ω

Last edited by meciu; 11-13-2019 at 12:59 PM..
meciu is offline   Reply With Quote
Old 11-13-2019, 04:29 PM   #3
digitalpc
Senior Member
 
Join Date: Jun 2016
City & State: DLL
My Country: .DLL
I'm a: Student Tech
Posts: 108
Default Re: BenQ BL2400PT no backlight

do u check output capacitor and diode
digitalpc is offline   Reply With Quote
Old 11-13-2019, 05:36 PM   #4
R_J
Badcaps Veteran
 
Join Date: Jun 2012
City & State: ☻
My Country: Canada
I'm a: Professional Tech
Posts: 4,871
Default Re: BenQ BL2400PT no backlight

I doubt your problem is with the power supply, check the voltage on the led driver board.
I suspect you have a problem with the led's themselves, Check the voltage going to the led's when you first turn on the monitor.
R_J is offline   Reply With Quote
Old 11-14-2019, 01:19 AM   #5
meciu
New Member
 
Join Date: Nov 2016
City & State: Mannheim
My Country: Germany
I'm a: Knowledge Seeker
Posts: 15
Default Re: BenQ BL2400PT no backlight

This tested by me 6 pin cable is actually a LED power cable.
So it is time for a LCD screen disassembly to check led diodes.
meciu is offline   Reply With Quote
Old 11-14-2019, 09:43 AM   #6
meciu
New Member
 
Join Date: Nov 2016
City & State: Mannheim
My Country: Germany
I'm a: Knowledge Seeker
Posts: 15
Default Re: BenQ BL2400PT no backlight

Okay,
Almost half of leds aren't working correctly.
Question is - what kind of LEDs I need to look for.
I assume that I need to find LEDs in 4 pin PLCC package (5x3x1mm) but which one?

This led bar has two markings
"AS-24M07005-N5HEX-X-1-11G-0057" and "N5HE"
Attached Images
File Type: jpg IMG_20191114_164135.jpg (566.9 KB, 4 views)

Last edited by meciu; 11-14-2019 at 09:45 AM..
meciu is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 02:48 AM.
Did you find this forum helpful?