Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 03-22-2017, 04:34 AM   #61
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: QLD
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 6,369
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Quote:
Originally Posted by benjamin.d.bird View Post
any ideas on how many/which ones would need swapping out?
and if its just coils and caps which i am capable of but anything involving micro surgery then i'd be at a loss!
Before you do this, I would check the buffers are ok, then hook it all up, fire the TV u check it is all good including 3D if you use it.;

Then get a copy of the manual for your model, a copy of the TX-P50G20B or E as that is the model which uses rev AW

Then visually look for differences or compare all C16xxx and L16xxx parts numbers and locations to determine what is the same, what is different.

If you have the boards laid out in front of you you'll start noticing the differences.

I'm not going to work it out for you. I've never done it but it's feasible or return the board and get the correct one
tw2005 is offline   Reply With Quote
Old 03-22-2017, 04:53 AM   #62
benjamin.d.bird
Member
 
Join Date: Jun 2016
City & State: Burnley
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 41
Default Re: Panasonic TX-P42GT20B - Stuck Stby

i hooked it up (SC50 Bypass) no error flash, solid green light on tv.
led bright on SC and SS.
performed short test on sm board ribbon connectors - no short.

so if i now install the AW fully it'll fire up as it should do with AH installed?
i have got a copy of both of the manuals.
benjamin.d.bird is offline   Reply With Quote
Old 03-22-2017, 05:19 AM   #63
tw2005
Badcaps Veteran
 
tw2005's Avatar
 
Join Date: Oct 2011
City & State: QLD
My Country: Australia
Line Voltage: 240VAC
I'm a: Forum Junkie
Posts: 6,369
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Quote:
Originally Posted by benjamin.d.bird View Post
i hooked it up (SC50 Bypass) no error flash, solid green light on tv.
led bright on SC and SS.
performed short test on sm board ribbon connectors - no short.

so if i now install the AW fully it'll fire up as it should do with AH installed?
i have got a copy of both of the manuals.
It should, just not matched to the panel but it'll work. I've thrown a 50" in a 54 panel for a quick test, then repaired the original board
tw2005 is offline   Reply With Quote
Old 03-25-2017, 12:44 PM   #64
benjamin.d.bird
Member
 
Join Date: Jun 2016
City & State: Burnley
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 41
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Replacement SC board did the trick, now i have 3 horzontal lines on screen tried mirror in service mode but as they are in centre of screen they stay the same
benjamin.d.bird is offline   Reply With Quote
Old 03-25-2017, 01:02 PM   #65
vinceroger69
Badcaps Veteran
 
Join Date: Mar 2012
City & State: Nuneaton Warwickshire
My Country: uk
I'm a: Hobbyist Tech
Posts: 5,835
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Maybe buffer board connections
https://www.youtube.com/watch?v=h4XWCxUsSVU
vinceroger69 is online now   Reply With Quote
Old 03-25-2017, 01:45 PM   #66
benjamin.d.bird
Member
 
Join Date: Jun 2016
City & State: Burnley
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 41
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Quote:
Originally Posted by vinceroger69 View Post
Maybe buffer board connections
https://www.youtube.com/watch?v=h4XWCxUsSVU
spot on, thank you all for your help
benjamin.d.bird is offline   Reply With Quote
Old 11-13-2019, 08:11 PM   #67
ScottyWhistle
New Member
 
Join Date: Nov 2019
City & State: Burnley
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 5
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Hey,

Sorry to dig up this post but I've been following along with the same model, and I've had different results - and so hit a brick wall.

I tested voltages across P11 pins 1/4 and P2 pin 1 with the SC connected/disconnected, and got these results:

SC Disconnected
P11 pin 4 = 15.6v
P11 pin 1 = 208v
P2 pin 1 = 209v

SC Connected
P11 pin 4 = 16v
P11 pin 1 = 208v
P2 pin 1 = 208v

Also, no continuity between the Q661 legs.

I believe this rules out the SC board?

I get 10 blinks with the SC both connected and disconnected
I get 10 blinks with the D board (D25 connector) connected and disconnected

I have visually checked every port on the A board for damage or bent pins and I have not found anything.

I'm stuck, I'm a beginner at this so I can't work out what to test next, any guidance is extremely appreciated.

The only extra info I've found is that there is no voltage across P2 or P11 when D25 is disconnected, but from what I've found this is normal.

Also by some crazy coincidence live in the same town as benjamin - feel free to come and fix it if you're a pro these days.
ScottyWhistle is offline   Reply With Quote
Old 11-14-2019, 12:59 AM   #68
tn245
Badcaps Veteran
 
Join Date: Oct 2013
City & State: South East
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Knowledge Seeker
Posts: 437
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Most likely the A board is bad then.
tn245 is offline   Reply With Quote
Old 11-14-2019, 05:21 AM   #69
ScottyWhistle
New Member
 
Join Date: Nov 2019
City & State: Burnley
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 5
Default Re: Panasonic TX-P42GT20B - Stuck Stby

How can I rule out the P and SS board?
ScottyWhistle is offline   Reply With Quote
Old 11-14-2019, 06:51 PM   #70
ScottyWhistle
New Member
 
Join Date: Nov 2019
City & State: Burnley
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 5
Default Re: Panasonic TX-P42GT20B - Stuck Stby

I've given it my best shot, according to the 2010 Viera training seminar PDF posted earlier in this thread, if the voltage between A6 pin 1 and 9 is 15v just before the TV shuts down, the problem is the A board.

My only worry is that although very similar, this PDF is for VT20T series TVs. Will this rule still apply? Shall I go for the A board replacement?

Thanks
ScottyWhistle is offline   Reply With Quote
Old 11-15-2019, 12:42 AM   #71
tn245
Badcaps Veteran
 
Join Date: Oct 2013
City & State: South East
My Country: UK
Line Voltage: 230Vac 50Hz
I'm a: Knowledge Seeker
Posts: 437
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Yes, replace the A board. It's extremely unlikely to be P or SS.
tn245 is offline   Reply With Quote
Old 11-28-2019, 03:45 PM   #72
ScottyWhistle
New Member
 
Join Date: Nov 2019
City & State: Burnley
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 5
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Well, disaster struck. The replaced A board had the exact same issue. 10 blinks. I'm thinking it surely has to be the power board.
ScottyWhistle is offline   Reply With Quote
Old 12-02-2019, 02:16 PM   #73
ScottyWhistle
New Member
 
Join Date: Nov 2019
City & State: Burnley
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 5
Default Re: Panasonic TX-P42GT20B - Stuck Stby

Well, I'm on the verge of giving in.

A new A board and a new P board, together, do not work. 10 binks. I have made sure every wire in connectors P6 and P7 work/have continuity. No other connectors are connected at all. No D board, no SC, no SS.

What does this mean? Have I been sent a defective A or P board? I don't see a way for me to find out unless I order yet another.
ScottyWhistle is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 10:30 AM.
Did you find this forum helpful?