Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 06-30-2022, 10:15 PM   #1
lapse
Member
 
Join Date: Jun 2022
City & State: Sudbury, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 21
Default TCL 40S325-CA backlights, sound, no picture

Hello, another TV found on the sidewalk here.

I have a TCL 40S325-CA ROKU LED TV. The backlights turn on, I can hear the typical Roku click sound when pressing the power button (no remote unfortunately) but nothing is displayed on the screen.

Power supply:

Main board goes into standby, so no reason to suspect anything here. Backlights turn on, etc..

Driver boards:

I have 12V going on both sides of the fuse on the panel driver boards.
VGH and VGL are around 1V when powered on.
No shorts to GND on any of the test pads or any of the caps on the driver boards.

Main board:

See pictures - a number of the caps seem shorted, however they're about 90Ohms to GND. In diode mode, red probe on GND, black probe on non-GND side of the caps then I get about 0.05V.

With the TV turned on, there's about 1V on the caps.

My FLIR doesn't show any excessive hot spots on the board except for the main processor.

Thoughts? Main board toast?
Attached Images
File Type: jpg IMG_4349.jpg (386.3 KB, 10 views)
File Type: jpg IMG_4350.jpg (581.1 KB, 6 views)
File Type: jpg IMG_4351.jpg (422.9 KB, 5 views)
lapse is offline   Reply With Quote
Old 06-30-2022, 10:26 PM   #2
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,802
Default Re: TCL 40S325-CA backlights, sound, no picture

Vgh and Vgl are both bad.
__________________
I assume no responsibility for any stupid suggestions I might post.
dskall is online now   Reply With Quote
Old 07-01-2022, 03:57 AM   #3
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,186
Default Re: TCL 40S325-CA backlights, sound, no picture

^^^ I agree, very bad.
nomoresonys is offline   Reply With Quote
Old 07-01-2022, 04:45 AM   #4
lotas
Badcaps Veteran
 
Join Date: Jan 2016
City & State: Sochi
My Country: russia
I'm a: Knowledge Seeker
Posts: 851
Default Re: TCL 40S325-CA backlights, sound, no picture

90 Ohm is a normal resistance, it can be even lower, and 1 volt is the power supply of the processor core (there is always low resistance on this bus).
lotas is offline   Reply With Quote
Old 07-01-2022, 05:15 AM   #5
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,186
Default Re: TCL 40S325-CA backlights, sound, no picture

vgh should be 20-30, vgl -5 to -12.
nomoresonys is offline   Reply With Quote
Old 07-01-2022, 08:52 AM   #6
lapse
Member
 
Join Date: Jun 2022
City & State: Sudbury, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 21
Default Re: TCL 40S325-CA backlights, sound, no picture

Ugh ok, I'll track down why VGH and VGL are gone.
lapse is offline   Reply With Quote
Old 07-01-2022, 08:52 AM   #7
lapse
Member
 
Join Date: Jun 2022
City & State: Sudbury, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 21
Default Re: TCL 40S325-CA backlights, sound, no picture

Quote:
Originally Posted by lotas View Post
90 Ohm is a normal resistance, it can be even lower, and 1 volt is the power supply of the processor core (there is always low resistance on this bus).
This is very good information. Thank you!
lapse is offline   Reply With Quote
Old 07-01-2022, 09:39 AM   #8
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,802
Default Re: TCL 40S325-CA backlights, sound, no picture

Might try unhooking one side of panel board and see if voltages come up. Some good pictures of panel boards would help.
dskall is online now   Reply With Quote
Old 07-01-2022, 09:46 AM   #9
lapse
Member
 
Join Date: Jun 2022
City & State: Sudbury, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 21
Default Re: TCL 40S325-CA backlights, sound, no picture

Okay, I did a bit of troubleshooting. Of the two FPC cables that join the two driver boards, I found where VGH/VGL are and disconnected that ribbon cable.

I turned on the TV but VGH/VGL is still missing, so it's not the secondary (left-side) driver board.

Since this is a trash TV, I had nothing to lose so I found where VGH was going to to the COF flex on right-side driver board and cut the trace. I turned on the TV and got VGH=23V and VGL=-7.98V. A bit of success!

But still no picture.

CKV=1.6V
STV=0V
Attached Images
File Type: jpg IMG_4371.jpg (395.7 KB, 16 views)
File Type: jpg IMG_4373.jpg (424.2 KB, 10 views)
File Type: jpg IMG_4374.jpg (387.6 KB, 9 views)
File Type: jpg IMG_4375.jpg (413.4 KB, 10 views)
lapse is offline   Reply With Quote
Old 07-01-2022, 09:49 AM   #10
lapse
Member
 
Join Date: Jun 2022
City & State: Sudbury, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 21
Default Re: TCL 40S325-CA backlights, sound, no picture

Attached are some more pictures of the panel driver board that I've been poking at.

Apologies, but the last two pictures seem to have been uploaded and rotated 180!
Attached Images
File Type: jpg IMG_4358.jpg (328.0 KB, 8 views)
File Type: jpg IMG_4360.jpg (324.8 KB, 7 views)
File Type: jpg IMG_4361.jpg (325.7 KB, 7 views)
File Type: jpg IMG_4363.jpg (387.5 KB, 7 views)
File Type: jpg IMG_4364.jpg (385.7 KB, 8 views)

Last edited by lapse; 07-01-2022 at 09:51 AM.. Reason: Noticed last two pics are 180 out
lapse is offline   Reply With Quote
Old 07-01-2022, 10:01 AM   #11
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,186
Default Re: TCL 40S325-CA backlights, sound, no picture

hmm, well if it's a shorted panel, maybe the tape cu-off method will work?
nomoresonys is offline   Reply With Quote
Old 07-01-2022, 10:09 AM   #12
lapse
Member
 
Join Date: Jun 2022
City & State: Sudbury, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 21
Default Re: TCL 40S325-CA backlights, sound, no picture

Quote:
Originally Posted by nomoresonys View Post
hmm, well if it's a shorted panel, maybe the tape cu-off method will work?
I don't think it will... there's no dedicated TCON board. The signals seem to be passed-through one driver board to the other.

I think the tape cut off method _might_ work if the problem were on the panel driver board that's daisy chained off the main panel driver board (see first set of pics). However, the VGH trace that I severed is on the "main" panel driver board that has the LVDS connector going to it from the mainboard.
lapse is offline   Reply With Quote
Old 07-01-2022, 11:25 AM   #13
dskall
Badcaps Veteran
 
dskall's Avatar
 
Join Date: Oct 2016
City & State: Bakersfield ca.
My Country: usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 2,802
Default Re: TCL 40S325-CA backlights, sound, no picture

Probably need to inspect panel traces for short. And look at side cofs. If panel short you can jumper around it
dskall is online now   Reply With Quote
Old 07-01-2022, 11:49 AM   #14
lapse
Member
 
Join Date: Jun 2022
City & State: Sudbury, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 21
Default Re: TCL 40S325-CA backlights, sound, no picture

Quote:
Originally Posted by dskall View Post
Probably need to inspect panel traces for short. And look at side cofs. If panel short you can jumper around it
Any YouTube videos, or previous posts that I can use to help educate myself about doing this?
lapse is offline   Reply With Quote
Old 07-01-2022, 12:08 PM   #15
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 8,186
Default Re: TCL 40S325-CA backlights, sound, no picture

there's one of many videos, you might even find one in English but it might take some looking, why youtube doesn't have a choice to search for a preferred language is a mystery: https://www.youtube.com/watch?v=wQA02AvViRE
nomoresonys is offline   Reply With Quote
Old 07-03-2022, 10:48 AM   #16
lapse
Member
 
Join Date: Jun 2022
City & State: Sudbury, ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 21
Default Re: TCL 40S325-CA backlights, sound, no picture

Okay, I jumpered VGH to the side COF and got picture. Unfortunately huge horizontal lines are running across the screen. Spent enough time on this one, so I’ll scrap it for parts and take the rest to the dump!

RIP!
lapse is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2022
Powered by vBulletin ®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 05:11 PM.
Did you find this forum helpful?