Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 12-02-2019, 10:26 AM   #1
Jp06
Member
 
Join Date: May 2016
City & State: Ocoee,florida
My Country: Usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 63
Default lg 60ln5400 power on to lg logo and stuck at a weird screen

Happy holidays everyone,
I have a lg tv (60ln5400) stuck screen issue and hoping that someone could tell me what it is and how to fix it.
I lost the power cord and remote so i got a replacement cord on amazon. When i plugged it in, the tv came on without having to press the power button. The lg logo appeared and went straight to this screen with the circle at the bottom right and it's stuck there (refer to images please). There are no responses with any buttons from the back of tv.
I baked the main board at 385F for 10min and have the same results.
Thank you so much for any helps.
Attached Images
File Type: jpg stuck screen.jpg (67.9 KB, 15 views)
File Type: jpg stuck screen2.jpg (85.9 KB, 19 views)
File Type: jpg back.jpg (216.7 KB, 9 views)
File Type: jpg led driver.jpg (178.9 KB, 10 views)
File Type: jpg main.jpg (157.0 KB, 11 views)
File Type: jpg power.jpg (107.4 KB, 2 views)
Jp06 is offline   Reply With Quote
Old 12-02-2019, 11:51 AM   #2
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 4,228
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Could be a bad eeprom, that's one of the symptoms.
nomoresonys is offline   Reply With Quote
Old 12-02-2019, 12:18 PM   #3
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 4,228
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Ic 104, try heating it with a hairdryer or cooling with freeze spray or upside down can of duster, then plug in tv and try it, see if there's any change, even if only for a while.
nomoresonys is offline   Reply With Quote
Old 12-02-2019, 12:32 PM   #4
Jp06
Member
 
Join Date: May 2016
City & State: Ocoee,florida
My Country: Usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 63
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Thanks, I will try that out tonight. I had a feeling that i might need to buy a new main board.
Jp06 is offline   Reply With Quote
Old 12-02-2019, 12:41 PM   #5
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 4,228
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Replacement mainboard is probably the best bet, specially if fault can't be pinpointed.

Last edited by nomoresonys; 12-02-2019 at 12:53 PM..
nomoresonys is offline   Reply With Quote
Old 12-02-2019, 01:45 PM   #6
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 4,228
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Took a look around the net, most say sold out, best I see is there for 110 bux, there is a make offer option also: https://www.ebay.com/itm/LG-60LN5400....c100290.m3507
nomoresonys is offline   Reply With Quote
Old 12-02-2019, 10:00 PM   #7
nicholas1110
Member
 
Join Date: Aug 2012
City & State: minnesota
My Country: usa
I'm a: Knowledge Seeker
Posts: 99
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

From the picture it appears that it is trying to lower the volume as you can see the - symbol is highlighted red. I suggest unplugging the buttons and see if the fault goes away.
nicholas1110 is offline   Reply With Quote
Old 12-03-2019, 07:46 AM   #8
Jp06
Member
 
Join Date: May 2016
City & State: Ocoee,florida
My Country: Usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 63
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

I did what Nomoresonys and Nicholas suggested and got no changes. What seems odd is why does it power up right away when I plugged the power in (without having to press the power button). Can a bad ic104 or main board causes that or is it short circuit somewhere?

Last edited by Jp06; 12-03-2019 at 07:48 AM..
Jp06 is offline   Reply With Quote
Old 12-03-2019, 08:54 AM   #9
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 4,228
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Yes bad eeprom can do that.
nomoresonys is offline   Reply With Quote
Old 12-03-2019, 10:01 AM   #10
Jp06
Member
 
Join Date: May 2016
City & State: Ocoee,florida
My Country: Usa
Line Voltage: 120VAC 60Hz
I'm a: Knowledge Seeker
Posts: 63
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Thanks Nomoresony, I will get a new replacement board.
Jp06 is offline   Reply With Quote
Old 12-04-2019, 03:14 AM   #11
mmartell
Badcaps Veteran
 
Join Date: Oct 2013
City & State: Windsor ON
My Country: Canada
I'm a: Knowledge Seeker
Posts: 2,748
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Quote:
Originally Posted by Jp06 View Post
I did what Nomoresonys and Nicholas suggested and got no changes. What seems odd is why does it power up right away when I plugged the power in (without having to press the power button). Can a bad ic104 or main board causes that or is it short circuit somewhere?
Most times the main board remembers the state it was in when power was removed. IOW if you could power it off with the remote then unplug the power upon plugging it back in it would return to standby instead of "on". Try it with another TV you have.
mmartell is online now   Reply With Quote
Old 12-04-2019, 12:16 PM   #12
Unspun01
Badcaps Veteran
 
Join Date: Jun 2011
City & State: Manitoba
My Country: Canada
I'm a: Knowledge Seeker
Posts: 248
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

Quote:
Originally Posted by nicholas1110 View Post
From the picture it appears that it is trying to lower the volume as you can see the - symbol is highlighted red. I suggest unplugging the buttons and see if the fault goes away.
I agree.

Volume down button is highlighted in red. It appears the button is pressed, or some wire is pinched/shorted and makes the TV think the button is pressed.

Did you disconnect the buttons from the wire harness only? or did you disconnect the wire harness from the mainboard. If it is a bad wire, try disconnecting the harness from the mainboard.

Could also be a bad de-coupling capacitor or pull-up/pull-down resistor on the volume down input line to the processor. If you can figure out which line is being pulled down, you may be able to force it the other way.

You could also try shorting pins 5-6 on the 8-leg SOIC EEPROM/SPIFlash chip when you plug in the TV. This will interrupt communication to and from the EEPROM IC and could allow you to start the TV.
Unspun01 is offline   Reply With Quote
Old 12-04-2019, 02:28 PM   #13
nomoresonys
Badcaps Veteran
 
Join Date: Jan 2013
City & State: midwest
My Country: U.S.
I'm a: Knowledge Seeker
Posts: 4,228
Default Re: lg 60ln5400 power on to lg logo and stuck at a weird screen

For sure shorting pins 5-6 might work, don't cost anything to try.
nomoresonys is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 02:48 PM.
Did you find this forum helpful?