Badcaps.net Forum
Go Back   Badcaps Forums > Motherboards with Bad Capacitors > Major Manufacturers Boards
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 01-09-2011, 02:29 AM   #1
rize
New Member
 
Join Date: Jan 2011
Posts: 2
Default Acer Aspire 5672WLMi fails to power up

This laptop was used with the wrong AC adapter. Original AC adapter is lost. I tried powering up with bench PSU with 19 V DC but it was no go. The laptop was drawing something around .20 amps when I pressed the power reset which is obviously not enough to get anything going, no lights, no sound - no nothing.

On eBay I've seen the power jack and cable that plugs into the main board sold as a unit. Is it possible this jack & harness assembly has a power fuse included which may have burned out when a wrong AC adapter was used?

Any suggestions on how to trace the burned out components? Possibly the power regulation section of the main board, somewhere underneath the power-jack. I received one helpful tip to look for burned out diodes in this area.

Anyone with information on the strip-down sequence of the main board, in case I buy a refurbished replacement board.

Thank you for your comments in advance.
rize is offline   Reply With Quote
Old 01-09-2011, 02:40 AM   #2
mockingbird
Badcaps Veteran
 
mockingbird's Avatar
 
Join Date: Dec 2008
Posts: 4,874
Default Re: Acer Aspire 5672WLMi fails to power up

Regarding the Acer power jacks... I just worked on an Aspire 5513... To my best recollection, there was no fuse in that cable that connected the jack to the motherboard.
__________________
...Their plight, in fact is even worse, they don't realize that they're cantonists, they think they're free men. What a slavery that is - to confuse slavery for light, and bitter darkness for bright light.
-Rabbi Menachem Mendel Schneersohn
mockingbird is offline   Reply With Quote
Old 01-13-2011, 10:55 PM   #3
rize
New Member
 
Join Date: Jan 2011
Posts: 2
Default Re: Acer Aspire 5672WLMi fails to power up

Thank you for posting. I just got a new AC adapter which is suppose to be an OEM part, hooked things up and as I expected pressing power reset did not produce any results - no lights, no fan - nothing but silence. I checked the voltage on the adapter which was 19 VDC. I started removing screws to expose the board as much as possible but got stuck after removing all the screws from the bottom of the chassis and back of the LCD lid. I'm not sure how to remove the keyboard and disconnect the LCD panel. I've removed few easy to get items like the battery, hard disk and can certainly get to the fan and the copper pipe cooling assembly. There are obviously some hidden screws holding the top chassis cover. Any ideas on how to remove the main board will be very helpful.

Thanks for all your comments.
rize is offline   Reply With Quote
Old 01-14-2011, 01:44 AM   #4
mockingbird
Badcaps Veteran
 
mockingbird's Avatar
 
Join Date: Dec 2008
Posts: 4,874
Default Re: Acer Aspire 5672WLMi fails to power up

If you look at my post about the 5513 here, someone answered that it is possible that when I corrupted the bios on the laptop, it can actually corrupt an integral part which allows power to flow through the motherboard. I never thought I'd encounter something like that, but indeed, after the bios flash failed, I had similar symptops to yours. Acer boards have an SOIC 8-pin BIOS (At least mine did), so it would be relatively trivial for me to unsolder it and get it reflashed.

The problem is, I don't know if that would solve it, it could be there's another chip that was corrupted by the flash.

In any case, I found a website that has a service:
http://www.bios-service-center.com/p...oducts_id=6278

I just ended up getting a new motherboard for $100. Sure, it was expensive, but worth it for an X3100 laptop.
mockingbird is offline   Reply With Quote
Old 02-09-2011, 04:20 AM   #5
zedok
New Member
 
Join Date: Feb 2011
Posts: 2
Unhappy Re: Acer Aspire 5672WLMi fails to power up

Hi!

I have an acer 5672 wlmi notebook, my friend had reball / BGA the vga and then we need to change the fan, but we don't have a same type, so we take out and take in an another. Now, the computer is doesn't start. no led no fan. sometimes the led is on for a sec. Could we do something to get it to work or it can goes to trash?
zedok is offline   Reply With Quote
Old 02-09-2011, 06:23 AM   #6
Scenic
o.O
 
Scenic's Avatar
 
Join Date: Sep 2007
City & State: Duisburg
My Country: Germany
Line Voltage: 230VAC 50Hz
Posts: 2,614
Default Re: Acer Aspire 5672WLMi fails to power up

wrong pinout on the fan, creating a short?
__________________
The USA have Barack Obama, Bob Hope, Stevie Wonder and Jonny Cash.
We have Angela Merkel, no hope, no wonder, no cash.
Scenic is offline   Reply With Quote
Old 02-10-2011, 12:03 AM   #7
zedok
New Member
 
Join Date: Feb 2011
Posts: 2
Default Re: Acer Aspire 5672WLMi fails to power up

I dunno, but the fan has the same output volt etc. But it is interesting that, we did it 3-4 days ago. And the laptop didn't start only from yestarday :S
zedok is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 05:09 PM.
Did you find this forum helpful?