Badcaps.net Forum
Go Back   Badcaps Forums > Electronics Theory and Troubleshooting > Troubleshooting Laptops, Portable, and Mobile Devices
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 11-10-2017, 03:34 AM   #21
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

Does anybody know why ME_AC_PRESENT does not go high?
caspian is offline   Reply With Quote
Old 11-11-2017, 07:42 AM   #22
meritosari
Badcaps Veteran
 
meritosari's Avatar
 
Join Date: Oct 2010
City & State: Palangkaraya, Central Kalimantan
My Country: Indonesia
Line Voltage: 220VAC 50Hz
I'm a: Knowledge Seeker
Posts: 719
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

I think could we ignore the signal ME_AC_PRESENT. Just go to check signal 1.5_ON, might be that signal was present after you pressing power button. If yes, then check on Low side mosfet on block 1.5 (pin 4 PQ8301/pin 15 PU8300). Because signal En for controller 1.5VO coming not from SUSC signal. Just guessing, maybe this point was clue the problem.
meritosari is offline   Reply With Quote
Old 11-11-2017, 10:59 AM   #23
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

signal 1.5_ON is not present.
SIO generates RSMRST and 3v_SUS_ON and other signals after pressing the power button.
should be they generated after plugging adapter in before pressing the power button?
caspian is offline   Reply With Quote
Old 11-11-2017, 12:59 PM   #24
meritosari
Badcaps Veteran
 
meritosari's Avatar
 
Join Date: Oct 2010
City & State: Palangkaraya, Central Kalimantan
My Country: Indonesia
Line Voltage: 220VAC 50Hz
I'm a: Knowledge Seeker
Posts: 719
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

What I thought if there's signal premature, seem it not happen. Signal 1.5_ON generated after pressing power button.

Asus X450VP seem as revision of X450CC, as far I know it board almost had problem only with regulator 3V and 5V.

does +12VSUS have correct voltage?
does 3VSUS_PWRGD signal present?
meritosari is offline   Reply With Quote
Old 11-11-2017, 01:30 PM   #25
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

both 12VSUS and 3VSUS_PWRGD are present. may be, this board can not be fixed.
caspian is offline   Reply With Quote
Old 11-13-2017, 11:04 AM   #26
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

I do not know why PM_SUSC is not generated by PCH.
In this laptop, BIOS chip is connected to SIO. SIO reads BIOS, but PCH does not.
Does PCH read BIOS before generating PM_SUSC?
caspian is offline   Reply With Quote
Old 11-13-2017, 11:19 PM   #27
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

does anyone know at which stage PCH reads Bios chip for the first time during startup?
is it S4 , S3 or S0?
caspian is offline   Reply With Quote
Old 11-14-2017, 04:22 PM   #28
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

I need Bios for Asus D452V Laptop.
mainboard model: X450VP REV. 2.1


note1: my original bios in post 1 and 2 are probably damaged, because I tested them and got no result.
note2: I already got bios of mainboard x450cc rev2.1. I tested it. It was good considering SIO but PCH does not turn on. I downloaded it from this thread: https://www.badcaps.net/forum/showpo...13&postcount=2

Last edited by caspian; 11-14-2017 at 04:33 PM..
caspian is offline   Reply With Quote
Old 11-17-2017, 07:04 AM   #29
cacla
Member
 
Join Date: Apr 2015
City & State: Skopje
My Country: Macedonija
I'm a: Professional Tech
Posts: 90
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

try this one and pls sent msg if is ok or not
Attached Files
File Type: zip X450VPF1209.zip (3.51 MB, 2 views)
cacla is offline   Reply With Quote
Old 11-17-2017, 07:24 AM   #30
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

thank you, I will report back tomorrow.
caspian is offline   Reply With Quote
Old 11-18-2017, 12:51 PM   #31
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

I carefully looked at the markings on the laptop. I realized that laptop model is Asus X452CP. So I appreciate if someone uploads bios dump for this laptop:

Laptop model: Asus X452CP
Mainboard model: X450VP REV. 2.1

the original dump is in the first post that does not work.

Last edited by caspian; 11-18-2017 at 01:02 PM..
caspian is offline   Reply With Quote
Old 11-18-2017, 03:35 PM   #32
ala_borbe
aka Donald
 
Join Date: Apr 2011
City & State: Prijedor
My Country: Bosnia and Herzegovina
I'm a: Knowledge Seeker
Posts: 1,383
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

this is your bios
ala_borbe is offline   Reply With Quote
Old 11-18-2017, 03:41 PM   #33
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

thank you. I will program it and report back tomorrow.

Last edited by caspian; 11-18-2017 at 04:19 PM..
caspian is offline   Reply With Quote
Old 11-19-2017, 05:53 AM   #34
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

it did not work because the SIO and the PCH seem faulty.
caspian is offline   Reply With Quote
Old Yesterday, 04:18 PM   #35
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

Now I need boardview for Mainboard model: Asus X450VP REV. 2.1
thanks If someone uploads it.

note: I already got boardview for X450CC, but it is a bit different.

Last edited by caspian; Yesterday at 04:19 PM..
caspian is offline   Reply With Quote
Old Today, 05:04 AM   #36
cacla
Member
 
Join Date: Apr 2015
City & State: Skopje
My Country: Macedonija
I'm a: Professional Tech
Posts: 90
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

Pls sent me picture from sticker with sn on laptop
cacla is offline   Reply With Quote
Old Today, 08:58 AM   #37
caspian
Badcaps Veteran
 
Join Date: Oct 2015
City & State: Mazandaran
My Country: Iran
I'm a: Hobbyist Tech
Posts: 356
Default Re: BIOS for Asus X450VP rev2.1 with ATI graphics

The mainboard was not fixed. I'm gonna replace the mainboard by a new one.
caspian is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2017
Powered by vBulletin ®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 09:39 PM.

Did you find this forum helpful?