Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting TVs and Video Sources
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 09-11-2018, 05:05 PM   #1
dsswhiz
New Member
 
Join Date: Sep 2018
City & State: Alberta
My Country: Canada
I'm a: Knowledge Seeker
Posts: 6
Default Sony Bravia KDL-60R550A- distorted picture

So the story with this set is I got it free as water damaged. When I first got it I had no picture or sound only had backlight. After some troubleshooting and voltage checks, I narrowed it down to a short in the left side of the panel.

i'll list the steps i've done so far.

1) Checked audio with a headphone on audio out jack and got audio.
2) Check the temp of Tcon chip, was ice cold.
3) Disconnected the left side of the panel at the TCON and got the right side to display an image- however the image was slow and distorted.
4)Dissembled the panel and checked the left connector, found a short in one of the ribbon cables. Cleaned and reassembled got the full panel to have a image.
5)Checked audio setting and after changing to Tv speaker got audio going.


So where i'm at is the panel displays image, audio works but image is distored and the image is refreshing extremely show, like extreme slow motion. Seft test returned a two TCON errors but i'm not sure if those errors are from when i had the left panel disconnected or if this is a failed TCON or Mainboard processor. Has anyone seen these symptoms before and what cause it?


https://ibb.co/dDxTLU
https://ibb.co/b5sHEp
https://ibb.co/n7uVZp
https://ibb.co/jgtPup
dsswhiz is offline   Reply With Quote
Old 09-11-2018, 05:32 PM   #2
tvtimmy
Badcaps Veteran
 
Join Date: Mar 2015
City & State: milwaukee,wi
My Country: usa
Line Voltage: 120VAC/60HZ
I'm a: Knowledge Seeker
Posts: 571
Default Re: Sony Bravia KDL-60R550A- distorted picture

I had a 50" version of this tv and it was the panel. Got another that wouldnt start so I replaced the main, power, and tcon and all was good.
tvtimmy is online now   Reply With Quote
Old 09-11-2018, 06:06 PM   #3
dsswhiz
New Member
 
Join Date: Sep 2018
City & State: Alberta
My Country: Canada
I'm a: Knowledge Seeker
Posts: 6
Default Re: Sony Bravia KDL-60R550A- distorted picture

Quote:
Originally Posted by tvtimmy View Post
I had a 50" version of this tv and it was the panel. Got another that wouldnt start so I replaced the main, power, and tcon and all was good.
I'm hoping it not a failed panel, it seems weird that all four segments would fail. Disconnecting each section yielded the same results. I'll see if anyone has any more idea before dumping it.
dsswhiz is offline   Reply With Quote
Old 09-11-2018, 06:12 PM   #4
budwich
Badcaps Veteran
 
Join Date: Jul 2015
City & State: Kanata Ontario
My Country: Canada
I'm a: Knowledge Seeker
Posts: 1,435
Default Re: Sony Bravia KDL-60R550A- distorted picture

your problem is likely a panel issue given the water ingression.
the pictures that you posted are too "busy" to see whats up. If you can input a color bar test signal and you will likely see a highlight on the display of some horizontal lines that shouldn't be there... potentially like your last picture... maybe which shows a "fading line" just about the "checks". Further, another picture appears to show vertical lines down in the corner... but again the display has too much to determine if it is a "hard display issue" or something else (ie. display not updating... a symptom of the panel problem).

The set may be saveable depending on what the actual problem is... that is IF it is only the side.

PS. lots of threads with similar type issues of many sets as the panel usually is the same manufacturer / technique.

Last edited by budwich; 09-11-2018 at 06:14 PM..
budwich is offline   Reply With Quote
Old 09-12-2018, 07:43 PM   #5
dsswhiz
New Member
 
Join Date: Sep 2018
City & State: Alberta
My Country: Canada
I'm a: Knowledge Seeker
Posts: 6
Default Re: Sony Bravia KDL-60R550A- distorted picture

Quote:
Originally Posted by budwich View Post
your problem is likely a panel issue given the water ingression.
the pictures that you posted are too "busy" to see whats up. If you can input a color bar test signal and you will likely see a highlight on the display of some horizontal lines that shouldn't be there... potentially like your last picture... maybe which shows a "fading line" just about the "checks". Further, another picture appears to show vertical lines down in the corner... but again the display has too much to determine if it is a "hard display issue" or something else (ie. display not updating... a symptom of the panel problem).

The set may be saveable depending on what the actual problem is... that is IF it is only the side.

PS. lots of threads with similar type issues of many sets as the panel usually is the same manufacturer / technique.
So update with a colour bar screen test, cant really see any lines but not sure what am looking for. The colour bleed is from the slow image. Still cant get any change by pressing the bond tabs. I know it seems like a panel failure but what has me scratching my head is how is it affecting the whole screen and not just the damaged section. Am i wrong to think each half of the screen is Isolated when the ribbon cable is disconnected at the TCON? Has anyone tried fixing one of these panels? I have access to a digital microscope. If replacing the tab could fix it i might have a go at it.

https://ibb.co/ddz9Up

Last edited by dsswhiz; 09-12-2018 at 07:45 PM..
dsswhiz is offline   Reply With Quote
Old 09-13-2018, 06:33 AM   #6
budwich
Badcaps Veteran
 
Join Date: Jul 2015
City & State: Kanata Ontario
My Country: Canada
I'm a: Knowledge Seeker
Posts: 1,435
Default Re: Sony Bravia KDL-60R550A- distorted picture

ok... if I see the "still picture" correctly... you can see that there is a mid section where there is a shift in the "timing" such that it appears to "time delayed". That portion has a tab this is impacted such the applied signal shows up just a bit late causing the shift. In your case it is a significant section, not just a line, as a result it is having major impact on the rest of the display timing.

As indicated, there are numerous threads about this type of failure. It is likely that this sony uses a sharp panel which have a common failure with or without watering... :-)

Anyways, post a good picture of the lower corner of the panel which shows how the panel is connected to the lower / bottom edge boards (note that depending on the build, it might actually be on the top instead). Similarly, post a picture of the side of the panel which hopefully shows the bonded tabs and if there are any edge boards along the side (may or may not be)... go from there. Your problem is on the left side of the screen and possibly the lower corner(s).

One other question: is there multiple edge boards along the bottom .... that is more than 2 (ie. one per "side")... if there are more than one per side, they are interconnected by a "u" like flat ribbon that is unclampable. IF so, you can unclamp said ribbon and see if that changes the results... this test isolates the side that is no longer connected for signals and may tell you more about your problem area.

PS... in terms of what to look for, feed that same "static test pattern" into a normal set / display and you quickly see where there is issues.

Last edited by budwich; 09-13-2018 at 07:14 AM..
budwich is offline   Reply With Quote
Old 09-13-2018, 05:03 PM   #7
dsswhiz
New Member
 
Join Date: Sep 2018
City & State: Alberta
My Country: Canada
I'm a: Knowledge Seeker
Posts: 6
Default Re: Sony Bravia KDL-60R550A- distorted picture

Quote:
Originally Posted by budwich View Post
ok... if I see the "still picture" correctly... you can see that there is a mid section where there is a shift in the "timing" such that it appears to "time delayed". That portion has a tab this is impacted such the applied signal shows up just a bit late causing the shift. In your case it is a significant section, not just a line, as a result it is having major impact on the rest of the display timing.

As indicated, there are numerous threads about this type of failure. It is likely that this sony uses a sharp panel which have a common failure with or without watering... :-)

Anyways, post a good picture of the lower corner of the panel which shows how the panel is connected to the lower / bottom edge boards (note that depending on the build, it might actually be on the top instead). Similarly, post a picture of the side of the panel which hopefully shows the bonded tabs and if there are any edge boards along the side (may or may not be)... go from there. Your problem is on the left side of the screen and possibly the lower corner(s).

One other question: is there multiple edge boards along the bottom .... that is more than 2 (ie. one per "side")... if there are more than one per side, they are interconnected by a "u" like flat ribbon that is unclampable. IF so, you can unclamp said ribbon and see if that changes the results... this test isolates the side that is no longer connected for signals and may tell you more about your problem area.

PS... in terms of what to look for, feed that same "static test pattern" into a normal set / display and you quickly see where there is issues.
Thanks budwich, your input is greatly appreciated. I follow up with more pictures. If this is going to be a scrap i might try to see if i can rework these connectors. The panel is a "Sharp JE600D3LC5N" Only bonding tabs i see are at the bottom which connects to the driver boards 8 in total. The tabs on the side arent connected to a board they just hang there. I'lll post up pictures.

Last edited by dsswhiz; 09-13-2018 at 05:07 PM..
dsswhiz is offline   Reply With Quote
Old 09-14-2018, 07:26 AM   #8
JDC
Badcaps Veteran
 
Join Date: May 2015
City & State: Wheeling, WV
My Country: USA
I'm a: Hobbyist Tech
Posts: 209
Default Re: Sony Bravia KDL-60R550A- distorted picture

Sony KDLs in my opinion are mostly panel issues. As soon as a customer says KDL I cringe.
JDC is offline   Reply With Quote
Old 09-14-2018, 07:42 AM   #9
budwich
Badcaps Veteran
 
Join Date: Jul 2015
City & State: Kanata Ontario
My Country: Canada
I'm a: Knowledge Seeker
Posts: 1,435
Default Re: Sony Bravia KDL-60R550A- distorted picture

with the water ingression, you may be fighting a losing battle. Because there are no side edge boards, there is no easy way to isolate the side tabs to see if things improve. further, water doesn't necessarily have to cause an issue with the tabs as it can ingress anywhere along the edge of the panel which is layered and leave "deposits" when dried.

one thing you can try is "fire up" the set and then use your "touch" to see if you can detect any of the side tabs being hotter than others as that is one sign that things around that tab are not happy. Of course, be careful playing with tabs as the bonding isn't the strongest, hence issues on many panel fronts.

Last edited by budwich; 09-14-2018 at 07:43 AM..
budwich is offline   Reply With Quote
Old 09-14-2018, 01:46 PM   #10
jjanssen7
Senior Member
 
Join Date: Nov 2012
City & State: Chilliwack, BC
My Country: Canada
I'm a: Knowledge Seeker
Posts: 107
Default Re: Sony Bravia KDL-60R550A- distorted picture

Tconn error count of 2 also indicates a possible panel problem. I'd look very closely at the bottom ribbons and driver board on the panel for corrosion give the water damage history.
jjanssen7 is offline   Reply With Quote
Old 09-14-2018, 06:40 PM   #11
Davi.p
Badcaps Veteran
 
Join Date: Sep 2009
City & State: Milan
My Country: Italy
Line Voltage: 230Vac 50Hz
I'm a: Hobbyist Tech
Posts: 1,203
Default Re: Sony Bravia KDL-60R550A- distorted picture

i had a similar issue on a big Sony, are you happy to experiment? There are some long passes to do. if you are unfamiliar with electronics repair then.. leave it to more expert users, please.. if not i can tell you the steps, but keep in mind them are experiments, no warranty of success..!
Davi.p is offline   Reply With Quote
Old 09-15-2018, 10:03 PM   #12
dsswhiz
New Member
 
Join Date: Sep 2018
City & State: Alberta
My Country: Canada
I'm a: Knowledge Seeker
Posts: 6
Default Re: Sony Bravia KDL-60R550A- distorted picture

Quote:
Originally Posted by Davi.p View Post
i had a similar issue on a big Sony, are you happy to experiment? There are some long passes to do. if you are unfamiliar with electronics repair then.. leave it to more expert users, please.. if not i can tell you the steps, but keep in mind them are experiments, no warranty of success..!
My next step is to check if i have the correct voltages at each bond tab on the board. I'm good with electronics repair. my next step is to try tese steps https://www.youtube.com/watch?v=9UrTVEC5LkA&t=119s

But Davi if you have something in mind let me know, but a big deal if it gets screwed. The panel is already almost dead.
dsswhiz is offline   Reply With Quote
Old 09-16-2018, 12:57 AM   #13
Davi.p
Badcaps Veteran
 
Join Date: Sep 2009
City & State: Milan
My Country: Italy
Line Voltage: 230Vac 50Hz
I'm a: Hobbyist Tech
Posts: 1,203
Default Re: Sony Bravia KDL-60R550A- distorted picture

First thing to do is to test the screen by connecting the tcon>panel flat cable one at a time to see if you have a combination where you see half image of good quality, the the other one is the faulty side as probably you have some gate drivers that are not working and make the work harder for the drivers of the good side. Then save the content of the tcon's eeprom, this for safety reasons.. next step is to locate the VCC of the cofs, i need an hires shiny picture of the tcon, silkscreens well visible, i can help you identify it. It is most likely a 3,3v or 1,8v that goes to the panel. Then when you found it, trace it to the panel where it enters the last COF of the fault side, it enters in many points, you have tu cut the lines where VCC enters the tab but passes through without entering the chip (COF) ie on the side traces of the tab that flows directly to the glass and then to the vertical COFS. Now switch on the tv with all the flat cables attached, probably the tv can self shut off for protection, now switch it fully off. Then join the cut traces, retest the tv and let me know what it does..
Davi.p is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2018
Powered by vBulletin ®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 03:34 PM.

Did you find this forum helpful?