Badcaps.net Forum
Go Back   Badcaps Forums > Troubleshooting Hardware & Devices and Electronics Theory > Troubleshooting Computer Displays
Register FAQ Calendar Search Today's Posts Mark Forums Read

 
Thread Tools Display Modes
Old 04-18-2017, 03:10 PM   #21
eaarnoudse
Erwin Aarnoudse
 
Join Date: Mar 2016
City & State: Rijnsburg
My Country: The Netherlands
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 26
Default Re: HP ZR2440w backlight cutting out

The type number of the LED driver chip is OZ9907GN. I also have the problems mentioned above with this monitor type. I read perfect values on the power supply (5V/12V) and the monitor works perfect when I disconnect the flex cable to the LED backlight first. The blue power light is up and running and after 10 seconds, the monitor goes into standby mode and the yellow light turns on. I read 75V on one of the pins of the flex cable wires and the BLON signal cable reads 3.3V. When I connect the flex cable, the monitor doesn't turn on, the power light is off, BLON=0V.

I suspect a faulty LED backlight strip, or maybe something is wrong with the IC. It's a pity that nobody fixed this problem yet...
eaarnoudse is offline   Reply With Quote
Old 04-18-2017, 05:49 PM   #22
eaarnoudse
Erwin Aarnoudse
 
Join Date: Mar 2016
City & State: Rijnsburg
My Country: The Netherlands
Line Voltage: 230VAC 50Hz
I'm a: Knowledge Seeker
Posts: 26
Default Re: HP ZR2440w backlight cutting out

I did some additional investigation of the power supply and it seems like that the LED driver IC and the LED strips in the panel are OK. I found something really weird in the primary part of the power supply. When I connect all boards and cables and I switch on the monitor, it stays dead. Ok, here is the trick. When I HOVER my screwdriver over the PWM IC (OZ531GN), the monitor and the LED backlight turn on. It looks like there is some capacitive "sensing" that activates the IC and the rest of the circuit. I will try to measure the circuit with my oscilliscope later this week.
Attached Images
File Type: jpg 20170419_004612.jpg (862.4 KB, 18 views)
File Type: jpg 20170419_004824.jpg (751.6 KB, 18 views)
File Type: jpg 20170419_004607.jpg (850.4 KB, 16 views)
eaarnoudse is offline   Reply With Quote
Old 04-29-2017, 04:58 PM   #23
cmg
Member
 
Join Date: Dec 2016
City & State: London
My Country: United Kingdom
I'm a: Knowledge Seeker
Posts: 31
Default Re: HP ZR2440w backlight cutting out

Ginko - you have a very similar problem and circuit to the one i am trying to diagnose. From your pics I can see the ZR2440W is like a cutdown version of the 2740 that I have. Probably they've used the same controller ICs.

Please try altering the brightness on the front panel control and see if it becomes stable at high brightness. I wasn't clear from the above if you tried swapping the LCD panel (i.e. including the backlights) from one of your good monitors into the bad monitor. That way you can tell if it is the LEDs or not. From what you described i guess this is not your problem. I have had one of these with one the LEDs strips open circuit and it causes the monitor to shutoff completely.

My suggestions are:
- check for dry joints in the LIVE circuit. Some look odd in the photo but i guess that is just reflections.
- read the part number on I801, see if it is the same as mine; it could be UCC25600 which is an SMPS controller. I have linked the docs for this on my thread. One good thing about that is its only $1 or $2 and you can buy it direct from TI.
- look at the signal on the isolated side of the opto-isolator I803 with a scope. I can't make out if the circuit on the driving side of that is like mine or not. You are looking to see if this is stable or not. Try adjusting the brightness from min to max while checking this. You can compare vs mine to see if the symptoms seem the same.
- look at the signal on Vadj of P803. It should be a PWM waveform at mid brightness, 5V DC at max brightness and 0V at min.
- compare readings between the good & bad PSUs. You can do both for resistance/capacitance as well as the voltage readings.

Measuring voltages on the Live side is dangerous as there are lethal voltages in that circuit and the ground is not isolated.
I reckon your problem is around I801 but you should only try measuring voltages around it if you are used to working on high voltage circuits. Aside from the safety, it if difficult since it is not isolated so you cannot use a mains-powered scope to measure the details of the circuit around I801. I have used the scope to look at the high voltage lines. My multimeter has a nice function which is that it has a bargraph. I have found that useful for measuring the SMPS circuit. As mine is flickering at a failrly slow rate (5-10Hz) it is visible on this bargraph. To take any measure measurements on this live side i have:
- left the PSU PCB bolted into the chassis but just exposed the solder-side
- soldered short wires onto the places i wanted to measure and then attached the meter or scope to these so i dont need to poke around while its on.
- stand back and ensure the monitor is unplugged from the mains immediately after. In mine there is still 320V in the PSU when the monitor is on standby.

I still havent solved mine. It is really difficult, because it manifests itself as an instability in the whole circuit, through the current-sense feedback loop. I am now thinking it is in the PFC circuit but your monitor doesn't have that - looks like it just rectifies the mains and feeds this into the SMPS circuit. Mine has another controller before this which looks like it is playing up to me. Will update my thread on this.

Best of luck and stay safe.
cmg is offline   Reply With Quote
Old 05-15-2019, 03:06 PM   #24
NBel
New Member
 
Join Date: May 2016
City & State: Chisinau
My Country: Moldova
I'm a: Knowledge Seeker
Posts: 1
Default Re: HP ZR2440w backlight cutting out

Hi, had the same monitor with very dark backlight, mine problem was with cracked pcb copper on the pads near the backlight flex connector on the power supply. As seen on some photoes, they are tinned one some boards, but mine were not. Just soldered them and backlight works)
Hope this helps somebody)
NBel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Badcaps.net Technical Forums 2003 - 2019
Powered by vBulletin ®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
All times are GMT -6. The time now is 07:15 AM.
Did you find this forum helpful?